Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/сопоставление и перенос данных с листа1 на лист2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сопоставление и перенос данных с листа1 на лист2 (Формулы/Formulas)
сопоставление и перенос данных с листа1 на лист2
19kip Дата: Четверг, 10.08.2017, 10:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
добрый день.
помогите решить маленькую задачу (лучше формулами или функцией, если это возможно)
В лист 1 вставить данные с листа 2 если столбцы A совпадают, если в листе 2 нет такого значения, то в листе 1 они просто не заполняются.
спасибо
К сообщению приложен файл: 6148119.xlsx(11Kb)
 
Ответить
Сообщениедобрый день.
помогите решить маленькую задачу (лучше формулами или функцией, если это возможно)
В лист 1 вставить данные с листа 2 если столбцы A совпадают, если в листе 2 нет такого значения, то в листе 1 они просто не заполняются.
спасибо

Автор - 19kip
Дата добавления - 10.08.2017 в 10:11
and_evg Дата: Четверг, 10.08.2017, 10:16 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 159
Репутация: 31 ±
Замечаний: 0% ±

Excel 2007
Добрый :D
Код
=ЕСЛИОШИБКА(ВПР(A1;Лист2!$A$1:$B$30;2;);"")
К сообщению приложен файл: 8202596.xlsx(13Kb)


Сообщение отредактировал and_evg - Четверг, 10.08.2017, 10:16
 
Ответить
СообщениеДобрый :D
Код
=ЕСЛИОШИБКА(ВПР(A1;Лист2!$A$1:$B$30;2;);"")

Автор - and_evg
Дата добавления - 10.08.2017 в 10:16
китин Дата: Четверг, 10.08.2017, 10:17 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4280
Репутация: 665 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вам доброго!
как то так
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!B$1:B$30;ПОИСКПОЗ(Лист1!$A1;Лист2!$A$1:$A$30;0));"")
К сообщению приложен файл: 19kip.xlsx(14Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 10.08.2017, 10:18
 
Ответить
Сообщениеи вам доброго!
как то так
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!B$1:B$30;ПОИСКПОЗ(Лист1!$A1;Лист2!$A$1:$A$30;0));"")

Автор - китин
Дата добавления - 10.08.2017 в 10:17
_Boroda_ Дата: Четверг, 10.08.2017, 10:54 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 4564 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ну и еще вариант
Код
=СУММЕСЛИ(Лист2!A$1:A$30;A1;Лист2!B$1:B$30)

Нули можно скрыть форматом ячеек
Основной;;
К сообщению приложен файл: 6148119_1.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНу и еще вариант
Код
=СУММЕСЛИ(Лист2!A$1:A$30;A1;Лист2!B$1:B$30)

Нули можно скрыть форматом ячеек
Основной;;

Автор - _Boroda_
Дата добавления - 10.08.2017 в 10:54
19kip Дата: Четверг, 10.08.2017, 11:08 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
большое спасибо
 
Ответить
Сообщениебольшое спасибо

Автор - 19kip
Дата добавления - 10.08.2017 в 11:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сопоставление и перенос данных с листа1 на лист2 (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!