Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчёт прибыли за месяц (выборка по дате из списка) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт прибыли за месяц (выборка по дате из списка) (Формулы/Formulas)
Расчёт прибыли за месяц (выборка по дате из списка)
maksis Дата: Четверг, 10.08.2017, 12:15 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго здравия! Прошу помощи в создании простой формулы для Вас,простите дилетанта :D
Необходим подсчёт суммы прибыли за календарный месяц с учетом столбца в котором содержится дата продажи.
Благодарен всем за ответ! :)
К сообщению приложен файл: 1346422.xlsx(10Kb)
 
Ответить
СообщениеДоброго здравия! Прошу помощи в создании простой формулы для Вас,простите дилетанта :D
Необходим подсчёт суммы прибыли за календарный месяц с учетом столбца в котором содержится дата продажи.
Благодарен всем за ответ! :)

Автор - maksis
Дата добавления - 10.08.2017 в 12:15
китин Дата: Четверг, 10.08.2017, 12:21 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4280
Репутация: 665 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вам не хворать
как то так
Код
=СУММПРОИЗВ($C$2:$C$11*(ТЕКСТ($D$2:$D$11;"МММ.ГГ")=ТЕКСТ($F5;"МММ.ГГ")))
К сообщению приложен файл: maksis.xlsx(11Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 10.08.2017, 12:22
 
Ответить
Сообщениеи вам не хворать
как то так
Код
=СУММПРОИЗВ($C$2:$C$11*(ТЕКСТ($D$2:$D$11;"МММ.ГГ")=ТЕКСТ($F5;"МММ.ГГ")))

Автор - китин
Дата добавления - 10.08.2017 в 12:21
buchlotnik Дата: Четверг, 10.08.2017, 12:22 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2866
Репутация: 806 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
можно и формулой типа
Код
=СУММПРОИЗВ((ТЕКСТ(F5;"ММГГ")=ТЕКСТ($D$2:$D$11;"ММГГ"))*$C$2:$C$11)
, но я бы сводной делал
К сообщению приложен файл: 6284716.xlsx(16Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениеможно и формулой типа
Код
=СУММПРОИЗВ((ТЕКСТ(F5;"ММГГ")=ТЕКСТ($D$2:$D$11;"ММГГ"))*$C$2:$C$11)
, но я бы сводной делал

Автор - buchlotnik
Дата добавления - 10.08.2017 в 12:22
китин Дата: Четверг, 10.08.2017, 12:23 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4280
Репутация: 665 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]
можно и формулой типа

списал да? :D :D :D :D :D :D :D :D :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]
можно и формулой типа

списал да? :D :D :D :D :D :D :D :D :D

Автор - китин
Дата добавления - 10.08.2017 в 12:23
Nic70y Дата: Четверг, 10.08.2017, 12:23 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4045
Репутация: 861 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММЕСЛИМН(C$2:C$9;D$2:D$9;">="&F5;D$2:D$9;"<="&КОНМЕСЯЦА(F5;0))
К сообщению приложен файл: 3895655.xlsx(10Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММЕСЛИМН(C$2:C$9;D$2:D$9;">="&F5;D$2:D$9;"<="&КОНМЕСЯЦА(F5;0))

Автор - Nic70y
Дата добавления - 10.08.2017 в 12:23
buchlotnik Дата: Четверг, 10.08.2017, 12:24 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2866
Репутация: 806 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
[offtop]
Цитата
списал
вообще-то сократил, ажно на 5 символов и сводную примотать успел :p


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщение[offtop]
Цитата
списал
вообще-то сократил, ажно на 5 символов и сводную примотать успел :p

Автор - buchlotnik
Дата добавления - 10.08.2017 в 12:24
maksis Дата: Четверг, 10.08.2017, 12:31 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо други! Отлично все выходит! hands hands
 
Ответить
СообщениеСпасибо други! Отлично все выходит! hands hands

Автор - maksis
Дата добавления - 10.08.2017 в 12:31
_Boroda_ Дата: Четверг, 10.08.2017, 12:35 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 4564 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
сократил, ажно на 5 символов

А почему не на 13? :D :D


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
сократил, ажно на 5 символов

А почему не на 13? :D :D

Автор - _Boroda_
Дата добавления - 10.08.2017 в 12:35
buchlotnik Дата: Четверг, 10.08.2017, 12:57 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2866
Репутация: 806 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
почему не на 13?
потому что поторопился, можно и на 14
Код
=СУММ((F5<=D$2:D$11)*(D$2:D$11<=КОНМЕСЯЦА(F5;0))*C$2:C$11)
и даже на 17
Код
=СУММ((F5<=D$2:D$11)*(D$2:D$11<ДАТАМЕС(F5;1))*C$2:C$11)
:p


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 10.08.2017, 13:14
 
Ответить
Сообщение
Цитата
почему не на 13?
потому что поторопился, можно и на 14
Код
=СУММ((F5<=D$2:D$11)*(D$2:D$11<=КОНМЕСЯЦА(F5;0))*C$2:C$11)
и даже на 17
Код
=СУММ((F5<=D$2:D$11)*(D$2:D$11<ДАТАМЕС(F5;1))*C$2:C$11)
:p

Автор - buchlotnik
Дата добавления - 10.08.2017 в 12:57
_Boroda_ Дата: Четверг, 10.08.2017, 14:17 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 4564 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Нееее, ничего принципиально не меняя. СУММПРОИЗВ должно остаться и ТЕКСТ тоже. Чтобы можно было сказать "Списал"


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНееее, ничего принципиально не меняя. СУММПРОИЗВ должно остаться и ТЕКСТ тоже. Чтобы можно было сказать "Списал"

Автор - _Boroda_
Дата добавления - 10.08.2017 в 14:17
buchlotnik Дата: Четверг, 10.08.2017, 14:43 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2866
Репутация: 806 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Так что ли?
Код
=СУММПРОИЗВ(C$2:C$11*(ТЕКСТ(D$2:D$11;"ГМ")=ТЕКСТ(F5;"ГМ")))


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
СообщениеТак что ли?
Код
=СУММПРОИЗВ(C$2:C$11*(ТЕКСТ(D$2:D$11;"ГМ")=ТЕКСТ(F5;"ГМ")))

Автор - buchlotnik
Дата добавления - 10.08.2017 в 14:43
_Boroda_ Дата: Четверг, 10.08.2017, 14:56 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 4564 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Колдун! Опять списал! :D :D :D


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеКолдун! Опять списал! :D :D :D

Автор - _Boroda_
Дата добавления - 10.08.2017 в 14:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт прибыли за месяц (выборка по дате из списка) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!