Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск максимального значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск максимального значения (Формулы/Formulas)
Поиск максимального значения
fr0st Дата: Пятница, 11.08.2017, 09:39 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Суть такая, есть колонка Знач. F и Результат, в колонке Знач. F указаны значения с шагом 0.01, а в колонке Результат происходит расчет по формуле. Задача следующая нужно в ячейки с желтой заливкой в Ячейке Результат (L5) указать максимальное значение полученное по формуле из колонки С и в ячейке (К5) указать значение из колонки В соответствующее максимальному значению результата. Файл прикладываю.
К сообщению приложен файл: 2784694.xlsx(11Kb)
 
Ответить
СообщениеСуть такая, есть колонка Знач. F и Результат, в колонке Знач. F указаны значения с шагом 0.01, а в колонке Результат происходит расчет по формуле. Задача следующая нужно в ячейки с желтой заливкой в Ячейке Результат (L5) указать максимальное значение полученное по формуле из колонки С и в ячейке (К5) указать значение из колонки В соответствующее максимальному значению результата. Файл прикладываю.

Автор - fr0st
Дата добавления - 11.08.2017 в 09:39
Karataev Дата: Пятница, 11.08.2017, 09:45 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 889
Репутация: 335 ±
Замечаний: 0% ±

Excel
для "K5":
Код
=ИНДЕКС(B:B;ПОИСКПОЗ(L5;C:C;0);1)

для "L5":
Код
=МАКС(C:C)
К сообщению приложен файл: 3524587.xlsx(11Kb)


 
Ответить
Сообщениедля "K5":
Код
=ИНДЕКС(B:B;ПОИСКПОЗ(L5;C:C;0);1)

для "L5":
Код
=МАКС(C:C)

Автор - Karataev
Дата добавления - 11.08.2017 в 09:45
_Boroda_ Дата: Пятница, 11.08.2017, 09:45 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11512
Репутация: 4736 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=МАКС(C3:C102)

Код
=ИНДЕКС(B3:B102;ПОИСКПОЗ(L5;C3:C102;))

или
Код
=СУММПРОИЗВ(B3:B102*(C3:C102=L5))


С учетом формулы в столбце С
Код
=ЕСЛИ(ЗНАК($F4*$G4)>0;B3;B102)
К сообщению приложен файл: 2784694_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=МАКС(C3:C102)

Код
=ИНДЕКС(B3:B102;ПОИСКПОЗ(L5;C3:C102;))

или
Код
=СУММПРОИЗВ(B3:B102*(C3:C102=L5))


С учетом формулы в столбце С
Код
=ЕСЛИ(ЗНАК($F4*$G4)>0;B3;B102)

Автор - _Boroda_
Дата добавления - 11.08.2017 в 09:45
fr0st Дата: Пятница, 11.08.2017, 21:51 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Спасибо Вам за помощь.
 
Ответить
СообщениеСпасибо Вам за помощь.

Автор - fr0st
Дата добавления - 11.08.2017 в 21:51
fr0st Дата: Суббота, 12.08.2017, 09:16 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
У меня такой вопрос, а как сделать если у меня большое количество значений в колонке Сделка и Убыток, для каждого значения делать отдельную колонку Знач F и Результат, не очень удобно, может есть какое решение?
 
Ответить
СообщениеУ меня такой вопрос, а как сделать если у меня большое количество значений в колонке Сделка и Убыток, для каждого значения делать отдельную колонку Знач F и Результат, не очень удобно, может есть какое решение?

Автор - fr0st
Дата добавления - 12.08.2017 в 09:16
Karataev Дата: Суббота, 12.08.2017, 09:25 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 889
Репутация: 335 ±
Замечаний: 0% ±

Excel
fr0st, на первый взгляд вопрос не связан с темой, решение по данной теме найдено. Поэтому наверное правильнее Вам создать новую тему.
И сделайте файл пример, т.к. не понятна связь между столбцами F:G и K:L.




Сообщение отредактировал Karataev - Суббота, 12.08.2017, 09:27
 
Ответить
Сообщениеfr0st, на первый взгляд вопрос не связан с темой, решение по данной теме найдено. Поэтому наверное правильнее Вам создать новую тему.
И сделайте файл пример, т.к. не понятна связь между столбцами F:G и K:L.

Автор - Karataev
Дата добавления - 12.08.2017 в 09:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск максимального значения (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!