Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества данных по нескольким критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества данных по нескольким критериям (Формулы/Formulas)
Подсчет количества данных по нескольким критериям
Allexsin Дата: Вторник, 12.09.2017, 18:25 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем доброго время суток!
Возник вопрос по подсчету данных находящихся в массиве данных по нескольким критериям.
Суть задачи. Необходимо посчитать сколько раз встречается в массиве значения относящиеся к пункту 1 (строка) и т.д. и к отпр. (столбец) и т.д.
Что-то по функции "счётесли" не получается. Прилагаю файл с материалом. Заранее благодарю.
К сообщению приложен файл: 6257193.xlsx(19Kb)
 
Ответить
СообщениеВсем доброго время суток!
Возник вопрос по подсчету данных находящихся в массиве данных по нескольким критериям.
Суть задачи. Необходимо посчитать сколько раз встречается в массиве значения относящиеся к пункту 1 (строка) и т.д. и к отпр. (столбец) и т.д.
Что-то по функции "счётесли" не получается. Прилагаю файл с материалом. Заранее благодарю.

Автор - Allexsin
Дата добавления - 12.09.2017 в 18:25
Che79 Дата: Вторник, 12.09.2017, 18:46 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 465
Репутация: 73 ±
Замечаний: 0% ±

Excel 2010 RUS
Allexsin, здравствуйте. Так нужно?
Код
=СЧЁТЕСЛИМН($B2:$AI2;"<>";$B$1:$AI$1;AL$1)
Код
=СУММПРОИЗВ(($B2:$AI2<>"")*($B$1:$AI$1=AL$1))
формула массива
Код
{=СЧЁТ(ЕСЛИ($B2:$AI2;ЕСЛИ($B$1:$AI$1=AL$1;)))}
К сообщению приложен файл: 6257193_1.xlsx(24Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Вторник, 12.09.2017, 18:58
 
Ответить
СообщениеAllexsin, здравствуйте. Так нужно?
Код
=СЧЁТЕСЛИМН($B2:$AI2;"<>";$B$1:$AI$1;AL$1)
Код
=СУММПРОИЗВ(($B2:$AI2<>"")*($B$1:$AI$1=AL$1))
формула массива
Код
{=СЧЁТ(ЕСЛИ($B2:$AI2;ЕСЛИ($B$1:$AI$1=AL$1;)))}

Автор - Che79
Дата добавления - 12.09.2017 в 18:46
TimSha Дата: Вторник, 12.09.2017, 18:55 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 522
Репутация: 82 ±
Замечаний: 0% ±

Excel 2013 Pro +
Что-то по функции "счётесли" не получается

Берем более современную -
Код
=СЧЁТЕСЛИМН($B$1:$AI$1;AL$1;$B2:$AI2;">"&0)


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
Сообщение
Что-то по функции "счётесли" не получается

Берем более современную -
Код
=СЧЁТЕСЛИМН($B$1:$AI$1;AL$1;$B2:$AI2;">"&0)

Автор - TimSha
Дата добавления - 12.09.2017 в 18:55
_Boroda_ Дата: Вторник, 12.09.2017, 20:23 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11327
Репутация: 4676 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще массивный вариант (формула вводится одновременным нажатием Контрл Шифт Ентер)
Код
=СЧЁТ(1/($B$1:$AI$1=AL$1)/$B2:$AI2)
К сообщению приложен файл: 6257193_2.xlsx(22Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще массивный вариант (формула вводится одновременным нажатием Контрл Шифт Ентер)
Код
=СЧЁТ(1/($B$1:$AI$1=AL$1)/$B2:$AI2)

Автор - _Boroda_
Дата добавления - 12.09.2017 в 20:23
Allexsin Дата: Вторник, 12.09.2017, 20:59 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем спасибо!
 
Ответить
СообщениеВсем спасибо!

Автор - Allexsin
Дата добавления - 12.09.2017 в 20:59
Allexsin Дата: Вторник, 12.09.2017, 21:22 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Формулы работают, но не совсем так. Одним из критериев подсчетов должны быть значения (1, 2, 3, ....) в столбце "пункт", т.е. поиск и подсчет должен выполнятся не только по "приб." и "отправ", но и по строкам. К примеру ссылка из формулы должно ссылаться на ячейки в столбце "Пункт". Если возможно так сделать.
 
Ответить
СообщениеФормулы работают, но не совсем так. Одним из критериев подсчетов должны быть значения (1, 2, 3, ....) в столбце "пункт", т.е. поиск и подсчет должен выполнятся не только по "приб." и "отправ", но и по строкам. К примеру ссылка из формулы должно ссылаться на ячейки в столбце "Пункт". Если возможно так сделать.

Автор - Allexsin
Дата добавления - 12.09.2017 в 21:22
Che79 Дата: Вторник, 12.09.2017, 21:34 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 465
Репутация: 73 ±
Замечаний: 0% ±

Excel 2010 RUS
не совсем понял, но, может, так?
Код
=СУММПРОИЗВ(($B2:$AI2<>"")*($B$1:$AI$1=AL$1)*($A$2:$A$43=$A2))
Правда, не понятен глобальный смысл. Если не угадал, нарисуйте в файле вручную желаемый результат - как должно быть правильно.


Делай нормально и будет нормально!
 
Ответить
Сообщениене совсем понял, но, может, так?
Код
=СУММПРОИЗВ(($B2:$AI2<>"")*($B$1:$AI$1=AL$1)*($A$2:$A$43=$A2))
Правда, не понятен глобальный смысл. Если не угадал, нарисуйте в файле вручную желаемый результат - как должно быть правильно.

Автор - Che79
Дата добавления - 12.09.2017 в 21:34
gling Дата: Вторник, 12.09.2017, 21:42 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1621
Репутация: 394 ±
Замечаний: 0% ±

2010
Может так?
Код
=СЧЁТЕСЛИМН($B$1:$AI$1;AL$1;ИНДЕКС($B$2:$AI$43;ПОИСКПОЗ($AK2;$A2:$A43;););">0")
Или так
Код
=СУММПРОИЗВ(($A$2:$A$43=AK2)*($B$1:$AI$1=AL1)*($B$2:$AI$43>0))
если в столбце "Пункт" будет повторяться.
Файл заменил.
К сообщению приложен файл: 3637752.xlsx(21Kb)


Сообщение отредактировал gling - Вторник, 12.09.2017, 21:55
 
Ответить
СообщениеМожет так?
Код
=СЧЁТЕСЛИМН($B$1:$AI$1;AL$1;ИНДЕКС($B$2:$AI$43;ПОИСКПОЗ($AK2;$A2:$A43;););">0")
Или так
Код
=СУММПРОИЗВ(($A$2:$A$43=AK2)*($B$1:$AI$1=AL1)*($B$2:$AI$43>0))
если в столбце "Пункт" будет повторяться.
Файл заменил.

Автор - gling
Дата добавления - 12.09.2017 в 21:42
Allexsin Дата: Вторник, 12.09.2017, 21:51 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Все работает! Большое спасибо!
 
Ответить
СообщениеВсе работает! Большое спасибо!

Автор - Allexsin
Дата добавления - 12.09.2017 в 21:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества данных по нескольким критериям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!