Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Число, входящее в промежуток - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Число, входящее в промежуток (Формулы/Formulas)
Число, входящее в промежуток
ПАМ Дата: Среда, 13.09.2017, 11:05 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 118
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте уважаемые Профи!
Подскажите пожалуйста как мне сделать в экселе, чтобы при вводе данных от (ячейка A) до (ячейки B) входит в правильный ответ (ячейка С), то в ячейке D Выигрыш, а если нет то Проигрыш.
Заранее СПАСИБО большое. Надеюсь, я четко объяснил.

P.S. прошу прощения, если тема названа некорректно.
К сообщению приложен файл: 5750779.xls(23Kb)
 
Ответить
СообщениеЗдравствуйте уважаемые Профи!
Подскажите пожалуйста как мне сделать в экселе, чтобы при вводе данных от (ячейка A) до (ячейки B) входит в правильный ответ (ячейка С), то в ячейке D Выигрыш, а если нет то Проигрыш.
Заранее СПАСИБО большое. Надеюсь, я четко объяснил.

P.S. прошу прощения, если тема названа некорректно.

Автор - ПАМ
Дата добавления - 13.09.2017 в 11:05
Karataev Дата: Среда, 13.09.2017, 11:08 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 902
Репутация: 337 ±
Замечаний: 0% ±

Excel
Формула для "D2":
Код
=ЕСЛИ(И(C2>=A2;C2<=B2);"Выигрыш";"Проигрыш")


 
Ответить
СообщениеФормула для "D2":
Код
=ЕСЛИ(И(C2>=A2;C2<=B2);"Выигрыш";"Проигрыш")

Автор - Karataev
Дата добавления - 13.09.2017 в 11:08
buchlotnik Дата: Среда, 13.09.2017, 11:10 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3328
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Код
=ЕСЛИ((C2>=A2)*(C2<=B2);"Выйгрыш";"Проигрыш")
К сообщению приложен файл: 5503019.xls(24Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщение
Код
=ЕСЛИ((C2>=A2)*(C2<=B2);"Выйгрыш";"Проигрыш")

Автор - buchlotnik
Дата добавления - 13.09.2017 в 11:10
ПАМ Дата: Среда, 13.09.2017, 11:15 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 118
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Karataev, buchlotnik, Спасибо большое, я похоже за лето немного подзабыл элементарную математику :) :) :)
 
Ответить
СообщениеKarataev, buchlotnik, Спасибо большое, я похоже за лето немного подзабыл элементарную математику :) :) :)

Автор - ПАМ
Дата добавления - 13.09.2017 в 11:15
_Boroda_ Дата: Среда, 13.09.2017, 11:19 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11659
Репутация: 4831 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Формула
Код
=--(МЕДИАНА(A2:C2)=C2)

И формат ячеек
"Выигрыш";;"Проигрыш"

Или так еще
Код
=ЕСЛИ(МЕДИАНА(A2:C2)=C2;"Вы";"Про")&"игрыш"
К сообщению приложен файл: 5750779_1.xls(24Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Формула
Код
=--(МЕДИАНА(A2:C2)=C2)

И формат ячеек
"Выигрыш";;"Проигрыш"

Или так еще
Код
=ЕСЛИ(МЕДИАНА(A2:C2)=C2;"Вы";"Про")&"игрыш"

Автор - _Boroda_
Дата добавления - 13.09.2017 в 11:19
ПАМ Дата: Среда, 13.09.2017, 11:30 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 118
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Александр и Вам огромное спасибо!
 
Ответить
Сообщение_Boroda_, Александр и Вам огромное спасибо!

Автор - ПАМ
Дата добавления - 13.09.2017 в 11:30
Che79 Дата: Среда, 13.09.2017, 14:59 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 599
Репутация: 108 ±
Замечаний: 0% ±

Excel 2007, 2013
вариант вне конкурса, до кучи: массивка
Код
{=--ИЛИ(A2:B2>=C2)}
+ формат ячеек Выи\грыш;;Прои\грыш
UPD
А, вообще, такую задачу, можно решить простым
Код
=--(B2>=C2)
+ формат ячеек, т.к. по здравой логике значения "От" не могут быть больше значений "До" :)
К сообщению приложен файл: 6257194.xlsx(9Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Среда, 13.09.2017, 17:00
 
Ответить
Сообщениевариант вне конкурса, до кучи: массивка
Код
{=--ИЛИ(A2:B2>=C2)}
+ формат ячеек Выи\грыш;;Прои\грыш
UPD
А, вообще, такую задачу, можно решить простым
Код
=--(B2>=C2)
+ формат ячеек, т.к. по здравой логике значения "От" не могут быть больше значений "До" :)

Автор - Che79
Дата добавления - 13.09.2017 в 14:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Число, входящее в промежуток (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!