Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автозаполнение ячеек при выборе значения в другой ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозаполнение ячеек при выборе значения в другой ячейке (Формулы/Formulas)
Автозаполнение ячеек при выборе значения в другой ячейке
LenaGLBYH Дата: Пятница, 15.09.2017, 15:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день. Помогите, пожалуйста, чайнику с Excel. Есть Лист2 с информацией в алфавитном порядке: 1 столбец - по Фамилии, 2 столбец - Имя, 3 столбец - Отчество, 4 столбец - л/с сотрудника. Очень бы хотелось на Лист1 получить из ниспадающего списка при выборе Фамилии (это столбец №2) автоматическое заполнение 1 столбца - л/с сотрудника, 3 - Имя, 4 - Отчество. И далее строчка 2 возможность выбора следующего сотрудника, строчка 3 возможность выбора следующего сотрудника и т.д. Будьте добры, помогите, пожалуйста.


Сообщение отредактировал LenaGLBYH - Пятница, 15.09.2017, 15:56
 
Ответить
СообщениеДобрый день. Помогите, пожалуйста, чайнику с Excel. Есть Лист2 с информацией в алфавитном порядке: 1 столбец - по Фамилии, 2 столбец - Имя, 3 столбец - Отчество, 4 столбец - л/с сотрудника. Очень бы хотелось на Лист1 получить из ниспадающего списка при выборе Фамилии (это столбец №2) автоматическое заполнение 1 столбца - л/с сотрудника, 3 - Имя, 4 - Отчество. И далее строчка 2 возможность выбора следующего сотрудника, строчка 3 возможность выбора следующего сотрудника и т.д. Будьте добры, помогите, пожалуйста.

Автор - LenaGLBYH
Дата добавления - 15.09.2017 в 15:49
китин Дата: Пятница, 15.09.2017, 16:00 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4331
Репутация: 673 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ВПР вам в помощь или ваш файл нам в помощь. и тогда наша помощь придет


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеВПР вам в помощь или ваш файл нам в помощь. и тогда наша помощь придет

Автор - китин
Дата добавления - 15.09.2017 в 16:00
LenaGLBYH Дата: Пятница, 15.09.2017, 16:23 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Простите, про ВПР не знала. Пыталась с ИНДЕКС и ПОИСКПОЗ только решить свою задачу. Прикрепляю файл с исходными данными.
К сообщению приложен файл: 6299017.xlsx(11Kb)


Сообщение отредактировал LenaGLBYH - Пятница, 15.09.2017, 16:24
 
Ответить
СообщениеПростите, про ВПР не знала. Пыталась с ИНДЕКС и ПОИСКПОЗ только решить свою задачу. Прикрепляю файл с исходными данными.

Автор - LenaGLBYH
Дата добавления - 15.09.2017 в 16:23
Pelena Дата: Пятница, 15.09.2017, 16:37 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11491
Репутация: 2555 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Можно и с ИНДЕКС()
К сообщению приложен файл: 6177143.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМожно и с ИНДЕКС()

Автор - Pelena
Дата добавления - 15.09.2017 в 16:37
LenaGLBYH Дата: Пятница, 15.09.2017, 17:45 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Ура!!!! Спасибо за помощь!!!! hands hands hands hands hands
 
Ответить
СообщениеУра!!!! Спасибо за помощь!!!! hands hands hands hands hands

Автор - LenaGLBYH
Дата добавления - 15.09.2017 в 17:45
Che79 Дата: Пятница, 15.09.2017, 18:24 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 465
Репутация: 73 ±
Замечаний: 0% ±

Excel 2010 RUS
Вариант с ВПР()
Код
=ЕСЛИОШИБКА(ВПР($B3;Справочник!$A$1:$D$1100;5-СТОЛБЕЦ(A$1)+ЕСЛИ(A$2="Отчество";2;););"")
Формулу в ячейку A3 листа "Выходные данные" (желтые ячейки), вниз - протягиваем, в ячейки С3 и D3 простым "копипастом".
К сообщению приложен файл: 6177143_1.xlsx(12Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Пятница, 15.09.2017, 18:28
 
Ответить
СообщениеВариант с ВПР()
Код
=ЕСЛИОШИБКА(ВПР($B3;Справочник!$A$1:$D$1100;5-СТОЛБЕЦ(A$1)+ЕСЛИ(A$2="Отчество";2;););"")
Формулу в ячейку A3 листа "Выходные данные" (желтые ячейки), вниз - протягиваем, в ячейки С3 и D3 простым "копипастом".

Автор - Che79
Дата добавления - 15.09.2017 в 18:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозаполнение ячеек при выборе значения в другой ячейке (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!