Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула перестановки слов в ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула перестановки слов в ячейке (Формулы/Formulas)
Формула перестановки слов в ячейке
Lavr Дата: Воскресенье, 08.10.2017, 09:56 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте.
Мне нужно переставить слова в ячейке например:
стиральную машину купить
С помощью какой команды можно переставить слово "купить" в начало предложения?
Спасибо.


Сообщение отредактировал Lavr - Воскресенье, 08.10.2017, 09:56
 
Ответить
СообщениеЗдравствуйте.
Мне нужно переставить слова в ячейке например:
стиральную машину купить
С помощью какой команды можно переставить слово "купить" в начало предложения?
Спасибо.

Автор - Lavr
Дата добавления - 08.10.2017 в 09:56
_Igor_61 Дата: Воскресенье, 08.10.2017, 10:07 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 191
Репутация: 34 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте! Вариант:
К сообщению приложен файл: 4545605.xls(14Kb)
 
Ответить
СообщениеЗдравствуйте! Вариант:

Автор - _Igor_61
Дата добавления - 08.10.2017 в 10:07
vikttur Дата: Воскресенье, 08.10.2017, 10:53 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2468
Репутация: 430 ±
Замечаний: 0% ±

Код
=СЖПРОБЕЛЫ(B1&" "&ПОДСТАВИТЬ(A2;B1;))

Если ячейка выбора не нужна, замените ссылку на слово


Сообщение отредактировал vikttur - Воскресенье, 08.10.2017, 10:53
 
Ответить
Сообщение
Код
=СЖПРОБЕЛЫ(B1&" "&ПОДСТАВИТЬ(A2;B1;))

Если ячейка выбора не нужна, замените ссылку на слово

Автор - vikttur
Дата добавления - 08.10.2017 в 10:53
Lavr Дата: Воскресенье, 08.10.2017, 10:55 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Igor_61,
Не знаю, сумею ли я ее применить , но я попробую)
Спасибо!
 
Ответить
Сообщение_Igor_61,
Не знаю, сумею ли я ее применить , но я попробую)
Спасибо!

Автор - Lavr
Дата добавления - 08.10.2017 в 10:55
Lavr Дата: Воскресенье, 08.10.2017, 12:21 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013

Если ячейка выбора не нужна, замените ссылку на слово

vikttur, Можно наглядно, как именно... ? )

Мне нужно в определенном столбце, слова "купить" переставить в начало заголовка. (прикпрепил скрин)


Сообщение отредактировал Lavr - Воскресенье, 08.10.2017, 12:22
 
Ответить
Сообщение

Если ячейка выбора не нужна, замените ссылку на слово

vikttur, Можно наглядно, как именно... ? )

Мне нужно в определенном столбце, слова "купить" переставить в начало заголовка. (прикпрепил скрин)

Автор - Lavr
Дата добавления - 08.10.2017 в 12:21
Pelena Дата: Воскресенье, 08.10.2017, 12:24 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11597
Репутация: 2572 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Код
=СЖПРОБЕЛЫ("купить "&ПОДСТАВИТЬ(A2;"купить";))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СЖПРОБЕЛЫ("купить "&ПОДСТАВИТЬ(A2;"купить";))

Автор - Pelena
Дата добавления - 08.10.2017 в 12:24
Lavr Дата: Воскресенье, 08.10.2017, 14:27 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=СЖПРОБЕЛЫ("купить "&ПОДСТАВИТЬ(A2;"купить";))

Pelena,
эта формула слово "купить" добавила в каждую ячейку в начало каждой строки.
Мне же нужно слова "купить" переставить с конца заголовков в начало только от туда где оно есть в конце, а не добавлять его в каждой строке)
Вполне возможно что, я не так сформулировал.

Тем не менее спасибо вам, возможно это мне тоже пригодится.


Сообщение отредактировал Lavr - Воскресенье, 08.10.2017, 14:55
 
Ответить
Сообщение
=СЖПРОБЕЛЫ("купить "&ПОДСТАВИТЬ(A2;"купить";))

Pelena,
эта формула слово "купить" добавила в каждую ячейку в начало каждой строки.
Мне же нужно слова "купить" переставить с конца заголовков в начало только от туда где оно есть в конце, а не добавлять его в каждой строке)
Вполне возможно что, я не так сформулировал.

Тем не менее спасибо вам, возможно это мне тоже пригодится.

Автор - Lavr
Дата добавления - 08.10.2017 в 14:27
vikttur Дата: Воскресенье, 08.10.2017, 20:57 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2468
Репутация: 430 ±
Замечаний: 0% ±

Цитата
только от туда где оно есть в конце

Так Вы же об этом не пиисали...
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("слово";A2));СЖПРОБЕЛЫ(B1&" "&ПОДСТАВИТЬ(A2;"слово";));A2)
 
Ответить
Сообщение
Цитата
только от туда где оно есть в конце

Так Вы же об этом не пиисали...
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("слово";A2));СЖПРОБЕЛЫ(B1&" "&ПОДСТАВИТЬ(A2;"слово";));A2)

Автор - vikttur
Дата добавления - 08.10.2017 в 20:57
Pelena Дата: Воскресенье, 08.10.2017, 22:01 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11597
Репутация: 2572 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Или так
Код
=ЕСЛИ(ПРАВСИМВ(A2;6)="купить";СЖПРОБЕЛЫ("купить "&ПОДСТАВИТЬ(A2;"купить";));A2)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИли так
Код
=ЕСЛИ(ПРАВСИМВ(A2;6)="купить";СЖПРОБЕЛЫ("купить "&ПОДСТАВИТЬ(A2;"купить";));A2)

Автор - Pelena
Дата добавления - 08.10.2017 в 22:01
_Boroda_ Дата: Понедельник, 09.10.2017, 09:16 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11525
Репутация: 4744 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ЕСЛИ(ПРАВБ(A1;6)="купить";"купить "&ЛЕВБ(A1;ДЛСТР(A1)-7);A1)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ЕСЛИ(ПРАВБ(A1;6)="купить";"купить "&ЛЕВБ(A1;ДЛСТР(A1)-7);A1)

Автор - _Boroda_
Дата добавления - 09.10.2017 в 09:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула перестановки слов в ячейке (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!