Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Удалить дубли строк, просуммировав значения. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удалить дубли строк, просуммировав значения. (Формулы/Formulas)
Удалить дубли строк, просуммировав значения.
Jingo Дата: Понедельник, 09.10.2017, 19:25 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Уважаемые эксперты, добрый вечер!

Как "объединить" строки так, чтобы осталась одна строка и просуммировались числа всех "числовых" столбцов кроме последнего. И в лишних 1-2 строках все числовые значения удалились или сами строки удалились.
Пример на листе 2, исходник - Лист 1.

Спасибо большое заранее!
К сообщению приложен файл: _parampampam.xlsx(9Kb)


Сообщение отредактировал Jingo - Понедельник, 09.10.2017, 19:26
 
Ответить
СообщениеУважаемые эксперты, добрый вечер!

Как "объединить" строки так, чтобы осталась одна строка и просуммировались числа всех "числовых" столбцов кроме последнего. И в лишних 1-2 строках все числовые значения удалились или сами строки удалились.
Пример на листе 2, исходник - Лист 1.

Спасибо большое заранее!

Автор - Jingo
Дата добавления - 09.10.2017 в 19:25
buchlotnik Дата: Понедельник, 09.10.2017, 19:38 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3113
Репутация: 853 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
видимо нужна сводная таблица
К сообщению приложен файл: 6387766.xlsx(15Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениевидимо нужна сводная таблица

Автор - buchlotnik
Дата добавления - 09.10.2017 в 19:38
Che79 Дата: Понедельник, 09.10.2017, 21:08 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 533
Репутация: 92 ±
Замечаний: 0% ±

Excel 2010 RUS
Jingo, вариант формулами. См. желтые ячейки в файле на Листе 1.
Первые четыре столбца
Код
=СУММ(C1:ИНДЕКС(C1:C$13;СЧЁТЕСЛИ($A1:$A$13;$A1)))*(СЧЁТЕСЛИ($A$1:$A1;$A1)=1)

Пятый столбец
Код
=СРЗНАЧ(G1:ИНДЕКС(G1:G$13;СЧЁТЕСЛИ($A1:$A$13;$A1)))*(СЧЁТЕСЛИ($A$1:$A1;$A1)=1)
+ в жёлтых формат ячеек 0;;но не на все строки
В зеленые ячейки добавил проверку.
К сообщению приложен файл: _parampampam_1.xlsx(13Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеJingo, вариант формулами. См. желтые ячейки в файле на Листе 1.
Первые четыре столбца
Код
=СУММ(C1:ИНДЕКС(C1:C$13;СЧЁТЕСЛИ($A1:$A$13;$A1)))*(СЧЁТЕСЛИ($A$1:$A1;$A1)=1)

Пятый столбец
Код
=СРЗНАЧ(G1:ИНДЕКС(G1:G$13;СЧЁТЕСЛИ($A1:$A$13;$A1)))*(СЧЁТЕСЛИ($A$1:$A1;$A1)=1)
+ в жёлтых формат ячеек 0;;но не на все строки
В зеленые ячейки добавил проверку.

Автор - Che79
Дата добавления - 09.10.2017 в 21:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удалить дубли строк, просуммировав значения. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!