Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор ФИО по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор ФИО по условию (Формулы/Formulas)
Выбор ФИО по условию
Chirig Дата: Среда, 11.10.2017, 12:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день. Помогите, пожалуйста, прописать формулу, чтобы на листе Приказ в столбце ФИО вносились только те ФИО с листа ОФИС значение столбца "Итого суммой" для которых не равно 0.


С уважением, Ирина
 
Ответить
СообщениеДобрый день. Помогите, пожалуйста, прописать формулу, чтобы на листе Приказ в столбце ФИО вносились только те ФИО с листа ОФИС значение столбца "Итого суммой" для которых не равно 0.

Автор - Chirig
Дата добавления - 11.10.2017 в 12:45
Chirig Дата: Среда, 11.10.2017, 12:45 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Ой, забыла файл. Вот он
К сообщению приложен файл: 2785444.xlsx(29Kb)


С уважением, Ирина
 
Ответить
СообщениеОй, забыла файл. Вот он

Автор - Chirig
Дата добавления - 11.10.2017 в 12:45
buchlotnik Дата: Среда, 11.10.2017, 12:57 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3437
Репутация: 922 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
как-то так:
Код
=ИНДЕКС(Офис!$B$1:$B$28;НАИМЕНЬШИЙ(ЕСЛИ(Офис!$G$5:$G$29>0;СТРОКА(Офис!$G$5:$G$29);"");СТРОКА(Приказ!B1)))
К сообщению приложен файл: 3464225.xlsx(30Kb)


"заступлюсь за Юрия" - публичный плевок в душу!
 
Ответить
Сообщениекак-то так:
Код
=ИНДЕКС(Офис!$B$1:$B$28;НАИМЕНЬШИЙ(ЕСЛИ(Офис!$G$5:$G$29>0;СТРОКА(Офис!$G$5:$G$29);"");СТРОКА(Приказ!B1)))

Автор - buchlotnik
Дата добавления - 11.10.2017 в 12:57
_Boroda_ Дата: Среда, 11.10.2017, 13:05 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Разъединяете ячейки, в А21 вставляете формулу
Код
=ЕСЛИОШИБКА(ИНДЕКС(Офис!B$5:B$29;НАИМЕНЬШИЙ(ЕСЛИ(Офис!M$5:M$29;СТРОКА(Офис!M$5:M$29)-СТРОКА(Офис!M$4));СТРОКА(A1)));"")

Жмете Контрл Шифт Ентер (это формула массива), выделяете ранее разъединенные ячейки, объединяете
Вообще-то объединенные ячейки - зло. От них нужно избавляться
К сообщению приложен файл: 2785444_1.xlsx(33Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеРазъединяете ячейки, в А21 вставляете формулу
Код
=ЕСЛИОШИБКА(ИНДЕКС(Офис!B$5:B$29;НАИМЕНЬШИЙ(ЕСЛИ(Офис!M$5:M$29;СТРОКА(Офис!M$5:M$29)-СТРОКА(Офис!M$4));СТРОКА(A1)));"")

Жмете Контрл Шифт Ентер (это формула массива), выделяете ранее разъединенные ячейки, объединяете
Вообще-то объединенные ячейки - зло. От них нужно избавляться

Автор - _Boroda_
Дата добавления - 11.10.2017 в 13:05
Chirig Дата: Среда, 11.10.2017, 13:09 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо огромное. Помогите ещё, пожалуйста, я не учла, что нужно ещё одно условие.
В приказе должны прописываться ФИО при условии, что в столбце "Структурное Подразделение" значение = Пресса ЮЗ и итого суммой не равно 0 ( что вы уже прописали)
К сообщению приложен файл: 3005060.xlsx(30Kb)


С уважением, Ирина
 
Ответить
СообщениеСпасибо огромное. Помогите ещё, пожалуйста, я не учла, что нужно ещё одно условие.
В приказе должны прописываться ФИО при условии, что в столбце "Структурное Подразделение" значение = Пресса ЮЗ и итого суммой не равно 0 ( что вы уже прописали)

Автор - Chirig
Дата добавления - 11.10.2017 в 13:09
_Boroda_ Дата: Среда, 11.10.2017, 13:15 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ИНДЕКС(Офис!$B$1:$B$28;НАИМЕНЬШИЙ(ЕСЛИ(Офис!$G$5:$G$29*(Офис!$A$5:$A$29="Пресса ЮЗ");СТРОКА(Офис!$G$5:$G$29);"");СТРОКА(Приказ!B1)))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ИНДЕКС(Офис!$B$1:$B$28;НАИМЕНЬШИЙ(ЕСЛИ(Офис!$G$5:$G$29*(Офис!$A$5:$A$29="Пресса ЮЗ");СТРОКА(Офис!$G$5:$G$29);"");СТРОКА(Приказ!B1)))

Автор - _Boroda_
Дата добавления - 11.10.2017 в 13:15
buchlotnik Дата: Среда, 11.10.2017, 13:17 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3437
Репутация: 922 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Тогда так:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Офис!$B$1:$B$28;НАИМЕНЬШИЙ(ЕСЛИ((Офис!$G$5:$G$29>0)*(Офис!$A$5:$A$29="Пресса ЮЗ");СТРОКА(Офис!$G$5:$G$29);"");СТРОКА(Приказ!B1)));"")
К сообщению приложен файл: 9878365.xlsx(31Kb)


"заступлюсь за Юрия" - публичный плевок в душу!
 
Ответить
СообщениеТогда так:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Офис!$B$1:$B$28;НАИМЕНЬШИЙ(ЕСЛИ((Офис!$G$5:$G$29>0)*(Офис!$A$5:$A$29="Пресса ЮЗ");СТРОКА(Офис!$G$5:$G$29);"");СТРОКА(Приказ!B1)));"")

Автор - buchlotnik
Дата добавления - 11.10.2017 в 13:17
Chirig Дата: Среда, 11.10.2017, 13:25 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, Огромное спасибо.


С уважением, Ирина
 
Ответить
Сообщение_Boroda_, Огромное спасибо.

Автор - Chirig
Дата добавления - 11.10.2017 в 13:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор ФИО по условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!