Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данные из таблицы в таблицу по критерию поиска - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данные из таблицы в таблицу по критерию поиска (Формулы/Formulas)
Перенос данные из таблицы в таблицу по критерию поиска
Vzdruney Дата: Пятница, 27.10.2017, 09:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте!
Прошу помощи
Есть две таблицы в Таблице 2 содержаться данные
которые нужно перенести в Таблицу 1 найдя такую же ячейку
Если не ошибаюсь это возможно сделать через ВПР, но не могу сообразить до конца
Пример во вложении.
Заранее спасибо
К сообщению приложен файл: 5701990.xlsx(12Kb)


Сообщение отредактировал Vzdruney - Пятница, 27.10.2017, 09:45
 
Ответить
СообщениеЗдравствуйте!
Прошу помощи
Есть две таблицы в Таблице 2 содержаться данные
которые нужно перенести в Таблицу 1 найдя такую же ячейку
Если не ошибаюсь это возможно сделать через ВПР, но не могу сообразить до конца
Пример во вложении.
Заранее спасибо

Автор - Vzdruney
Дата добавления - 27.10.2017 в 09:44
Pelena Дата: Пятница, 27.10.2017, 09:48 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11755
Репутация: 2596 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
через ВПР

Код
=ВПР(A3;$D$3:$E$23;2;0)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
через ВПР

Код
=ВПР(A3;$D$3:$E$23;2;0)

Автор - Pelena
Дата добавления - 27.10.2017 в 09:48
_Boroda_ Дата: Пятница, 27.10.2017, 09:52 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11646
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ВПР(A3;D$3:E$23;2;)
Код
=ПРОСМОТР(A3;D$3:D$23;E$3:E$23)
Код
=ИНДЕКС(E$3:E$23;ПОИСКПОЗ(A3;D$3:D$23;))
Код
=СУММЕСЛИ(D$3:D$23;A3;E$3:E$23)
Код
=СУММПРОИЗВ((D$3:D$23=A3)*E$3:E$23)
К сообщению приложен файл: 5701990_1.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ВПР(A3;D$3:E$23;2;)
Код
=ПРОСМОТР(A3;D$3:D$23;E$3:E$23)
Код
=ИНДЕКС(E$3:E$23;ПОИСКПОЗ(A3;D$3:D$23;))
Код
=СУММЕСЛИ(D$3:D$23;A3;E$3:E$23)
Код
=СУММПРОИЗВ((D$3:D$23=A3)*E$3:E$23)

Автор - _Boroda_
Дата добавления - 27.10.2017 в 09:52
Vzdruney Дата: Пятница, 27.10.2017, 10:38 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Спасибо огромное,
а как протянуть формулу на всю таблицу что бы диапазон D$3:E$23 в формуле =ВПР(A3;D$3:E$23;2;) не менялся??
 
Ответить
СообщениеСпасибо огромное,
а как протянуть формулу на всю таблицу что бы диапазон D$3:E$23 в формуле =ВПР(A3;D$3:E$23;2;) не менялся??

Автор - Vzdruney
Дата добавления - 27.10.2017 в 10:38
Vzdruney Дата: Пятница, 27.10.2017, 10:49 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

А если например вот такой случай во второй таблице откуда берём данные для первой таблице ячейки в разнобой стоят и многих нет как в примере во вложении
Как в данном случае можно сделать?
Файл первоначально не тот вложил
К сообщению приложен файл: 2946342.xlsx(13Kb)


Сообщение отредактировал Vzdruney - Пятница, 27.10.2017, 10:53
 
Ответить
СообщениеА если например вот такой случай во второй таблице откуда берём данные для первой таблице ячейки в разнобой стоят и многих нет как в примере во вложении
Как в данном случае можно сделать?
Файл первоначально не тот вложил

Автор - Vzdruney
Дата добавления - 27.10.2017 в 10:49
_Boroda_ Дата: Пятница, 27.10.2017, 10:55 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11646
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Доллары видите в ссылке на диапазон? Там, где эти доллары - тот показатель меняться не будет при протягивании. Почитайте про абсолютные и относительные ссылки
Если вразнобой - это неважно
Если какого-то значения нет - то перепишите формулу вот так
Код
=ЕСЛИОШИБКА(ВПР(A3;D$3:E$16;2;);"")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДоллары видите в ссылке на диапазон? Там, где эти доллары - тот показатель меняться не будет при протягивании. Почитайте про абсолютные и относительные ссылки
Если вразнобой - это неважно
Если какого-то значения нет - то перепишите формулу вот так
Код
=ЕСЛИОШИБКА(ВПР(A3;D$3:E$16;2;);"")

Автор - _Boroda_
Дата добавления - 27.10.2017 в 10:55
Vzdruney Дата: Пятница, 27.10.2017, 13:24 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Спасибо большое, век живи - век учись!!
Очень помогли, что посоветовали бы почитать?? что бы не задавать глупые вопросы))
 
Ответить
СообщениеСпасибо большое, век живи - век учись!!
Очень помогли, что посоветовали бы почитать?? что бы не задавать глупые вопросы))

Автор - Vzdruney
Дата добавления - 27.10.2017 в 13:24
_Boroda_ Дата: Пятница, 27.10.2017, 13:35 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11646
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
что посоветовали бы почитать?

Форум
Уокенбаха "Бибилию пользователя" и другие книги http://www.excelworld.ru/index/bibl/0-5


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
что посоветовали бы почитать?

Форум
Уокенбаха "Бибилию пользователя" и другие книги http://www.excelworld.ru/index/bibl/0-5

Автор - _Boroda_
Дата добавления - 27.10.2017 в 13:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данные из таблицы в таблицу по критерию поиска (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!