Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как снять ограничение условий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как снять ограничение условий (Формулы/Formulas)
Как снять ограничение условий
BONA Дата: Вторник, 31.10.2017, 08:56 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Добрый день, уважаемые форумчане!
Помогите пожалуйста, нужна формула для выбора значения из 20 по двум условиям ЕСЛИ. Но такую длинную формулу не пропускает, ошибка. Вот формула:

=ЕСЛИ(И(C353=1;D353=1);Q11;ЕСЛИ(И(C353=1;D353=2);R11;ЕСЛИ(И(C353=1;D353=3);S11;ЕСЛИ(И(C353=1;D353=4);T11;ЕСЛИ(И(C353=1;D353=5);U11;
ЕСЛИ(И(C353=2;D353=1);Q12;ЕСЛИ(И(C353=2;D353=2);R12;ЕСЛИ(И(C353=2;D353=3);S12;ЕСЛИ(И(C353=2;D353=4);T12;ЕСЛИ(И(C353=2;D353=5);U12;
ЕСЛИ(И(C353=3;D353=1);Q13;ЕСЛИ(И(C353=3;D353=2);R13;ЕСЛИ(И(C353=3;D353=3);S13;ЕСЛИ(И(C353=3;D353=4);T13;ЕСЛИ(И(C353=3;D353=5);U13;
ЕСЛИ(И(C353=4;D353=1);Q14;ЕСЛИ(И(C353=4;D353=2);R14;ЕСЛИ(И(C353=4;D353=3);S14;ЕСЛИ(И(C353=4;D353=4);T14;ЕСЛИ(И(C353=4;D353=5);U14;))))))))))))))))))))

Как этот ужас сократить?


Сообщение отредактировал BONA - Вторник, 31.10.2017, 08:58
 
Ответить
СообщениеДобрый день, уважаемые форумчане!
Помогите пожалуйста, нужна формула для выбора значения из 20 по двум условиям ЕСЛИ. Но такую длинную формулу не пропускает, ошибка. Вот формула:

=ЕСЛИ(И(C353=1;D353=1);Q11;ЕСЛИ(И(C353=1;D353=2);R11;ЕСЛИ(И(C353=1;D353=3);S11;ЕСЛИ(И(C353=1;D353=4);T11;ЕСЛИ(И(C353=1;D353=5);U11;
ЕСЛИ(И(C353=2;D353=1);Q12;ЕСЛИ(И(C353=2;D353=2);R12;ЕСЛИ(И(C353=2;D353=3);S12;ЕСЛИ(И(C353=2;D353=4);T12;ЕСЛИ(И(C353=2;D353=5);U12;
ЕСЛИ(И(C353=3;D353=1);Q13;ЕСЛИ(И(C353=3;D353=2);R13;ЕСЛИ(И(C353=3;D353=3);S13;ЕСЛИ(И(C353=3;D353=4);T13;ЕСЛИ(И(C353=3;D353=5);U13;
ЕСЛИ(И(C353=4;D353=1);Q14;ЕСЛИ(И(C353=4;D353=2);R14;ЕСЛИ(И(C353=4;D353=3);S14;ЕСЛИ(И(C353=4;D353=4);T14;ЕСЛИ(И(C353=4;D353=5);U14;))))))))))))))))))))

Как этот ужас сократить?

Автор - BONA
Дата добавления - 31.10.2017 в 08:56
_Boroda_ Дата: Вторник, 31.10.2017, 09:06 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11647
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- Исправьте название темы согласно п.2 Правил форума
- Приложите файл в формате Excel размером до 100кб согласно п.3 Правил форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- Исправьте название темы согласно п.2 Правил форума
- Приложите файл в формате Excel размером до 100кб согласно п.3 Правил форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - _Boroda_
Дата добавления - 31.10.2017 в 09:06
китин Дата: Вторник, 31.10.2017, 09:55 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4409
Репутация: 697 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Саша ссылка "здесь" битая


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеСаша ссылка "здесь" битая

Автор - китин
Дата добавления - 31.10.2017 в 09:55
_Boroda_ Дата: Вторник, 31.10.2017, 09:58 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11647
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Игорь, спасибо. Это я шаблон неверно сделал и не проверил


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИгорь, спасибо. Это я шаблон неверно сделал и не проверил

Автор - _Boroda_
Дата добавления - 31.10.2017 в 09:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как снять ограничение условий (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!