Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ранжирование от суммы очков - отрицательные значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ранжирование от суммы очков - отрицательные значения (Формулы/Formulas)
Ранжирование от суммы очков - отрицательные значения
YuraYushkevich Дата: Вторник, 31.10.2017, 13:46 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Необходимо проставить ранг, в зависимости от набранных очков.... прописал 2 разных решения (формулы) но осталась проблема, не правильно ранжирует при отрицательном значении..
Для наглядности и примера прилагаю маленький файлик. Заранее благодарю.
К сообщению приложен файл: 6679146.xlsx(12Kb)


Сообщение отредактировал YuraYushkevich - Вторник, 31.10.2017, 13:50
 
Ответить
СообщениеНеобходимо проставить ранг, в зависимости от набранных очков.... прописал 2 разных решения (формулы) но осталась проблема, не правильно ранжирует при отрицательном значении..
Для наглядности и примера прилагаю маленький файлик. Заранее благодарю.

Автор - YuraYushkevich
Дата добавления - 31.10.2017 в 13:46
китин Дата: Вторник, 31.10.2017, 13:47 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4409
Репутация: 697 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
файла нет


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениефайла нет

Автор - китин
Дата добавления - 31.10.2017 в 13:47
YuraYushkevich Дата: Вторник, 31.10.2017, 13:47 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Вот файлик
К сообщению приложен файл: 2817314.xlsx(12Kb)


Сообщение отредактировал YuraYushkevich - Вторник, 31.10.2017, 13:48
 
Ответить
СообщениеВот файлик

Автор - YuraYushkevich
Дата добавления - 31.10.2017 в 13:47
buchlotnik Дата: Вторник, 31.10.2017, 14:28 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3325
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
может так нужно?
Код
=СУММПРОИЗВ(($B$2:$B$9>B2)/СЧЁТЕСЛИ($B$2:$B$9;$B$2:$B$9))+1
К сообщению приложен файл: 2817314-1-.xlsx(13Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениеможет так нужно?
Код
=СУММПРОИЗВ(($B$2:$B$9>B2)/СЧЁТЕСЛИ($B$2:$B$9;$B$2:$B$9))+1

Автор - buchlotnik
Дата добавления - 31.10.2017 в 14:28
YuraYushkevich Дата: Вторник, 31.10.2017, 14:37 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, Спасибо огромное, вроде как то что нужно..... работает.... буду обкатывать.
 
Ответить
Сообщениеbuchlotnik, Спасибо огромное, вроде как то что нужно..... работает.... буду обкатывать.

Автор - YuraYushkevich
Дата добавления - 31.10.2017 в 14:37
_Boroda_ Дата: Вторник, 31.10.2017, 15:08 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11644
Репутация: 4825 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще такой дурной вариант
Код
=СЧЁТ(1/ЧАСТОТА((B$2:B$9>B2)*(B$2:B$9-МИН(B$2:B$9));B$2:B$9-МИН(B$2:B$9)))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще такой дурной вариант
Код
=СЧЁТ(1/ЧАСТОТА((B$2:B$9>B2)*(B$2:B$9-МИН(B$2:B$9));B$2:B$9-МИН(B$2:B$9)))

Автор - _Boroda_
Дата добавления - 31.10.2017 в 15:08
YuraYushkevich Дата: Вторник, 31.10.2017, 15:18 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Еще вопросик, а как отранжировать это же условие в обратном порядке?
 
Ответить
СообщениеЕще вопросик, а как отранжировать это же условие в обратном порядке?

Автор - YuraYushkevich
Дата добавления - 31.10.2017 в 15:18
YuraYushkevich Дата: Вторник, 31.10.2017, 15:22 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
ой, сам нашел, знак > необходимо заменить на знак <
 
Ответить
Сообщениеой, сам нашел, знак > необходимо заменить на знак <

Автор - YuraYushkevich
Дата добавления - 31.10.2017 в 15:22
buchlotnik Дата: Вторник, 31.10.2017, 15:22 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3325
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Ну а подумать?
Цитата
ой, сам нашел
другое дело yes yes
Код
=СУММПРОИЗВ(($B$2:$B$9<B2)/СЧЁТЕСЛИ($B$2:$B$9;$B$2:$B$9))+1
К сообщению приложен файл: 0622458.xlsx(13Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Вторник, 31.10.2017, 15:27
 
Ответить
СообщениеНу а подумать?
Цитата
ой, сам нашел
другое дело yes yes
Код
=СУММПРОИЗВ(($B$2:$B$9<B2)/СЧЁТЕСЛИ($B$2:$B$9;$B$2:$B$9))+1

Автор - buchlotnik
Дата добавления - 31.10.2017 в 15:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ранжирование от суммы очков - отрицательные значения (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!