Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перемещение данных из таблиц в другую таблицу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перемещение данных из таблиц в другую таблицу (Формулы/Formulas)
Перемещение данных из таблиц в другую таблицу
Tenken Дата: Среда, 01.11.2017, 20:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, Подскажите пожалуйста.Я совсем недавно начал изучать Excel .Имеется 2 таблицы.В которых есть данные о средствах измерений в каком-то цеху( для упрощения занес все в одну книгу ( но будет разное кол-во средств измерений в каждом цеху от 2 до 100)для понятия алгоримта ограничился небольшим кол-вом) , c их номерами и датами поверки по месяцами. Можно ли как-нибудь выцепить именно само название средства измерений с датой поверки и заводским номером, конкретно по одному месяцу со всех таблиц.То есть чтобы не лопатить какие средства измерений надо поверять в июле например( из нескольких сотен и записывать на бумажку) , просто создать перечень из имеющихся данных по таблицам из 9 колонки( в следущем месяце из 10 колонки). Но чтобы результат был связан еще и с двумя текстовыми ячейками( заводские номера иногда бывают буквенные). Каким инструментом можно воспользоваться?В какую сторону смотреть? :D
К сообщению приложен файл: 9017256.xlsx(11Kb)


Сообщение отредактировал Tenken - Среда, 01.11.2017, 20:34
 
Ответить
СообщениеЗдравствуйте, Подскажите пожалуйста.Я совсем недавно начал изучать Excel .Имеется 2 таблицы.В которых есть данные о средствах измерений в каком-то цеху( для упрощения занес все в одну книгу ( но будет разное кол-во средств измерений в каждом цеху от 2 до 100)для понятия алгоримта ограничился небольшим кол-вом) , c их номерами и датами поверки по месяцами. Можно ли как-нибудь выцепить именно само название средства измерений с датой поверки и заводским номером, конкретно по одному месяцу со всех таблиц.То есть чтобы не лопатить какие средства измерений надо поверять в июле например( из нескольких сотен и записывать на бумажку) , просто создать перечень из имеющихся данных по таблицам из 9 колонки( в следущем месяце из 10 колонки). Но чтобы результат был связан еще и с двумя текстовыми ячейками( заводские номера иногда бывают буквенные). Каким инструментом можно воспользоваться?В какую сторону смотреть? :D

Автор - Tenken
Дата добавления - 01.11.2017 в 20:33
_Boroda_ Дата: Среда, 01.11.2017, 20:51 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11647
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если всё это на разных листах (или даже разных книгах), то вот так можно
В первых двух столбцах формулы массива (вводятся одновременным нажатием Контрл Шифт Ентер
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС($C$4:$N$999;;ПОИСКПОЗ($S$1;$C$3:$N$3;));СТРОКА(A$4:A$999));СТРОКА(Q1)));"")

В третьем обычная
Код
=ЕСЛИ(Q3="";"";ПРОСМОТР(2;1/(A$4:A$999&B$4:B$999=Q3&R3);ИНДЕКС($C$4:$N$999;;ПОИСКПОЗ($S$1;$C$3:$N$3;))))

Месяц выбирается из выпадающего списка

Если же все таблицы по разным цехам будут на одном листе, то Вам в итоговую табличку еще номер цеха наверное нужен?

Или достаточно и так?
К сообщению приложен файл: 9017256_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли всё это на разных листах (или даже разных книгах), то вот так можно
В первых двух столбцах формулы массива (вводятся одновременным нажатием Контрл Шифт Ентер
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС($C$4:$N$999;;ПОИСКПОЗ($S$1;$C$3:$N$3;));СТРОКА(A$4:A$999));СТРОКА(Q1)));"")

В третьем обычная
Код
=ЕСЛИ(Q3="";"";ПРОСМОТР(2;1/(A$4:A$999&B$4:B$999=Q3&R3);ИНДЕКС($C$4:$N$999;;ПОИСКПОЗ($S$1;$C$3:$N$3;))))

Месяц выбирается из выпадающего списка

Если же все таблицы по разным цехам будут на одном листе, то Вам в итоговую табличку еще номер цеха наверное нужен?

Или достаточно и так?

Автор - _Boroda_
Дата добавления - 01.11.2017 в 20:51
Tenken Дата: Среда, 01.11.2017, 22:15 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, да вы верно подметили номер цеха нужен)и вы правы скорее всего будет в разных книгах)
 
Ответить
Сообщение_Boroda_, да вы верно подметили номер цеха нужен)и вы правы скорее всего будет в разных книгах)

Автор - Tenken
Дата добавления - 01.11.2017 в 22:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перемещение данных из таблиц в другую таблицу (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!