Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Циклличное вычитание чисел. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Циклличное вычитание чисел. (Формулы/Formulas)
Циклличное вычитание чисел.
Ocelote Дата: Четверг, 02.11.2017, 22:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
У меня такая проблема. Есть определенное количество ячеек с цифрами. Нужно из первой ячейки вычесть определенное количество ячеек. Затем ячейка из которой нужно вычесть остальные меняется, и меняется она через определенное количество ячеек и из нее уже нужно вычесть последующие и так повторяется до бесконечности. Подскажите формулу.
К сообщению приложен файл: 0983871.xlsx(22Kb)
 
Ответить
СообщениеУ меня такая проблема. Есть определенное количество ячеек с цифрами. Нужно из первой ячейки вычесть определенное количество ячеек. Затем ячейка из которой нужно вычесть остальные меняется, и меняется она через определенное количество ячеек и из нее уже нужно вычесть последующие и так повторяется до бесконечности. Подскажите формулу.

Автор - Ocelote
Дата добавления - 02.11.2017 в 22:45
buchlotnik Дата: Четверг, 02.11.2017, 23:06 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3327
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ЕСЛИ((B9>=0,25)*(B9<=0,75);(ПРОСМОТР(;-$A$4:A9/($B$4:B9=0,25);$F$4:F9)-C9)*1000;"")
но при
Цитата
до бесконечности
реально будет тормозить
К сообщению приложен файл: 5985870.xlsx(27Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 02.11.2017, 23:08
 
Ответить
Сообщениетак нужно?
Код
=ЕСЛИ((B9>=0,25)*(B9<=0,75);(ПРОСМОТР(;-$A$4:A9/($B$4:B9=0,25);$F$4:F9)-C9)*1000;"")
но при
Цитата
до бесконечности
реально будет тормозить

Автор - buchlotnik
Дата добавления - 02.11.2017 в 23:06
Ocelote Дата: Четверг, 02.11.2017, 23:36 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
buchlotnik, Да спасибо огромное, очень помог.
 
Ответить
Сообщениеbuchlotnik, Да спасибо огромное, очень помог.

Автор - Ocelote
Дата добавления - 02.11.2017 в 23:36
_Boroda_ Дата: Пятница, 03.11.2017, 10:19 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11647
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вот так должно быть значительно быстрее на больших объемах
Код
=ЕСЛИ(ЧАС(B4+"18:")<13;(ИНДЕКС(F:F;СТРОКА()-ЧАС(B4+"18:"))-C4)*1000;"")


*первый кусок в ЕСЛИ у Михаила скорее всего быстрее работает. Нужно проверять, но, на самом деле, наиболее важен здесь второй кусок, а именно нахождение значения для 6 часов текущего дня
К сообщению приложен файл: 5985870_1.xlsx(30Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВот так должно быть значительно быстрее на больших объемах
Код
=ЕСЛИ(ЧАС(B4+"18:")<13;(ИНДЕКС(F:F;СТРОКА()-ЧАС(B4+"18:"))-C4)*1000;"")


*первый кусок в ЕСЛИ у Михаила скорее всего быстрее работает. Нужно проверять, но, на самом деле, наиболее важен здесь второй кусок, а именно нахождение значения для 6 часов текущего дня

Автор - _Boroda_
Дата добавления - 03.11.2017 в 10:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Циклличное вычитание чисел. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!