Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Журнал общих работ. Работа с датами. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Журнал общих работ. Работа с датами. (Формулы/Formulas)
Журнал общих работ. Работа с датами.
tinpu Дата: Вторник, 07.11.2017, 12:59 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте Уважаемые форумчане!
Пользуюсь форумом давно и всегда находил много полезной информации, но столкнулся с вопросом, на который не смог найти ответа. Кроме вас, я думаю, никто мне не поможет…
Итак, к вопросу: Есть таблица с видами работ и датами, когда они начались и закончились (1 вкладка). Когда заполняешь журнал общих работ необходимо записать все работы, произведенные на определенную дату. В итоге, когда заполняешь журнал пропускаешь некоторые пересекающиеся работы, я думаю, что можно как-то автоматизировать разбивку по датам, но сам не справлюсь. Во второй вкладке отобразил то что должно получится после автоматизации.
К сообщению приложен файл: 6702366.xls(26Kb)
 
Ответить
СообщениеЗдравствуйте Уважаемые форумчане!
Пользуюсь форумом давно и всегда находил много полезной информации, но столкнулся с вопросом, на который не смог найти ответа. Кроме вас, я думаю, никто мне не поможет…
Итак, к вопросу: Есть таблица с видами работ и датами, когда они начались и закончились (1 вкладка). Когда заполняешь журнал общих работ необходимо записать все работы, произведенные на определенную дату. В итоге, когда заполняешь журнал пропускаешь некоторые пересекающиеся работы, я думаю, что можно как-то автоматизировать разбивку по датам, но сам не справлюсь. Во второй вкладке отобразил то что должно получится после автоматизации.

Автор - tinpu
Дата добавления - 07.11.2017 в 12:59
buchlotnik Дата: Вторник, 07.11.2017, 13:51 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3325
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Первая дата:
Код
=МИН(B2:B6)
Даты(кроме первой):
Код
=ЕСЛИ(СЧЁТЕСЛИ($A$11:A11;A11)<СУММПРОИЗВ(($B$2:$B$6<=A11)*($C$2:$C$6>=A11));A11;A11+1)
Значения (массивка):
Код
=ИНДЕКС($A$1:$A$6;НАИМЕНЬШИЙ(ЕСЛИ(($B$2:$B$6<=A12)*($C$2:$C$6>=A12);СТРОКА($A$2:$A$6);"");СЧЁТЕСЛИ($A$10:A12;A12)))
К сообщению приложен файл: 2313630.xls(36Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Вторник, 07.11.2017, 13:51
 
Ответить
СообщениеПервая дата:
Код
=МИН(B2:B6)
Даты(кроме первой):
Код
=ЕСЛИ(СЧЁТЕСЛИ($A$11:A11;A11)<СУММПРОИЗВ(($B$2:$B$6<=A11)*($C$2:$C$6>=A11));A11;A11+1)
Значения (массивка):
Код
=ИНДЕКС($A$1:$A$6;НАИМЕНЬШИЙ(ЕСЛИ(($B$2:$B$6<=A12)*($C$2:$C$6>=A12);СТРОКА($A$2:$A$6);"");СЧЁТЕСЛИ($A$10:A12;A12)))

Автор - buchlotnik
Дата добавления - 07.11.2017 в 13:51
tinpu Дата: Вторник, 07.11.2017, 16:35 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, Спасибо большое ! Буду пробовать...
 
Ответить
Сообщениеbuchlotnik, Спасибо большое ! Буду пробовать...

Автор - tinpu
Дата добавления - 07.11.2017 в 16:35
tinpu Дата: Четверг, 09.11.2017, 12:23 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, Сегодня попробовал, по датам вроде все ок - а вот массивка не протягивается, первая строка норм, а дальше никак...
К сообщению приложен файл: 7576748.xlsx(43Kb)


Сообщение отредактировал tinpu - Четверг, 09.11.2017, 12:25
 
Ответить
Сообщениеbuchlotnik, Сегодня попробовал, по датам вроде все ок - а вот массивка не протягивается, первая строка норм, а дальше никак...

Автор - tinpu
Дата добавления - 09.11.2017 в 12:23
buchlotnik Дата: Четверг, 09.11.2017, 12:33 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3325
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Я для кого написал - массивка? Вводим одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 6423426.xlsx(50Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 09.11.2017, 12:34
 
Ответить
СообщениеЯ для кого написал - массивка? Вводим одновременным нажатием Ctrl+Shift+Enter

Автор - buchlotnik
Дата добавления - 09.11.2017 в 12:33
tinpu Дата: Четверг, 09.11.2017, 12:40 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, точно !!! запамятовал ))) сории. Спасибо большое !!!
 
Ответить
Сообщениеbuchlotnik, точно !!! запамятовал ))) сории. Спасибо большое !!!

Автор - tinpu
Дата добавления - 09.11.2017 в 12:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Журнал общих работ. Работа с датами. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!