Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сопоставление двух прайсов с разным форматом артикулов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставление двух прайсов с разным форматом артикулов (Формулы/Formulas)
Сопоставление двух прайсов с разным форматом артикулов
slaiter Дата: Вторник, 07.11.2017, 17:37 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день, уважаемые профи Экселя.

По работе сформировалась задачка, на первый взгляд, показавшаяся очень простой, но по факту я ее не смог решить. Не хватает знаний формул, а может и макросов.

Смысл вот в чем, есть список товаров у нашей организации, с артикулами, которые являются названиями товара. И есть прайс от поставщика по этим товарам, но они используют в названии/артикуле чуть другой формат, у них полное название, поэтому в артикуле содержатся дополнительные символы, которые используют производители, а в магазинах они отсекаются. К примеру, у нас товар называется "EFR-539BK-1A2" а у них "EFR-539BK-1A2VUDF". То есть их название длиннее на 4 последних символа. Нам необходимо произвести сопоставление наших артикулов с их Артикулами, чтобы всегда быстро ориентироваться по наличию товаров и прочим коммерческим делам. Первое что пришло в голову, это ВПР, но по факту у меня ничего не вышло. Он решает часть проблемы, но я не смог найти выход из такой ситуации. К сожалению некоторые похожие товары имеют очень похожие артикулы и отличаются одним дополнительным символом, к примеру у нас есть товары ERA-200DB-1A и ERA-200DB-1A9. Это наш укороченный артикул, а у поставщика в прайсе в наличии только один товар, и это ERA-200DB-1A9DR. в Итоге при сопоставлении нашего каталога с прайсом поставщика, напротив обоих наших артикулов возвращается результат ERA-200DB-1A9DR. Сопоставление в ВПР идет не по точному совпадению, а по вхождению искомого артикула, поэтому наш ERA-200DB-1A подходит к ERA-200DB-1A9DR полным вхождением. Плюсом накладывается и то, что те допсимволы в конце каждого артикула поставщика, которые отсечены у нас, не имеют какой либо логики определенной, где то есть 2, где то 1, где то 4 допсимвола, т.к. что отсечь их, кроме как руками не выходит. В приложенном файле краткий кусок прайсов, по которому в принципе можно понять суть проблемы, в столбце А список наших артикулов, в столбце E артикулы поставщика. В столбце С вариант нашего решения, который в этом же примере и выдает кучу ошибок. В столбце F руками сделано то, что хочется получать автоматизированно с помощью формул.

Спасибо всем заранее, если подскажете какие то варианты.
К сообщению приложен файл: 4712467.xlsx(13Kb)
 
Ответить
СообщениеДобрый день, уважаемые профи Экселя.

По работе сформировалась задачка, на первый взгляд, показавшаяся очень простой, но по факту я ее не смог решить. Не хватает знаний формул, а может и макросов.

Смысл вот в чем, есть список товаров у нашей организации, с артикулами, которые являются названиями товара. И есть прайс от поставщика по этим товарам, но они используют в названии/артикуле чуть другой формат, у них полное название, поэтому в артикуле содержатся дополнительные символы, которые используют производители, а в магазинах они отсекаются. К примеру, у нас товар называется "EFR-539BK-1A2" а у них "EFR-539BK-1A2VUDF". То есть их название длиннее на 4 последних символа. Нам необходимо произвести сопоставление наших артикулов с их Артикулами, чтобы всегда быстро ориентироваться по наличию товаров и прочим коммерческим делам. Первое что пришло в голову, это ВПР, но по факту у меня ничего не вышло. Он решает часть проблемы, но я не смог найти выход из такой ситуации. К сожалению некоторые похожие товары имеют очень похожие артикулы и отличаются одним дополнительным символом, к примеру у нас есть товары ERA-200DB-1A и ERA-200DB-1A9. Это наш укороченный артикул, а у поставщика в прайсе в наличии только один товар, и это ERA-200DB-1A9DR. в Итоге при сопоставлении нашего каталога с прайсом поставщика, напротив обоих наших артикулов возвращается результат ERA-200DB-1A9DR. Сопоставление в ВПР идет не по точному совпадению, а по вхождению искомого артикула, поэтому наш ERA-200DB-1A подходит к ERA-200DB-1A9DR полным вхождением. Плюсом накладывается и то, что те допсимволы в конце каждого артикула поставщика, которые отсечены у нас, не имеют какой либо логики определенной, где то есть 2, где то 1, где то 4 допсимвола, т.к. что отсечь их, кроме как руками не выходит. В приложенном файле краткий кусок прайсов, по которому в принципе можно понять суть проблемы, в столбце А список наших артикулов, в столбце E артикулы поставщика. В столбце С вариант нашего решения, который в этом же примере и выдает кучу ошибок. В столбце F руками сделано то, что хочется получать автоматизированно с помощью формул.

Спасибо всем заранее, если подскажете какие то варианты.

Автор - slaiter
Дата добавления - 07.11.2017 в 17:37
Nic70y Дата: Вторник, 07.11.2017, 20:10 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4185
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
с помощью формул
массивная
Код
=ВПР(A2&"*";ЕСЛИ(ЕОШ(ПОИСК(ПОДСТАВИТЬ(ЕСЛИОШИБКА(ВПР(A2&"*";A$1:A1;1;);"ю")&ЕСЛИОШИБКА(ВПР(A2&"*";A3:A$10;1;);"ю");"ю";;1);E$2:E$8));E$2:E$8);1;)
К сообщению приложен файл: 4141019.xlsx(13Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
с помощью формул
массивная
Код
=ВПР(A2&"*";ЕСЛИ(ЕОШ(ПОИСК(ПОДСТАВИТЬ(ЕСЛИОШИБКА(ВПР(A2&"*";A$1:A1;1;);"ю")&ЕСЛИОШИБКА(ВПР(A2&"*";A3:A$10;1;);"ю");"ю";;1);E$2:E$8));E$2:E$8);1;)

Автор - Nic70y
Дата добавления - 07.11.2017 в 20:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставление двух прайсов с разным форматом артикулов (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!