Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Распределение на другой лист по нескольким условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Распределение на другой лист по нескольким условиям (Формулы/Formulas)
Распределение на другой лист по нескольким условиям
Suspension Дата: Четверг, 09.11.2017, 18:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер!

Помогите, пожалуйста, со следующей задачей. На листе "data" таблица, в которой содержится список фамилий? аудитров, закрепленных за этими людьми и логинами самих людей.

нужно на лист "распределение" сделать это самое распределение по следующим условиям:
1) под каждым аудитором собирается список логинов его подопечных (пример того что надо получить на выходе есть в файле)
2) если у подопечного логин отсутствует, то он в список аудитора не попадает
3) список строится автоматически, при любом изменении в столбцах B:E на листе "Data" изменения перестраивают списки на листе "Распределение" в.т.ч. при полном перезаливе данных в исходную таблицу (выделена синим цветом).

Список исходных данных подразумевается из 300+ фамилий, поэтому работать, видимо, нужно со всем диапазоном B:E

Возможно ли это сделать без макросов, поскольку файлу предстоит жить и работать в Excel Online? Спасибо!
К сообщению приложен файл: Sample1.xlsx(10Kb)


Сообщение отредактировал Suspension - Четверг, 09.11.2017, 18:02
 
Ответить
СообщениеДобрый вечер!

Помогите, пожалуйста, со следующей задачей. На листе "data" таблица, в которой содержится список фамилий? аудитров, закрепленных за этими людьми и логинами самих людей.

нужно на лист "распределение" сделать это самое распределение по следующим условиям:
1) под каждым аудитором собирается список логинов его подопечных (пример того что надо получить на выходе есть в файле)
2) если у подопечного логин отсутствует, то он в список аудитора не попадает
3) список строится автоматически, при любом изменении в столбцах B:E на листе "Data" изменения перестраивают списки на листе "Распределение" в.т.ч. при полном перезаливе данных в исходную таблицу (выделена синим цветом).

Список исходных данных подразумевается из 300+ фамилий, поэтому работать, видимо, нужно со всем диапазоном B:E

Возможно ли это сделать без макросов, поскольку файлу предстоит жить и работать в Excel Online? Спасибо!

Автор - Suspension
Дата добавления - 09.11.2017 в 18:01
jakim Дата: Четверг, 09.11.2017, 18:56 | Сообщение № 2
Группа: Друзья
Ранг: Ветеран
Сообщений: 807
Репутация: 209 ±
Замечаний: 0% ±

Предлагаю решение формулой

Код
=IFERROR(INDEX(Data!$B$2:$B$100;AGGREGATE(15;6;ROW($1:$100)/(Data!$C$2:$C$100=A$1)/(Data!$E$2:$E$100<>"");ROWS($2:2)));"")
К сообщению приложен файл: Sample1-1.xlsx(11Kb)
 
Ответить
Сообщение
Предлагаю решение формулой

Код
=IFERROR(INDEX(Data!$B$2:$B$100;AGGREGATE(15;6;ROW($1:$100)/(Data!$C$2:$C$100=A$1)/(Data!$E$2:$E$100<>"");ROWS($2:2)));"")

Автор - jakim
Дата добавления - 09.11.2017 в 18:56
Suspension Дата: Четверг, 09.11.2017, 20:53 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
jakim, большое спасибо! Решение полностью подходит, правда выводить надо было не фамилии, а логины, но это я уже сам исправил.

Если есть еще варианты решения, было бы интересно посмотреть и их, уже в рамках моего саморазвития.


Сообщение отредактировал Suspension - Четверг, 09.11.2017, 20:54
 
Ответить
Сообщениеjakim, большое спасибо! Решение полностью подходит, правда выводить надо было не фамилии, а логины, но это я уже сам исправил.

Если есть еще варианты решения, было бы интересно посмотреть и их, уже в рамках моего саморазвития.

Автор - Suspension
Дата добавления - 09.11.2017 в 20:53
buchlotnik Дата: Четверг, 09.11.2017, 21:29 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3327
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
ну вот такая массивка:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Data!$E$1:$E$10;НАИМЕНЬШИЙ(ЕСЛИ((Data!$C$2:$C$10=A$1)*ЕТЕКСТ(Data!$E$2:$E$10);СТРОКА(Data!$C$2:$C$10);"");СТРОКА(A1)));"")
К сообщению приложен файл: 0000965.xlsx(11Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениену вот такая массивка:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Data!$E$1:$E$10;НАИМЕНЬШИЙ(ЕСЛИ((Data!$C$2:$C$10=A$1)*ЕТЕКСТ(Data!$E$2:$E$10);СТРОКА(Data!$C$2:$C$10);"");СТРОКА(A1)));"")

Автор - buchlotnik
Дата добавления - 09.11.2017 в 21:29
Nic70y Дата: Четверг, 09.11.2017, 22:40 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4185
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
вариант:
в ID аудитора
Код
=ЕСЛИ(СЧЁТЕСЛИ(C$1:C2;C2)=1;ЦЕЛОЕ(МАКС(A$1:A1))+1;ЦЕЛОЕ(ИНДЕКС(A$1:A1;ПОИСКПОЗ(C2;C$1:C1;))))+СЧЁТЕСЛИМН(C$1:C2;C2;E$1:E2;"<>")/100

в распределение 1 стр.
Код
=ЕСНД(ВПР(1,01;Data!A:E;3);"")
и т.п.
и формула
Код
=ЕСНД(ВПР((СТОЛБЕЦ()+1)/2+(СТРОКА()-1)/100;Data!$A:$E;5;);"")
К сообщению приложен файл: 9156829.xlsx(11Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениевариант:
в ID аудитора
Код
=ЕСЛИ(СЧЁТЕСЛИ(C$1:C2;C2)=1;ЦЕЛОЕ(МАКС(A$1:A1))+1;ЦЕЛОЕ(ИНДЕКС(A$1:A1;ПОИСКПОЗ(C2;C$1:C1;))))+СЧЁТЕСЛИМН(C$1:C2;C2;E$1:E2;"<>")/100

в распределение 1 стр.
Код
=ЕСНД(ВПР(1,01;Data!A:E;3);"")
и т.п.
и формула
Код
=ЕСНД(ВПР((СТОЛБЕЦ()+1)/2+(СТРОКА()-1)/100;Data!$A:$E;5;);"")

Автор - Nic70y
Дата добавления - 09.11.2017 в 22:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Распределение на другой лист по нескольким условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!