Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование значений из диапазона по заданному интервалу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование значений из диапазона по заданному интервалу (Формулы/Formulas)
Суммирование значений из диапазона по заданному интервалу
YEJ Дата: Вторник, 21.11.2017, 14:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Столкнулся с проблемой: есть диапазон значений (в моём примере B4:AF34), есть интервалы, которые я бы хотел менять (E39:F46). Необходимо искать значения из диапазона, входящие в интервал и складывать их. Функцией СУММЕСЛИ сделать этого не получилось..
К сообщению приложен файл: __.xls(31.5 Kb)
 
Ответить
СообщениеЗдравствуйте. Столкнулся с проблемой: есть диапазон значений (в моём примере B4:AF34), есть интервалы, которые я бы хотел менять (E39:F46). Необходимо искать значения из диапазона, входящие в интервал и складывать их. Функцией СУММЕСЛИ сделать этого не получилось..

Автор - YEJ
Дата добавления - 21.11.2017 в 14:03
Nic70y Дата: Вторник, 21.11.2017, 14:12 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4882
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
и что обозначают Ваши интервалы?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеи что обозначают Ваши интервалы?

Автор - Nic70y
Дата добавления - 21.11.2017 в 14:12
Che79 Дата: Вторник, 21.11.2017, 14:12 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
YEJ, здравствуйте. Навскидку. Оно?
Код
=СУММПРОИЗВ($B$4:$AF$4*($B$4:$AF$4>=E39)*($B$4:$AF$4<=F39))

Да, я поторопился и лохонулся, вариант Михаила (сообщ. #4) верный


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Вторник, 21.11.2017, 14:17
 
Ответить
СообщениеYEJ, здравствуйте. Навскидку. Оно?
Код
=СУММПРОИЗВ($B$4:$AF$4*($B$4:$AF$4>=E39)*($B$4:$AF$4<=F39))

Да, я поторопился и лохонулся, вариант Михаила (сообщ. #4) верный

Автор - Che79
Дата добавления - 21.11.2017 в 14:12
buchlotnik Дата: Вторник, 21.11.2017, 14:14 | Сообщение № 4
Группа: Заблокированные
Ранг: Участник клуба
Сообщений: 3443
Репутация: 924 ±
Замечаний: 20% ±

2010, 2013, 2016 RUS / ENG
Здравствуйте, так нужно? (или нужно включать граничные значения в оба интервала?)
Код
=СУММПРОИЗВ($E$4:$AF$34*($E$4:$AF$34>E39)*($E$4:$AF$34<=F39))
К сообщению приложен файл: 9496197.xls(38.5 Kb)


Сообщение отредактировал buchlotnik - Вторник, 21.11.2017, 14:15
 
Ответить
СообщениеЗдравствуйте, так нужно? (или нужно включать граничные значения в оба интервала?)
Код
=СУММПРОИЗВ($E$4:$AF$34*($E$4:$AF$34>E39)*($E$4:$AF$34<=F39))

Автор - buchlotnik
Дата добавления - 21.11.2017 в 14:14
YEJ Дата: Вторник, 21.11.2017, 14:17 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Che79, buchlotnik, Да, спасибо! То что нужно.
 
Ответить
СообщениеChe79, buchlotnik, Да, спасибо! То что нужно.

Автор - YEJ
Дата добавления - 21.11.2017 в 14:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование значений из диапазона по заданному интервалу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!