Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос значений из таблицы в таблицу без пустых строк - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос значений из таблицы в таблицу без пустых строк (Формулы/Formulas)
Перенос значений из таблицы в таблицу без пустых строк
Sergo99 Дата: Среда, 22.11.2017, 20:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый времени суток! Помогите в решении задачи! Требуется, чтобы из Таблицы 1, данные автоматически переносились в Таблицу 2, но без промежуточных пустых строк между данными в Таблице 1.
К сообщению приложен файл: 111.xlsm(19Kb)
 
Ответить
СообщениеДобрый времени суток! Помогите в решении задачи! Требуется, чтобы из Таблицы 1, данные автоматически переносились в Таблицу 2, но без промежуточных пустых строк между данными в Таблице 1.

Автор - Sergo99
Дата добавления - 22.11.2017 в 20:18
_Boroda_ Дата: Среда, 22.11.2017, 20:30 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(I$4:I$23;НАИМЕНЬШИЙ(ЕСЛИ(I$4:I$23<>"";$H$4:$H$23);СТРОКА(M1)));"")

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
Из основной таблицы
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$4:B$23;НАИМЕНЬШИЙ(ЕСЛИ(E$4:E$23<>"";$A$4:$A$23);СТРОКА(Q1)));"")

Можно все сложить с помощью сводной таблицы

Файл перевложил
К сообщению приложен файл: 111_1.xlsm(25Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(I$4:I$23;НАИМЕНЬШИЙ(ЕСЛИ(I$4:I$23<>"";$H$4:$H$23);СТРОКА(M1)));"")

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
Из основной таблицы
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$4:B$23;НАИМЕНЬШИЙ(ЕСЛИ(E$4:E$23<>"";$A$4:$A$23);СТРОКА(Q1)));"")

Можно все сложить с помощью сводной таблицы

Файл перевложил

Автор - _Boroda_
Дата добавления - 22.11.2017 в 20:30
Pelena Дата: Среда, 22.11.2017, 20:30 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11842
Репутация: 2609 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$4:$B$23;НАИМЕНЬШИЙ(ЕСЛИ($E$4:$E$23=$F$3;СТРОКА($B$4:$B$23)-3);СТРОКА(A1)));"")
К сообщению приложен файл: 6748995.xlsm(19Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$4:$B$23;НАИМЕНЬШИЙ(ЕСЛИ($E$4:$E$23=$F$3;СТРОКА($B$4:$B$23)-3);СТРОКА(A1)));"")

Автор - Pelena
Дата добавления - 22.11.2017 в 20:30
_Igor_61 Дата: Среда, 22.11.2017, 20:51 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 238
Репутация: 44 ±
Замечаний: 20% ±

Excel 2007
Ну и поскольку пример в xlsm - не удержался, слепил макрос.
Непонятно только, для чего нужна Таблица 1, можно же сразу из основной значения тянуть, что Елена и сделала :)
К сообщению приложен файл: 5096462.xlsm(23Kb)


Сообщение отредактировал _Igor_61 - Среда, 22.11.2017, 20:51
 
Ответить
СообщениеНу и поскольку пример в xlsm - не удержался, слепил макрос.
Непонятно только, для чего нужна Таблица 1, можно же сразу из основной значения тянуть, что Елена и сделала :)

Автор - _Igor_61
Дата добавления - 22.11.2017 в 20:51
Sergo99 Дата: Суббота, 25.11.2017, 14:56 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо! всё супер, работает. то что нужно.
 
Ответить
СообщениеСпасибо! всё супер, работает. то что нужно.

Автор - Sergo99
Дата добавления - 25.11.2017 в 14:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос значений из таблицы в таблицу без пустых строк (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!