Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула ексель. Как отобрать определенный номер. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула ексель. Как отобрать определенный номер. (Формулы/Formulas)
Формула ексель. Как отобрать определенный номер.
Znenzi Дата: Четверг, 23.11.2017, 14:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день.
Как можно в эксель подставить вместо букв цифры. например, нам нужно перебрать красивые табельные номера из нескольких тыс. Есть классы типа: AAABBBB. И нужно, чтобы ексель нашел номер удовлетворяющий этому критерию. (например: 6667777 или 1112222, где 1 и 6 =A; 2 и 7=B ).
Файл во вложении.
К сообщению приложен файл: 3176382.xlsx(28Kb)
 
Ответить
СообщениеДобрый день.
Как можно в эксель подставить вместо букв цифры. например, нам нужно перебрать красивые табельные номера из нескольких тыс. Есть классы типа: AAABBBB. И нужно, чтобы ексель нашел номер удовлетворяющий этому критерию. (например: 6667777 или 1112222, где 1 и 6 =A; 2 и 7=B ).
Файл во вложении.

Автор - Znenzi
Дата добавления - 23.11.2017 в 14:47
buchlotnik Дата: Четверг, 23.11.2017, 15:44 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3437
Репутация: 922 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
ну чисто по примеру:
Код
=((A2&"")=(ПОВТОР(ЛЕВСИМВ(A2;1);3)&ПОВТОР(ПРАВСИМВ(A2;1);4)))*(ЛЕВСИМВ(A2;1)<>ПРАВСИМВ(A2;1))
К сообщению приложен файл: 3222194.xlsx(43Kb)


"заступлюсь за Юрия" - публичный плевок в душу!
 
Ответить
Сообщениену чисто по примеру:
Код
=((A2&"")=(ПОВТОР(ЛЕВСИМВ(A2;1);3)&ПОВТОР(ПРАВСИМВ(A2;1);4)))*(ЛЕВСИМВ(A2;1)<>ПРАВСИМВ(A2;1))

Автор - buchlotnik
Дата добавления - 23.11.2017 в 15:44
bmv98rus Дата: Четверг, 23.11.2017, 15:56 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 686
Репутация: 114 ±
Замечаний: 0% ±

Excel 2013/2016
ну или так
Код
=(LEFT(A2;3)=TRIM(LEFT(A2;1)*111))*(RIGHT(A2;4)=TRIM(RIGHT(A2;1)*1111))


А если взять методу тезки, то
Код
=A2=--(LEFT(A2;1)*111&RIGHT(A2;1)*1111)


[p.s.] красивый табельный номер - просто интересно, это для чего?


Сообщение отредактировал bmv98rus - Четверг, 23.11.2017, 16:10
 
Ответить
Сообщениену или так
Код
=(LEFT(A2;3)=TRIM(LEFT(A2;1)*111))*(RIGHT(A2;4)=TRIM(RIGHT(A2;1)*1111))


А если взять методу тезки, то
Код
=A2=--(LEFT(A2;1)*111&RIGHT(A2;1)*1111)


[p.s.] красивый табельный номер - просто интересно, это для чего?

Автор - bmv98rus
Дата добавления - 23.11.2017 в 15:56
vikttur Дата: Четверг, 23.11.2017, 17:57 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2557
Репутация: 460 ±
Замечаний: 0% ±

Цитата
6667777 или 1112222, где 1 и 6 =A; 2 и 7=B

А точнее? когда 2, а когда 7? Какая связь букв с цифрами?


Сообщение отредактировал vikttur - Четверг, 23.11.2017, 17:57
 
Ответить
Сообщение
Цитата
6667777 или 1112222, где 1 и 6 =A; 2 и 7=B

А точнее? когда 2, а когда 7? Какая связь букв с цифрами?

Автор - vikttur
Дата добавления - 23.11.2017 в 17:57
output Дата: Четверг, 23.11.2017, 17:57 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Т.е. ищет только один номер. Если нужны все красивые исходя из файла на листе2? Как сделать так, чтобы ексель искал сразу все?
 
Ответить
СообщениеТ.е. ищет только один номер. Если нужны все красивые исходя из файла на листе2? Как сделать так, чтобы ексель искал сразу все?

Автор - output
Дата добавления - 23.11.2017 в 17:57
bmv98rus Дата: Четверг, 23.11.2017, 18:07 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 686
Репутация: 114 ±
Замечаний: 0% ±

Excel 2013/2016
vikttur,
Виктор, ну тут же понятно все просто xxxXXXX. Пример только запутывает.

output,
тема не ваша , но просто отфильтровать.
 
Ответить
Сообщениеvikttur,
Виктор, ну тут же понятно все просто xxxXXXX. Пример только запутывает.

output,
тема не ваша , но просто отфильтровать.

Автор - bmv98rus
Дата добавления - 23.11.2017 в 18:07
vikttur Дата: Четверг, 23.11.2017, 18:09 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2557
Репутация: 460 ±
Замечаний: 0% ±

тут же понятно все просто

Да? Это тоже понятно? ABCCCCC, AAAABAB - это совсем не xxxXXXX.

Цитата
подставить вместо букв цифры.

Вот это можно. Из буквенных кодов в числовой (если буква в алфавите имеет порядковый номер не более 9):
Код
=СУММПРОИЗВ((КОДСИМВ(ПСТР(A2;{7;6;5;4;3;2;1};1))-64)*10^{0;1;2;3;4;5;6})
К сообщению приложен файл: 2973604.xlsx(11Kb)


Сообщение отредактировал vikttur - Четверг, 23.11.2017, 18:15
 
Ответить
Сообщение
тут же понятно все просто

Да? Это тоже понятно? ABCCCCC, AAAABAB - это совсем не xxxXXXX.

Цитата
подставить вместо букв цифры.

Вот это можно. Из буквенных кодов в числовой (если буква в алфавите имеет порядковый номер не более 9):
Код
=СУММПРОИЗВ((КОДСИМВ(ПСТР(A2;{7;6;5;4;3;2;1};1))-64)*10^{0;1;2;3;4;5;6})

Автор - vikttur
Дата добавления - 23.11.2017 в 18:09
Pelena Дата: Четверг, 23.11.2017, 18:15 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11842
Репутация: 2609 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
[offtop]
красивый табельный номер - просто интересно, это для чего?

Больше похоже на красивые телефонные номера :) [/offtop]


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение[offtop]
красивый табельный номер - просто интересно, это для чего?

Больше похоже на красивые телефонные номера :) [/offtop]

Автор - Pelena
Дата добавления - 23.11.2017 в 18:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула ексель. Как отобрать определенный номер. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!