Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование по нескольким критериям в табл с пустыми ячейка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по нескольким критериям в табл с пустыми ячейка (Формулы/Formulas)
Суммирование по нескольким критериям в табл с пустыми ячейка
DmitriyL Дата: Среда, 29.11.2017, 22:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2002
Здравствуйте, ув. Профессионалы и знатоки excel! Требуется Ваша помощь в следующей задаче:
- необходимо просуммировать значения по нескольким критериям в таблице где имеются пустые ячейки вида "". И сделать это желательно при помощи формулы массива. Вся проблема заключается в том, что при умножении единицы на пустую ячейку ("") в массиве получается #Знач, а не ноль, ну соответственно все выражение тоже #Знач
К сообщению приложен файл: 0241597.xls(18Kb)
 
Ответить
СообщениеЗдравствуйте, ув. Профессионалы и знатоки excel! Требуется Ваша помощь в следующей задаче:
- необходимо просуммировать значения по нескольким критериям в таблице где имеются пустые ячейки вида "". И сделать это желательно при помощи формулы массива. Вся проблема заключается в том, что при умножении единицы на пустую ячейку ("") в массиве получается #Знач, а не ноль, ну соответственно все выражение тоже #Знач

Автор - DmitriyL
Дата добавления - 29.11.2017 в 22:24
_Boroda_ Дата: Среда, 29.11.2017, 22:31 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Массивная, как хотели
Код
=СУММ((B$18:B$38=B2)*ТЕКСТ(C$18:C$38;"0;\0;0;\0"))

Обычная формула для 2007 и выше
Код
=СУММЕСЛИМН(C$18:C$38;B$18:B$38;B2;C$18:C$38;">0")

обычная для любой версии
Код
=СУММПРОИЗВ((B$18:B$38=B2)*ТЕКСТ(C$18:C$38;"0;\0;0;\0"))
К сообщению приложен файл: 0241597_1.xls(36Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Массивная, как хотели
Код
=СУММ((B$18:B$38=B2)*ТЕКСТ(C$18:C$38;"0;\0;0;\0"))

Обычная формула для 2007 и выше
Код
=СУММЕСЛИМН(C$18:C$38;B$18:B$38;B2;C$18:C$38;">0")

обычная для любой версии
Код
=СУММПРОИЗВ((B$18:B$38=B2)*ТЕКСТ(C$18:C$38;"0;\0;0;\0"))

Автор - _Boroda_
Дата добавления - 29.11.2017 в 22:31
DmitriyL Дата: Среда, 29.11.2017, 23:00 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2002
_Boroda_, Да, именно так - формула считает все верно. На данный момент я обескуражен и в замешательстве - пытаюсь разобраться в логике формулы. Например, а как изменится Ваша формула если мне нужно будет просуммировать не все положительные значения для каждой записи, а все отрицательные? Большое Вам Спасибо Борода за помощь!!!
 
Ответить
Сообщение_Boroda_, Да, именно так - формула считает все верно. На данный момент я обескуражен и в замешательстве - пытаюсь разобраться в логике формулы. Например, а как изменится Ваша формула если мне нужно будет просуммировать не все положительные значения для каждой записи, а все отрицательные? Большое Вам Спасибо Борода за помощь!!!

Автор - DmitriyL
Дата добавления - 29.11.2017 в 23:00
_Boroda_ Дата: Среда, 29.11.2017, 23:14 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Функция ТЕКСТ - это почти то, что мы пишем в пользовательском формате ячейки http://www.excelworld.ru/publ/hacks/formatting/format_user/63-1-0-141
В нашем случае это выглядит так
Положительные;Отрицательные;Ноль;Текст

0 - это то число (целое, по модулю), которое мы проверяем
\0 - это уже не число, а именно ноль (знак \ перед чем-либо указывает на то, что выводить нужно не код форматов, а именно тот символ, который находится после \)

Для отрицательных будет
\0;-0;0;\0


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФункция ТЕКСТ - это почти то, что мы пишем в пользовательском формате ячейки http://www.excelworld.ru/publ/hacks/formatting/format_user/63-1-0-141
В нашем случае это выглядит так
Положительные;Отрицательные;Ноль;Текст

0 - это то число (целое, по модулю), которое мы проверяем
\0 - это уже не число, а именно ноль (знак \ перед чем-либо указывает на то, что выводить нужно не код форматов, а именно тот символ, который находится после \)

Для отрицательных будет
\0;-0;0;\0

Автор - _Boroda_
Дата добавления - 29.11.2017 в 23:14
DmitriyL Дата: Среда, 29.11.2017, 23:35 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2002
Благодарю, буду вникать. Еще раз Спасибо. Приятно иметь дело с профессионалами
 
Ответить
СообщениеБлагодарю, буду вникать. Еще раз Спасибо. Приятно иметь дело с профессионалами

Автор - DmitriyL
Дата добавления - 29.11.2017 в 23:35
Che79 Дата: Четверг, 30.11.2017, 02:15 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 672
Репутация: 114 ±
Замечаний: 0% ±

Excel 2007, 2013
Еще вариант для решенной уже задачи,
при помощи формулы массива
Код
{=СУММ(ЕСЛИ(($C$18:$C$38>0)*($B$18:$B$38=B2);$C$18:$C$38))}
К сообщению приложен файл: 3694513.xls(34Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЕще вариант для решенной уже задачи,
при помощи формулы массива
Код
{=СУММ(ЕСЛИ(($C$18:$C$38>0)*($B$18:$B$38=B2);$C$18:$C$38))}

Автор - Che79
Дата добавления - 30.11.2017 в 02:15
DmitriyL Дата: Четверг, 30.11.2017, 14:46 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2002
Очень простое и понятное решение. Класс!!! Все гениальное - ПРОСТО!!! Спасибо за такое решение Che79

После 3,5 часов вникания в решение задачи при помощи формулы ТЕКСТ - все таки разобрался, оказалось все очень логично и понятно

Хотя с программой excel я знаком очень давно и на мой взгляд очень хорошо (помимо использования встроенных функций - писал макросы, создавал свои пользовательские функции средствами VBA и VB6, писал надстройки COM для excel средствами VB6), но решения задачи, представленные на форуме подняли мои навыки по использованию excel на новый уровень. Спасибо Бороде и Che79 за помощь, разъяснения и представленные решения!!!
 
Ответить
СообщениеОчень простое и понятное решение. Класс!!! Все гениальное - ПРОСТО!!! Спасибо за такое решение Che79

После 3,5 часов вникания в решение задачи при помощи формулы ТЕКСТ - все таки разобрался, оказалось все очень логично и понятно

Хотя с программой excel я знаком очень давно и на мой взгляд очень хорошо (помимо использования встроенных функций - писал макросы, создавал свои пользовательские функции средствами VBA и VB6, писал надстройки COM для excel средствами VB6), но решения задачи, представленные на форуме подняли мои навыки по использованию excel на новый уровень. Спасибо Бороде и Che79 за помощь, разъяснения и представленные решения!!!

Автор - DmitriyL
Дата добавления - 30.11.2017 в 14:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по нескольким критериям в табл с пустыми ячейка (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!