Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР - подстановка значения при отрицательном условии - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР - подстановка значения при отрицательном условии (Формулы/Formulas)
ВПР - подстановка значения при отрицательном условии
nechehov Дата: Четверг, 30.11.2017, 10:43 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!

Хочу избавиться от громоздкой формулы ЕСЛИ и подставлять нужное слово с помощью ВПР. Но как задать условие при отрицательном значении?
К сообщению приложен файл: 2196917.xlsx(9Kb)
 
Ответить
СообщениеДобрый день!

Хочу избавиться от громоздкой формулы ЕСЛИ и подставлять нужное слово с помощью ВПР. Но как задать условие при отрицательном значении?

Автор - nechehov
Дата добавления - 30.11.2017 в 10:43
ВладимирG Дата: Четверг, 30.11.2017, 10:54 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 131
Репутация: 21 ±
Замечаний: 0% ±

2007
Код
=ВПР(ЕСЛИ(C2<0;"<0";C2);$F$2:$G$3;2;0)
 
Ответить
Сообщение
Код
=ВПР(ЕСЛИ(C2<0;"<0";C2);$F$2:$G$3;2;0)

Автор - ВладимирG
Дата добавления - 30.11.2017 в 10:54
_Boroda_ Дата: Четверг, 30.11.2017, 10:55 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В первом столбце диапазона второго аргумента ВПР нужно ставить данные по возрастанию,
К сообщению приложен файл: 2196917_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ первом столбце диапазона второго аргумента ВПР нужно ставить данные по возрастанию,

Автор - _Boroda_
Дата добавления - 30.11.2017 в 10:55
nechehov Дата: Четверг, 30.11.2017, 11:02 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Спасибо! Я так понимаю для отрицательных значений выбираем наименьшее число в условии, чтобы значения в задаче укладывались в диапазон от наименьшего до 0?
 
Ответить
Сообщение_Boroda_, Спасибо! Я так понимаю для отрицательных значений выбираем наименьшее число в условии, чтобы значения в задаче укладывались в диапазон от наименьшего до 0?

Автор - nechehov
Дата добавления - 30.11.2017 в 11:02
_Boroda_ Дата: Четверг, 30.11.2017, 11:07 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ага


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеАга

Автор - _Boroda_
Дата добавления - 30.11.2017 в 11:07
nechehov Дата: Четверг, 30.11.2017, 11:40 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, проблема оказалась сложнее. Когда появляется в колонке Изменение отрицательное значение, то это может означать как Решено, так и Уменьшение проблемы и это зависит от того сколько стало во 2 колонке - 0 или меньше, чем в 1 колонке. В таком случае ВПР подходит или уже нужно ЕСЛИ использовать?
К сообщению приложен файл: 1577966.xlsx(50Kb)
 
Ответить
Сообщение_Boroda_, проблема оказалась сложнее. Когда появляется в колонке Изменение отрицательное значение, то это может означать как Решено, так и Уменьшение проблемы и это зависит от того сколько стало во 2 колонке - 0 или меньше, чем в 1 колонке. В таком случае ВПР подходит или уже нужно ЕСЛИ использовать?

Автор - nechehov
Дата добавления - 30.11.2017 в 11:40
_Boroda_ Дата: Четверг, 30.11.2017, 12:14 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так?
Код
=ВПР((B2=0)-ЗНАК(C2);F$2:G$5;2;)
К сообщению приложен файл: 1577966_1.xlsx(50Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак?
Код
=ВПР((B2=0)-ЗНАК(C2);F$2:G$5;2;)

Автор - _Boroda_
Дата добавления - 30.11.2017 в 12:14
nechehov Дата: Четверг, 30.11.2017, 14:31 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Да, спасибо вам! Получше выглядит, чем ЕСЛИ.
 
Ответить
Сообщение_Boroda_, Да, спасибо вам! Получше выглядит, чем ЕСЛИ.

Автор - nechehov
Дата добавления - 30.11.2017 в 14:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР - подстановка значения при отрицательном условии (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!