Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР по первым 10 символам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР по первым 10 символам (Формулы/Formulas)
ВПР по первым 10 символам
Gopronotmore Дата: Пятница, 01.12.2017, 13:39 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 104
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Добрый день форумчане,

вопрос как то можно прописать формула ВПР, что бы она находила совпадения только по первым 4 символам

была похожая тема но не то http://www.excelworld.ru/forum/2-35406-1
К сообщению приложен файл: VPR___.xlsx(8.5 Kb)


Сообщение отредактировал Gopronotmore - Пятница, 01.12.2017, 13:39
 
Ответить
СообщениеДобрый день форумчане,

вопрос как то можно прописать формула ВПР, что бы она находила совпадения только по первым 4 символам

была похожая тема но не то http://www.excelworld.ru/forum/2-35406-1

Автор - Gopronotmore
Дата добавления - 01.12.2017 в 13:39
sboy Дата: Пятница, 01.12.2017, 13:51 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Так 10 или 4? определитесь)
Код
=ВПР(ЛЕВБ(D5;4)&"*";A:B;2;0)
К сообщению приложен файл: VPR_.xlsx(8.6 Kb)
 
Ответить
СообщениеДобрый день.
Так 10 или 4? определитесь)
Код
=ВПР(ЛЕВБ(D5;4)&"*";A:B;2;0)

Автор - sboy
Дата добавления - 01.12.2017 в 13:51
_Boroda_ Дата: Пятница, 01.12.2017, 14:14 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
но не то

Как "не то"? а вторая формула во втором посте?
Код
=СУММЕСЛИ(A:A;ЛЕВБ(D3;4)&"*";B:B)
Она не ВПР и считать немного иначе будет (см. файл), но иногда как раз она нужна
Оттуда же
Код
=ПРОСМОТР(;-1/ПОИСК(ЛЕВБ(D2;4);A$2:A$9);B$2:B$9)

Код
=ИНДЕКС(B:B;ПОИСКПОЗ(ЛЕВБ(D2;4)&"*";A:A;))
К сообщению приложен файл: VPR_1.xlsx(9.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
но не то

Как "не то"? а вторая формула во втором посте?
Код
=СУММЕСЛИ(A:A;ЛЕВБ(D3;4)&"*";B:B)
Она не ВПР и считать немного иначе будет (см. файл), но иногда как раз она нужна
Оттуда же
Код
=ПРОСМОТР(;-1/ПОИСК(ЛЕВБ(D2;4);A$2:A$9);B$2:B$9)

Код
=ИНДЕКС(B:B;ПОИСКПОЗ(ЛЕВБ(D2;4)&"*";A:A;))

Автор - _Boroda_
Дата добавления - 01.12.2017 в 14:14
Gopronotmore Дата: Пятница, 01.12.2017, 14:35 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 104
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Спасибо большое, вы очень помогли
 
Ответить
СообщениеСпасибо большое, вы очень помогли

Автор - Gopronotmore
Дата добавления - 01.12.2017 в 14:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР по первым 10 символам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!