Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/минесли, максесли - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » минесли, максесли (Настройки Excel/Setup)
минесли, максесли
YBX Дата: Воскресенье, 03.12.2017, 00:38 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день! Работаю в 2007 офисе. Подскажите пжлст можно ли и если можно то как добавить в него функции минесли, максесли?
И если нет то может у кого есть ссылка где скачать 2016 офис с этими функциями? Я слышал что в 2016 они есть. Но все что качал с интернета не устанавливается...
Спасибо! :)
 
Ответить
СообщениеДобрый день! Работаю в 2007 офисе. Подскажите пжлст можно ли и если можно то как добавить в него функции минесли, максесли?
И если нет то может у кого есть ссылка где скачать 2016 офис с этими функциями? Я слышал что в 2016 они есть. Но все что качал с интернета не устанавливается...
Спасибо! :)

Автор - YBX
Дата добавления - 03.12.2017 в 00:38
buchlotnik Дата: Воскресенье, 03.12.2017, 00:44 | Сообщение № 2
Группа: Заблокированные
Ранг: Участник клуба
Сообщений: 3443
Репутация: 924 ±
Замечаний: 20% ±

2010, 2013, 2016 RUS / ENG
YBX, минесли и максесли, конечно, удобны, но за неимением 2016 их легко реализовать на несложных формулах. Вы бы пример ваших данных показали
 
Ответить
СообщениеYBX, минесли и максесли, конечно, удобны, но за неимением 2016 их легко реализовать на несложных формулах. Вы бы пример ваших данных показали

Автор - buchlotnik
Дата добавления - 03.12.2017 в 00:44
YBX Дата: Воскресенье, 03.12.2017, 00:58 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
buchlotnik Пример приложил... К коэффициенту в столбце А ищем мин и мах из столбца В.
К сообщению приложен файл: 600.xlsx(10.8 Kb)
 
Ответить
Сообщениеbuchlotnik Пример приложил... К коэффициенту в столбце А ищем мин и мах из столбца В.

Автор - YBX
Дата добавления - 03.12.2017 в 00:58
vikttur Дата: Воскресенье, 03.12.2017, 01:40 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2715
Репутация: 477 ±
Замечаний: 0% ±

Диапазоны блоков коэффициентов разные (в примере по 16 и 10 строк)? Сложнее.
Алгоритм: в столбце С или D ищем последнее числовое значение, сдвигаемся на строку ниже - это начало диапазона. Его оконсание - на строке, после которой меняется коэффициент. Но вот беда - для первого диапазона нет числа выше...
Для того, чтобы избежать усложнения формулы, в первой строке столбцов С и D записать любое число:
Код
=ЕСЛИ($A2=$A3;"";МИН(ИНДЕКС($B$1:$B1;ПОИСКПОЗ(9E+307;C$1:C1)+1):$B2))

Для МАКС достаточно заменить функцию.
К сообщению приложен файл: 6524369.xlsx(12.9 Kb)
 
Ответить
СообщениеДиапазоны блоков коэффициентов разные (в примере по 16 и 10 строк)? Сложнее.
Алгоритм: в столбце С или D ищем последнее числовое значение, сдвигаемся на строку ниже - это начало диапазона. Его оконсание - на строке, после которой меняется коэффициент. Но вот беда - для первого диапазона нет числа выше...
Для того, чтобы избежать усложнения формулы, в первой строке столбцов С и D записать любое число:
Код
=ЕСЛИ($A2=$A3;"";МИН(ИНДЕКС($B$1:$B1;ПОИСКПОЗ(9E+307;C$1:C1)+1):$B2))

Для МАКС достаточно заменить функцию.

Автор - vikttur
Дата добавления - 03.12.2017 в 01:40
YBX Дата: Воскресенье, 03.12.2017, 02:08 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
vikttur

Спасибо! Формула крутая, работает! hands
Но блин, после функции "МИН" становится мне непонятной... %)
Все таки попробую найти 2016 офис, если не выйдет буду использовать Вашу формулу! А что в ней значит "9E+307"?
 
Ответить
Сообщение
vikttur

Спасибо! Формула крутая, работает! hands
Но блин, после функции "МИН" становится мне непонятной... %)
Все таки попробую найти 2016 офис, если не выйдет буду использовать Вашу формулу! А что в ней значит "9E+307"?

Автор - YBX
Дата добавления - 03.12.2017 в 02:08
buchlotnik Дата: Воскресенье, 03.12.2017, 02:14 | Сообщение № 6
Группа: Заблокированные
Ранг: Участник клуба
Сообщений: 3443
Репутация: 924 ±
Замечаний: 20% ±

2010, 2013, 2016 RUS / ENG
Цитата
попробую найти 2016
YBX, в вашей задаче это не поможет - тут МИНЕСЛИ() некуда приматывать, точнее можно, но, поверьте, у Виктора формула проще


Сообщение отредактировал buchlotnik - Воскресенье, 03.12.2017, 02:14
 
Ответить
Сообщение
Цитата
попробую найти 2016
YBX, в вашей задаче это не поможет - тут МИНЕСЛИ() некуда приматывать, точнее можно, но, поверьте, у Виктора формула проще

Автор - buchlotnik
Дата добавления - 03.12.2017 в 02:14
Pelena Дата: Воскресенье, 03.12.2017, 07:47 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 13218
Репутация: 2908 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
YBX, название темы никуда не годится. Сформулируйте суть задачи и отразите её в названии темы


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеYBX, название темы никуда не годится. Сформулируйте суть задачи и отразите её в названии темы

Автор - Pelena
Дата добавления - 03.12.2017 в 07:47
vikttur Дата: Воскресенье, 03.12.2017, 11:51 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2715
Репутация: 477 ±
Замечаний: 0% ±

Минимальное в диапазоне от найденной позиции до текущей строки:
Код
=МИН(ИНДЕКС($B$1:$B1;позиция):$B2)

Позиция:
Код
ПОИСКПОЗ(9E+307;C$1:C1)+1

Поиск наибольшего числа (9E+307) в диапазоне выше ячейки с формулой. Если не находим (а мы его, естественно, не находим), то функция покажет положение последнего числового значения.
+1 - не забываем спуститься на строку ниже
 
Ответить
СообщениеМинимальное в диапазоне от найденной позиции до текущей строки:
Код
=МИН(ИНДЕКС($B$1:$B1;позиция):$B2)

Позиция:
Код
ПОИСКПОЗ(9E+307;C$1:C1)+1

Поиск наибольшего числа (9E+307) в диапазоне выше ячейки с формулой. Если не находим (а мы его, естественно, не находим), то функция покажет положение последнего числового значения.
+1 - не забываем спуститься на строку ниже

Автор - vikttur
Дата добавления - 03.12.2017 в 11:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » минесли, максесли (Настройки Excel/Setup)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!