Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Преобразование строк в столбцы один под другим - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразование строк в столбцы один под другим (Формулы/Formulas)
Преобразование строк в столбцы один под другим
sm84 Дата: Четверг, 21.12.2017, 22:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Помогите решить проблему
Траспонирование делает столбцы один за другим, а нужно один под другим…
Есть ли какое-то решение?
К сообщению приложен файл: 2345.xlsx(11.7 Kb)


Сообщение отредактировал sm84 - Четверг, 21.12.2017, 22:18
 
Ответить
СообщениеПомогите решить проблему
Траспонирование делает столбцы один за другим, а нужно один под другим…
Есть ли какое-то решение?

Автор - sm84
Дата добавления - 21.12.2017 в 22:16
Nic70y Дата: Пятница, 22.12.2017, 07:35 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4560
Репутация: 985 ±
Замечаний: 0% ±

Excel 2013
формульный вариаент
Код
=ИНДЕКС(A$2:V$5;(СТРОКА(AA1)-1)/22+1;ОСТАТ(СТРОКА(AA1)-1;22)+1)
К сообщению приложен файл: 3601678.xlsx(13.1 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеформульный вариаент
Код
=ИНДЕКС(A$2:V$5;(СТРОКА(AA1)-1)/22+1;ОСТАТ(СТРОКА(AA1)-1;22)+1)

Автор - Nic70y
Дата добавления - 22.12.2017 в 07:35
bmv98rus Дата: Пятница, 22.12.2017, 07:50 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1180
Репутация: 204 ±
Замечаний: 0% ±

Excel 2013/2016
sm84, Есть несколько вариантов,
формулами с использованием вычисляемой позиции нужной ячейки (требует доработки)
Скриптом
Если вариант 1 применить только для имен полей, чтоб не трансформировать и копировать имена руками( как Вы сделали), то можно как в приложении. Вопрос в том, как часто это надо делать и от этого выбирать и готовить вариант.
К сообщению приложен файл: Copy_of_2345.xlsx(13.7 Kb)


Сообщение отредактировал bmv98rus - Пятница, 22.12.2017, 07:52
 
Ответить
Сообщениеsm84, Есть несколько вариантов,
формулами с использованием вычисляемой позиции нужной ячейки (требует доработки)
Скриптом
Если вариант 1 применить только для имен полей, чтоб не трансформировать и копировать имена руками( как Вы сделали), то можно как в приложении. Вопрос в том, как часто это надо делать и от этого выбирать и готовить вариант.

Автор - bmv98rus
Дата добавления - 22.12.2017 в 07:50
mechanix85 Дата: Пятница, 22.12.2017, 08:12 | Сообщение № 4
Группа: Друзья
Ранг: Форумчанин
Сообщений: 240
Репутация: 34 ±
Замечаний: 0% ±

вариант с помощью power query. Для 2013 и выше Оффиса
К сообщению приложен файл: 2345_mechanix85.xlsx(21.9 Kb)
 
Ответить
Сообщениевариант с помощью power query. Для 2013 и выше Оффиса

Автор - mechanix85
Дата добавления - 22.12.2017 в 08:12
sm84 Дата: Пятница, 22.12.2017, 17:20 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо товарищи) сэкономил кучу времени)
 
Ответить
СообщениеСпасибо товарищи) сэкономил кучу времени)

Автор - sm84
Дата добавления - 22.12.2017 в 17:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразование строк в столбцы один под другим (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!