Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/как найти в ячейке заданное слово и правильно ответить - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как найти в ячейке заданное слово и правильно ответить (Формулы/Formulas)
как найти в ячейке заданное слово и правильно ответить
not_you Дата: Суббота, 23.12.2017, 00:43 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Знаю что элементарно... но не выходит что-то...
Надо в ячейке отыскать слово "дев." - соответственно рядом написать "девочка", а если в этом столбце написано "мал." - написать "мальчик"
К сообщению приложен файл: 7684511.xls(33.5 Kb)
 
Ответить
СообщениеЗнаю что элементарно... но не выходит что-то...
Надо в ячейке отыскать слово "дев." - соответственно рядом написать "девочка", а если в этом столбце написано "мал." - написать "мальчик"

Автор - not_you
Дата добавления - 23.12.2017 в 00:43
sv2014 Дата: Суббота, 23.12.2017, 01:29 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 211
Репутация: 59 ±
Замечаний: 0% ±

Excel 2013
not_you, вариант функций в столбце E и столбце F

[vba]
Код
Function vvv$(t$)
With CreateObject("VBScript.RegExp"): .Pattern = "дев\."
  If .test(t) Then vvv = "девочка"
   .Pattern = "мал\."
  If .test(t) Then vvv = "мальчик"
End With
End Function
[/vba]

[vba]
Код
Function uuu$(t$)
If InStr(1, t, "дев.") Then uuu = "девочка"
If InStr(1, t, "мал.") Then uuu = "мальчик"
End Function
[/vba]
К сообщению приложен файл: example_23_12_2.xls(42.0 Kb)


Сообщение отредактировал sv2014 - Суббота, 23.12.2017, 01:40
 
Ответить
Сообщениеnot_you, вариант функций в столбце E и столбце F

[vba]
Код
Function vvv$(t$)
With CreateObject("VBScript.RegExp"): .Pattern = "дев\."
  If .test(t) Then vvv = "девочка"
   .Pattern = "мал\."
  If .test(t) Then vvv = "мальчик"
End With
End Function
[/vba]

[vba]
Код
Function uuu$(t$)
If InStr(1, t, "дев.") Then uuu = "девочка"
If InStr(1, t, "мал.") Then uuu = "мальчик"
End Function
[/vba]

Автор - sv2014
Дата добавления - 23.12.2017 в 01:29
gling Дата: Суббота, 23.12.2017, 02:37 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1784
Репутация: 433 ±
Замечаний: 0% ±

2010
Вариант с таблицей сопоставления.
Код
=ИНДЕКС($L$1:$L$10;СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($K$2:$K$4;D2))*СТРОКА($L$2:$L$4)))
К сообщению приложен файл: 7077401.xls(35.0 Kb)


ЯД-41001506838083
 
Ответить
СообщениеВариант с таблицей сопоставления.
Код
=ИНДЕКС($L$1:$L$10;СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($K$2:$K$4;D2))*СТРОКА($L$2:$L$4)))

Автор - gling
Дата добавления - 23.12.2017 в 02:37
bmv98rus Дата: Суббота, 23.12.2017, 09:43 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1261
Репутация: 214 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=INDEX({"Девочка";"Unisex";"Мальчик"};(2+(-NOT(ISERROR(FIND("дев.";D3)))+(--NOT(ISERROR(FIND("мал.";D3)))))))


Сообщение отредактировал bmv98rus - Суббота, 23.12.2017, 09:46
 
Ответить
Сообщение
Код
=INDEX({"Девочка";"Unisex";"Мальчик"};(2+(-NOT(ISERROR(FIND("дев.";D3)))+(--NOT(ISERROR(FIND("мал.";D3)))))))

Автор - bmv98rus
Дата добавления - 23.12.2017 в 09:43
Nic70y Дата: Суббота, 23.12.2017, 10:18 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4689
Репутация: 1011 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(ЕОШ(ПОИСК("дев.";D2));"мальчик";"девочка")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕОШ(ПОИСК("дев.";D2));"мальчик";"девочка")

Автор - Nic70y
Дата добавления - 23.12.2017 в 10:18
Che79 Дата: Суббота, 23.12.2017, 10:33 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1269
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Если во всех названиях в обязательном порядке есть либо "дев.", либо "мал.", то и так можно
Код
=--ЕЧИСЛО(ПОИСК("дев.";D2))
+ ФЯ \Дево\чка;;\Маль\чик


Делай нормально и будет нормально!
 
Ответить
СообщениеЕсли во всех названиях в обязательном порядке есть либо "дев.", либо "мал.", то и так можно
Код
=--ЕЧИСЛО(ПОИСК("дев.";D2))
+ ФЯ \Дево\чка;;\Маль\чик

Автор - Che79
Дата добавления - 23.12.2017 в 10:33
not_you Дата: Суббота, 23.12.2017, 17:08 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем спасибо! Всё получилось!
 
Ответить
СообщениеВсем спасибо! Всё получилось!

Автор - not_you
Дата добавления - 23.12.2017 в 17:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как найти в ячейке заданное слово и правильно ответить (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!