Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Значение в третьей ячейке в зависимости от 2-х других - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Значение в третьей ячейке в зависимости от 2-х других (Формулы/Formulas)
Значение в третьей ячейке в зависимости от 2-х других
Кайли Дата: Понедельник, 25.12.2017, 20:22 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Есть табличка из 3 ячеек с функцией =ЕСЛИ(A1>C1;"А";"Б") Описание, если в ячейки А1 цыфра больше то значение *А* а если меньше то *Б*.
Вопрос. Нужно добавить значение *С* при условие если ячейки A1 и C1 будут равны.
К сообщению приложен файл: 5290323.xlsx(10.2 Kb)


Привет Мир!

Сообщение отредактировал Кайли - Понедельник, 25.12.2017, 20:40
 
Ответить
СообщениеЕсть табличка из 3 ячеек с функцией =ЕСЛИ(A1>C1;"А";"Б") Описание, если в ячейки А1 цыфра больше то значение *А* а если меньше то *Б*.
Вопрос. Нужно добавить значение *С* при условие если ячейки A1 и C1 будут равны.

Автор - Кайли
Дата добавления - 25.12.2017 в 20:22
Che79 Дата: Понедельник, 25.12.2017, 20:33 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
Кайли, переименуйте тему согласно Правилам форума, дайте ей более конкретное название. Например, "Значение в третьей ячейке в зависимости от 2-х других". А ответ на Ваш вопрос уже готов.


Делай нормально и будет нормально!
 
Ответить
СообщениеКайли, переименуйте тему согласно Правилам форума, дайте ей более конкретное название. Например, "Значение в третьей ячейке в зависимости от 2-х других". А ответ на Ваш вопрос уже готов.

Автор - Che79
Дата добавления - 25.12.2017 в 20:33
Che79 Дата: Понедельник, 25.12.2017, 20:48 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
Вот такой вариант без ЕСЛИ()
Код
=--(A1-C1)
+ ФЯ А;Б;C. и доработанный Ваш вариант
Код
=ЕСЛИ(A1>C1;"А";ЕСЛИ(A1=C1;"С";"Б"))
К сообщению приложен файл: 211_.xlsx(11.3 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Понедельник, 25.12.2017, 20:51
 
Ответить
СообщениеВот такой вариант без ЕСЛИ()
Код
=--(A1-C1)
+ ФЯ А;Б;C. и доработанный Ваш вариант
Код
=ЕСЛИ(A1>C1;"А";ЕСЛИ(A1=C1;"С";"Б"))

Автор - Che79
Дата добавления - 25.12.2017 в 20:48
AlexM Дата: Понедельник, 25.12.2017, 23:53 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3762
Репутация: 949 ±
Замечаний: 0% ±

Excel 2003
Код
=ТЕКСТ(A1-C1;"А;Б;\С")
Код
=ПСТР("БСА";ЗНАК(A1-C1)+2;1)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 25.12.2017, 23:57
 
Ответить
Сообщение
Код
=ТЕКСТ(A1-C1;"А;Б;\С")
Код
=ПСТР("БСА";ЗНАК(A1-C1)+2;1)

Автор - AlexM
Дата добавления - 25.12.2017 в 23:53
Che79 Дата: Вторник, 26.12.2017, 00:59 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
Код
=ВПР(ЗНАК(A1-C1);{1;"А":-1;"Б":0;"C"};2;)


Делай нормально и будет нормально!
 
Ответить
Сообщение
Код
=ВПР(ЗНАК(A1-C1);{1;"А":-1;"Б":0;"C"};2;)

Автор - Che79
Дата добавления - 26.12.2017 в 00:59
vikttur Дата: Вторник, 26.12.2017, 01:43 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2711
Репутация: 477 ±
Замечаний: 0% ±

Код
=ВЫБОР(ЗНАК(A1-C1)+2;"Б";"C";"А")

Если буквы поставить по-порядку:
Код
=СИМВОЛ(ЗНАК(A1-C1)+66)


Сообщение отредактировал vikttur - Вторник, 26.12.2017, 01:48
 
Ответить
Сообщение
Код
=ВЫБОР(ЗНАК(A1-C1)+2;"Б";"C";"А")

Если буквы поставить по-порядку:
Код
=СИМВОЛ(ЗНАК(A1-C1)+66)

Автор - vikttur
Дата добавления - 26.12.2017 в 01:43
Che79 Дата: Вторник, 26.12.2017, 12:32 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
переберём уж все варианты тогда yes
Код
=ИНДЕКС({"Б":"С":"А"};2+ЗНАК(A1-C1))


Делай нормально и будет нормально!
 
Ответить
Сообщениепереберём уж все варианты тогда yes
Код
=ИНДЕКС({"Б":"С":"А"};2+ЗНАК(A1-C1))

Автор - Che79
Дата добавления - 26.12.2017 в 12:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Значение в третьей ячейке в зависимости от 2-х других (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!