Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/График работы на месяц - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » График работы на месяц (Формулы/Formulas)
График работы на месяц
Georg305 Дата: Вторник, 26.12.2017, 16:47 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток.
Просмотрев вопросы по теме "График работы" не нашел ответ на возникший у меня вопрос: есть график на целый год (Лист "2018 (ОТПУСК)"), не могу добиться чтобы при формировании нового листа "график февраль...." и выбора нового месяца работы (февраль)рабочие смены переносились из "2018 (ОТПУСК)" соответствующего месяца.
Просмотренные посты меняли смены "автоматом", что в данном случае мне не надо.
К сообщению приложен файл: -2018-.xlsx(95.4 Kb)
 
Ответить
СообщениеДоброго времени суток.
Просмотрев вопросы по теме "График работы" не нашел ответ на возникший у меня вопрос: есть график на целый год (Лист "2018 (ОТПУСК)"), не могу добиться чтобы при формировании нового листа "график февраль...." и выбора нового месяца работы (февраль)рабочие смены переносились из "2018 (ОТПУСК)" соответствующего месяца.
Просмотренные посты меняли смены "автоматом", что в данном случае мне не надо.

Автор - Georg305
Дата добавления - 26.12.2017 в 16:47
Nic70y Дата: Вторник, 26.12.2017, 16:56 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4850
Репутация: 1050 ±
Замечаний: 0% ±

Excel 2013
Код
=ИНДЕКС('2018 (ОТПУСК)'!4:4;$AN$12+СТОЛБЕЦ(A1))
$AN$12=
Код
=ПОИСКПОЗ(ДАТА(P10;ПОИСКПОЗ(N10;AO20:AO31;);1);'2018 (ОТПУСК)'!3:3;)-1
формулы в "январе" написал
К сообщению приложен файл: 0726845.xlsx(94.8 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ИНДЕКС('2018 (ОТПУСК)'!4:4;$AN$12+СТОЛБЕЦ(A1))
$AN$12=
Код
=ПОИСКПОЗ(ДАТА(P10;ПОИСКПОЗ(N10;AO20:AO31;);1);'2018 (ОТПУСК)'!3:3;)-1
формулы в "январе" написал

Автор - Nic70y
Дата добавления - 26.12.2017 в 16:56
Georg305 Дата: Вторник, 26.12.2017, 22:10 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y - спасибо!
 
Ответить
СообщениеNic70y - спасибо!

Автор - Georg305
Дата добавления - 26.12.2017 в 22:10
Georg305 Дата: Понедельник, 15.01.2018, 11:49 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток!
Как всегда возникла проблема на ровном месте. В случае перемещения работников на продолжительный период работы в графике меняют местами фамилии, а данные из листа "2018(отпуск)" отображаются без "привязки" к ФИО.
Как победить проблему. Для примера: февраль и март
К сообщению приложен файл: 0726845-1.rar(82.8 Kb)
 
Ответить
СообщениеДоброго времени суток!
Как всегда возникла проблема на ровном месте. В случае перемещения работников на продолжительный период работы в графике меняют местами фамилии, а данные из листа "2018(отпуск)" отображаются без "привязки" к ФИО.
Как победить проблему. Для примера: февраль и март

Автор - Georg305
Дата добавления - 15.01.2018 в 11:49
Karataev Дата: Понедельник, 15.01.2018, 13:20 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1257
Репутация: 485 ±
Замечаний: 0% ±

Excel
Правильно сделать привязку не по ФИО, а по табельному номеру, т.к. табельный номер, предположу, уникальный, а ФИО могут быть одинаковыми у двух человек.
Я сделал новую формулу на листе "новая формула", она привязана к табельному номеру, а не к ФИО. Соответствующий столбец ищется по датам: лист "отпуск" - строка 3, лист "новая формула" - строка 12.
Формулы вставлены на листе "новая формула" только в строку 18.
К сообщению приложен файл: 0726845-1_kar.zip(96.6 Kb)


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
СообщениеПравильно сделать привязку не по ФИО, а по табельному номеру, т.к. табельный номер, предположу, уникальный, а ФИО могут быть одинаковыми у двух человек.
Я сделал новую формулу на листе "новая формула", она привязана к табельному номеру, а не к ФИО. Соответствующий столбец ищется по датам: лист "отпуск" - строка 3, лист "новая формула" - строка 12.
Формулы вставлены на листе "новая формула" только в строку 18.

Автор - Karataev
Дата добавления - 15.01.2018 в 13:20
Georg305 Дата: Понедельник, 15.01.2018, 13:55 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Karataev, Вы правы. Спасибо за помощь.
 
Ответить
СообщениеKarataev, Вы правы. Спасибо за помощь.

Автор - Georg305
Дата добавления - 15.01.2018 в 13:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » График работы на месяц (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!