Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор ячейки из базы данных по условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор ячейки из базы данных по условиям (Формулы/Formulas)
Выбор ячейки из базы данных по условиям
solovievalera Дата: Вторник, 26.12.2017, 18:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток!

Уважаемые "форумцы", нужна ваша помощь в экселе.
Задача: есть база данных - столбцы-год, строки-субьекты РФ. Мне нужно условие, к примеру, "2015 год, Москва" и нужно найти эту ячейку с данными.
Для примера прикрепляю свою базу. На первых двух листах базы данных, на третьем условия (из списка).
Задачка вроде не сложная, но исполнение у меня никуда не годится, прошу помощи!
Заранее спасибо!
К сообщению приложен файл: _26.12.2017.xlsx(33.3 Kb)


Сообщение отредактировал solovievalera - Вторник, 26.12.2017, 18:17
 
Ответить
СообщениеДоброго времени суток!

Уважаемые "форумцы", нужна ваша помощь в экселе.
Задача: есть база данных - столбцы-год, строки-субьекты РФ. Мне нужно условие, к примеру, "2015 год, Москва" и нужно найти эту ячейку с данными.
Для примера прикрепляю свою базу. На первых двух листах базы данных, на третьем условия (из списка).
Задачка вроде не сложная, но исполнение у меня никуда не годится, прошу помощи!
Заранее спасибо!

Автор - solovievalera
Дата добавления - 26.12.2017 в 18:16
Pelena Дата: Вторник, 26.12.2017, 18:27 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12820
Репутация: 2825 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Если правильно поняла
Код
=ИНДЕКС(Субьекты!B6:R102;ПОИСКПОЗ(D5;Субьекты!A6:A102;0);ПОИСКПОЗ(D4;Субьекты!B5:R5;0))
К сообщению приложен файл: 5766885.xlsx(33.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если правильно поняла
Код
=ИНДЕКС(Субьекты!B6:R102;ПОИСКПОЗ(D5;Субьекты!A6:A102;0);ПОИСКПОЗ(D4;Субьекты!B5:R5;0))

Автор - Pelena
Дата добавления - 26.12.2017 в 18:27
solovievalera Дата: Вторник, 26.12.2017, 18:36 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, Большое Вам спасибо за помощь!
Да, все правильно. То что и требовалось!
Еще раз большое Вам спасибо! С наступающим, пусть Вам ваше добро возвращается в тысячекратном размере!)))
 
Ответить
СообщениеPelena, Большое Вам спасибо за помощь!
Да, все правильно. То что и требовалось!
Еще раз большое Вам спасибо! С наступающим, пусть Вам ваше добро возвращается в тысячекратном размере!)))

Автор - solovievalera
Дата добавления - 26.12.2017 в 18:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор ячейки из базы данных по условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!