Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/перенос значение из одного листа в другой. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перенос значение из одного листа в другой. (Формулы/Formulas)
перенос значение из одного листа в другой.
nadil Дата: Четверг, 28.12.2017, 08:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Приветствую!
Есть сводная таблица, куда надо перенести значение со второго листа, по коду контрагента.
на первом листе у каждого контрагента есть свой ID, на втором листе (который выгружается из терминала, его изменять нельзя) в столбце Контрагенты указаны соответствующие ID.
Нужно чтобы опираясь на столбец контрагенты(на листе 2), брал соответствующий вес(из столбца Масса нетто) в этой строке, и записывалось в первый лист в столбцы (вес один, вес два, вес три, вес 4) в соответствии с ID контрагента, по очереди, если нет веса , присваивал значение 0.
название листа соответствует числу месяца.
Спасибо.
К сообщению приложен файл: 2891400.xls(96Kb)


Сообщение отредактировал nadil - Четверг, 28.12.2017, 08:22
 
Ответить
СообщениеПриветствую!
Есть сводная таблица, куда надо перенести значение со второго листа, по коду контрагента.
на первом листе у каждого контрагента есть свой ID, на втором листе (который выгружается из терминала, его изменять нельзя) в столбце Контрагенты указаны соответствующие ID.
Нужно чтобы опираясь на столбец контрагенты(на листе 2), брал соответствующий вес(из столбца Масса нетто) в этой строке, и записывалось в первый лист в столбцы (вес один, вес два, вес три, вес 4) в соответствии с ID контрагента, по очереди, если нет веса , присваивал значение 0.
название листа соответствует числу месяца.
Спасибо.

Автор - nadil
Дата добавления - 28.12.2017 в 08:20
sboy Дата: Четверг, 28.12.2017, 09:53 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1268
Репутация: 338 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Над весами даты размножил
Код
=ЕСЛИОШИБКА(ИНДЕКС(ДВССЫЛ("'"&ДЕНЬ(E$2)&"'!$G$5:$G$100");АГРЕГАТ(15;6;(СТРОКА($G$5:$G$100)-4)/($B4=ДВССЫЛ("'"&ДЕНЬ(E$2)&"'!$S$5:$S$100"));ОСТАТ(СТОЛБЕЦ()+1;6)+1));)
К сообщению приложен файл: 2891400.xlsb(35Kb)
 
Ответить
СообщениеДобрый день.
Над весами даты размножил
Код
=ЕСЛИОШИБКА(ИНДЕКС(ДВССЫЛ("'"&ДЕНЬ(E$2)&"'!$G$5:$G$100");АГРЕГАТ(15;6;(СТРОКА($G$5:$G$100)-4)/($B4=ДВССЫЛ("'"&ДЕНЬ(E$2)&"'!$S$5:$S$100"));ОСТАТ(СТОЛБЕЦ()+1;6)+1));)

Автор - sboy
Дата добавления - 28.12.2017 в 09:53
nadil Дата: Четверг, 28.12.2017, 10:40 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое! Работает на ура! только голову поломать придется над формулой)
 
Ответить
СообщениеСпасибо большое! Работает на ура! только голову поломать придется над формулой)

Автор - nadil
Дата добавления - 28.12.2017 в 10:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перенос значение из одного листа в другой. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!