Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подставить значение из одной таблицы в другую по условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставить значение из одной таблицы в другую по условиям (Формулы/Formulas)
Подставить значение из одной таблицы в другую по условиям
Кайли Дата: Пятница, 29.12.2017, 13:56 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 86
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Имеются 2 таблички в ячейку B8 необходимо вписать значения по заданной формуле из ячейки B7 при выбирании из списка А8
К сообщению приложен файл: 4555457.xlsx(12Kb)


Привет Мир!

Сообщение отредактировал Кайли - Пятница, 29.12.2017, 15:55
 
Ответить
СообщениеИмеются 2 таблички в ячейку B8 необходимо вписать значения по заданной формуле из ячейки B7 при выбирании из списка А8

Автор - Кайли
Дата добавления - 29.12.2017 в 13:56
Che79 Дата: Пятница, 29.12.2017, 14:07 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 844
Репутация: 136 ±
Замечаний: 0% ±

Excel 2007, 2013
Кайли, приветствую.
Не совсем понял, что значит "сократить с удалением", но, может, так? Для B8
Код
=ВПР($A8;$A$2:$G$5;ПОИСКПОЗ(B7;$A$1:$G$1;);)
и протянуть до E8.
К сообщению приложен файл: 7700929_1.xlsx(14Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Пятница, 29.12.2017, 14:08
 
Ответить
СообщениеКайли, приветствую.
Не совсем понял, что значит "сократить с удалением", но, может, так? Для B8
Код
=ВПР($A8;$A$2:$G$5;ПОИСКПОЗ(B7;$A$1:$G$1;);)
и протянуть до E8.

Автор - Che79
Дата добавления - 29.12.2017 в 14:07
vikttur Дата: Пятница, 29.12.2017, 14:08 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2654
Репутация: 476 ±
Замечаний: 0% ±

Тему следует называть по основной задаче.
 
Ответить
СообщениеТему следует называть по основной задаче.

Автор - vikttur
Дата добавления - 29.12.2017 в 14:08
Кайли Дата: Пятница, 29.12.2017, 14:20 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 86
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Che79, Да так как надо!, будем оставлять.


Привет Мир!
 
Ответить
СообщениеChe79, Да так как надо!, будем оставлять.

Автор - Кайли
Дата добавления - 29.12.2017 в 14:20
Кайли Дата: Пятница, 29.12.2017, 14:23 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 86
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
vikttur, Составить не могу тему, Che79. Решил! А тему не могу описать. Какие есть варианты ?


Привет Мир!
 
Ответить
Сообщениеvikttur, Составить не могу тему, Che79. Решил! А тему не могу описать. Какие есть варианты ?

Автор - Кайли
Дата добавления - 29.12.2017 в 14:23
Кайли Дата: Пятница, 29.12.2017, 14:26 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 86
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всё понятно . Скажите зачем нужны знаки $ доллары ?


Привет Мир!
 
Ответить
СообщениеВсё понятно . Скажите зачем нужны знаки $ доллары ?

Автор - Кайли
Дата добавления - 29.12.2017 в 14:26
Che79 Дата: Пятница, 29.12.2017, 14:30 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 844
Репутация: 136 ±
Замечаний: 0% ±

Excel 2007, 2013
Какие есть варианты ?
"Поиск значений в массиве по данным другого массива"; "Подставить значение из одной таблицы в другую по условиям"...


Делай нормально и будет нормально!
 
Ответить
Сообщение
Какие есть варианты ?
"Поиск значений в массиве по данным другого массива"; "Подставить значение из одной таблицы в другую по условиям"...

Автор - Che79
Дата добавления - 29.12.2017 в 14:30
Кайли Дата: Пятница, 29.12.2017, 14:30 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 86
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Che79, сократить-удалить с очисткой содержимого F1:G5


Привет Мир!
 
Ответить
СообщениеChe79, сократить-удалить с очисткой содержимого F1:G5

Автор - Кайли
Дата добавления - 29.12.2017 в 14:30
Che79 Дата: Пятница, 29.12.2017, 14:33 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 844
Репутация: 136 ±
Замечаний: 0% ±

Excel 2007, 2013
зачем нужны знаки $ доллары ?
Для того, чтобы значение, которое ищем и массив данных, в котором это значение ищем не "поехали" при протягивании по строкам / столбцам. Быстрая подстановка "долларов" - выделить нужный массив в строке формул и нажать F4. Проверьте в файле, как это работает на практике.


Делай нормально и будет нормально!
 
Ответить
Сообщение
зачем нужны знаки $ доллары ?
Для того, чтобы значение, которое ищем и массив данных, в котором это значение ищем не "поехали" при протягивании по строкам / столбцам. Быстрая подстановка "долларов" - выделить нужный массив в строке формул и нажать F4. Проверьте в файле, как это работает на практике.

Автор - Che79
Дата добавления - 29.12.2017 в 14:33
Che79 Дата: Пятница, 29.12.2017, 14:34 | Сообщение № 10
Группа: Проверенные
Ранг: Ветеран
Сообщений: 844
Репутация: 136 ±
Замечаний: 0% ±

Excel 2007, 2013
сократить-удалить с очисткой
Причём здесь это? Вы же ничего не удаляете и не сокращаете.


Делай нормально и будет нормально!
 
Ответить
Сообщение
сократить-удалить с очисткой
Причём здесь это? Вы же ничего не удаляете и не сокращаете.

Автор - Che79
Дата добавления - 29.12.2017 в 14:34
Кайли Дата: Пятница, 29.12.2017, 14:47 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 86
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Che79, бито есть
Код
=(B2+C2)*D2
. Переправляю файл удалю


Привет Мир!

Сообщение отредактировал Кайли - Суббота, 30.12.2017, 01:47
 
Ответить
СообщениеChe79, бито есть
Код
=(B2+C2)*D2
. Переправляю файл удалю

Автор - Кайли
Дата добавления - 29.12.2017 в 14:47
Кайли Дата: Пятница, 29.12.2017, 16:14 | Сообщение № 12
Группа: Пользователи
Ранг: Участник
Сообщений: 86
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
файл и вопрос изменён. тема та же %)


Привет Мир!
 
Ответить
Сообщениефайл и вопрос изменён. тема та же %)

Автор - Кайли
Дата добавления - 29.12.2017 в 16:14
Che79 Дата: Пятница, 29.12.2017, 16:52 | Сообщение № 13
Группа: Проверенные
Ранг: Ветеран
Сообщений: 844
Репутация: 136 ±
Замечаний: 0% ±

Excel 2007, 2013
Ну, это уже вообще другой вопрос. Будем считать, Вы его изначально сформулировали не так, как хотели.
Если не думая и не оптимизируя формулу, то так. Проверяйте
Код
=(ДВССЫЛ("B"&(ПОИСКПОЗ($A8;$A$2:$A$5;)+1))+ДВССЫЛ("C"&(ПОИСКПОЗ($A8;$A$2:$A$5;)+1)))*ДВССЫЛ("D"&(ПОИСКПОЗ($A8;$A$2:$A$5;)+1))

Почитайте заодно справку по ДВССЫЛ()
К сообщению приложен файл: 4555457_1.xlsx(13Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеНу, это уже вообще другой вопрос. Будем считать, Вы его изначально сформулировали не так, как хотели.
Если не думая и не оптимизируя формулу, то так. Проверяйте
Код
=(ДВССЫЛ("B"&(ПОИСКПОЗ($A8;$A$2:$A$5;)+1))+ДВССЫЛ("C"&(ПОИСКПОЗ($A8;$A$2:$A$5;)+1)))*ДВССЫЛ("D"&(ПОИСКПОЗ($A8;$A$2:$A$5;)+1))

Почитайте заодно справку по ДВССЫЛ()

Автор - Che79
Дата добавления - 29.12.2017 в 16:52
Кайли Дата: Пятница, 29.12.2017, 17:07 | Сообщение № 14
Группа: Пользователи
Ранг: Участник
Сообщений: 86
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Che79, :D :D :D она самая, всё как надо!спасибо! hands будим учить ДВССЫЛ


Привет Мир!

Сообщение отредактировал Кайли - Пятница, 29.12.2017, 17:08
 
Ответить
СообщениеChe79, :D :D :D она самая, всё как надо!спасибо! hands будим учить ДВССЫЛ

Автор - Кайли
Дата добавления - 29.12.2017 в 17:07
Pelena Дата: Пятница, 29.12.2017, 19:04 | Сообщение № 15
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12043
Репутация: 2651 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Ещё варианты
Код
=СУММПРОИЗВ(ВПР($A8;$A$2:$E$5;{2;3};0))*ВПР($A8;$A$2:$E$5;4;0)

Код
=ИНДЕКС(($B$2:$B$5+$C$2:$C$5)*D$2:D$5;ПОИСКПОЗ($A8;$A$2:$A$5;0);0)
К сообщению приложен файл: 8002852.xlsx(13Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё варианты
Код
=СУММПРОИЗВ(ВПР($A8;$A$2:$E$5;{2;3};0))*ВПР($A8;$A$2:$E$5;4;0)

Код
=ИНДЕКС(($B$2:$B$5+$C$2:$C$5)*D$2:D$5;ПОИСКПОЗ($A8;$A$2:$A$5;0);0)

Автор - Pelena
Дата добавления - 29.12.2017 в 19:04
Che79 Дата: Пятница, 29.12.2017, 19:35 | Сообщение № 16
Группа: Проверенные
Ранг: Ветеран
Сообщений: 844
Репутация: 136 ±
Замечаний: 0% ±

Excel 2007, 2013
Если не думая и не оптимизируя
А если подумать и сократить, то
Код
=СУММ((($B$2:$B$5+$C$2:$C$5)*D$2:D$5)*($A$2:$A$5=$A$8))
формула массива (ввод Ctrl+Shift+Enter)

Спасибо Pelena за включение мозга. yes flowers
К сообщению приложен файл: 8002852_1.xlsx(13Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
Если не думая и не оптимизируя
А если подумать и сократить, то
Код
=СУММ((($B$2:$B$5+$C$2:$C$5)*D$2:D$5)*($A$2:$A$5=$A$8))
формула массива (ввод Ctrl+Shift+Enter)

Спасибо Pelena за включение мозга. yes flowers

Автор - Che79
Дата добавления - 29.12.2017 в 19:35
Кайли Дата: Суббота, 30.12.2017, 00:44 | Сообщение № 17
Группа: Пользователи
Ранг: Участник
Сообщений: 86
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Che79, Всё через ДВССЫЛ по формуле повторить, также как в прошлый раз не выходит
,
Код
=(ДВССЫЛ("B"&(ПОИСКПОЗ($A8;$A$2:$A$5;)+1))+ДВССЫЛ("C"&(ПОИСКПОЗ($A8;$A$2:$A$5;)+1)))*ДВССЫЛ("D"&(ПОИСКПОЗ($A8;$A$2:$A$5;)+1))
эта формула соответствует
Код
=(B+C)*D
. приложен файл 1.
Нужно таким же образом и формулу
Код
=((B+C)*I-J)+(D+E)*L-G
.приложен файл 2
К сообщению приложен файл: 5787410.xlsx(12Kb) · 1022575.xlsx(12Kb)


Привет Мир!

Сообщение отредактировал Кайли - Суббота, 30.12.2017, 01:45
 
Ответить
СообщениеChe79, Всё через ДВССЫЛ по формуле повторить, также как в прошлый раз не выходит
,
Код
=(ДВССЫЛ("B"&(ПОИСКПОЗ($A8;$A$2:$A$5;)+1))+ДВССЫЛ("C"&(ПОИСКПОЗ($A8;$A$2:$A$5;)+1)))*ДВССЫЛ("D"&(ПОИСКПОЗ($A8;$A$2:$A$5;)+1))
эта формула соответствует
Код
=(B+C)*D
. приложен файл 1.
Нужно таким же образом и формулу
Код
=((B+C)*I-J)+(D+E)*L-G
.приложен файл 2

Автор - Кайли
Дата добавления - 30.12.2017 в 00:44
Che79 Дата: Суббота, 30.12.2017, 00:57 | Сообщение № 18
Группа: Проверенные
Ранг: Ветеран
Сообщений: 844
Репутация: 136 ±
Замечаний: 0% ±

Excel 2007, 2013
Кайли, зачем Вы пишете в двух разных темах? Я Вам уже тут ответил. И заключите уже все формулы в тэги согласно Правилам форума. Отсутствие тэгов - серьёзное нарушение правил. Вам просто перестанут отвечать или замечание от модераторов получите.


Делай нормально и будет нормально!
 
Ответить
СообщениеКайли, зачем Вы пишете в двух разных темах? Я Вам уже тут ответил. И заключите уже все формулы в тэги согласно Правилам форума. Отсутствие тэгов - серьёзное нарушение правил. Вам просто перестанут отвечать или замечание от модераторов получите.

Автор - Che79
Дата добавления - 30.12.2017 в 00:57
Кайли Дата: Суббота, 30.12.2017, 01:10 | Сообщение № 19
Группа: Пользователи
Ранг: Участник
Сообщений: 86
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Che79, каким тегом заключить надо ?


Привет Мир!
 
Ответить
СообщениеChe79, каким тегом заключить надо ?

Автор - Кайли
Дата добавления - 30.12.2017 в 01:10
Che79 Дата: Суббота, 30.12.2017, 01:23 | Сообщение № 20
Группа: Проверенные
Ранг: Ветеран
Сообщений: 844
Репутация: 136 ±
Замечаний: 0% ±

Excel 2007, 2013
Правила форума
Как правильно оформлять сообщения?
Формульный тэг: нажимаете "Правка" - выделяете формулу - далее кнопка fx - Сохранить.


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Суббота, 30.12.2017, 01:24
 
Ответить
СообщениеПравила форума
Как правильно оформлять сообщения?
Формульный тэг: нажимаете "Правка" - выделяете формулу - далее кнопка fx - Сохранить.

Автор - Che79
Дата добавления - 30.12.2017 в 01:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставить значение из одной таблицы в другую по условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!