Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/К непустой ячейке добавить текст.Если пусто то пустая ячейка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » К непустой ячейке добавить текст.Если пусто то пустая ячейка (Формулы/Formulas)
К непустой ячейке добавить текст.Если пусто то пустая ячейка
Никанор Дата: Вторник, 02.01.2018, 16:34 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 177
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Поздравляю всех с Новым годом!
Желаю здоровья и что бы все желания исполнились.

Вот полное название темы:
Если не пустая ячейка с фамилией, то результат: к ячейка с фамилией, добавить текст. А если пустая ячейка с фамилией, то результат – пустая ячейка.

Пример в файле.

Как написать формулу для ячеек В31, В32, В33, В34, В35, с условием:
Условия для ячейки В31: Если не заполнена ячейка В25 – ячейка В31 пустая, а если заполнена ячейка В25, то в ячейке В31 формула = ячейка В25 и добавлен текст: Договор с
Условия для ячейки В32: Если не заполнена ячейка В26 – ячейка В32 пустая, а если заполнена ячейка В26, то в ячейке В32 формула = ячейка В26 и добавлен текст: Договор с
Условия для ячейки В33: Если не заполнена ячейка В27 – ячейка В33 пустая, а если заполнена ячейка В27, то в ячейке В33 формула = ячейка В27 и добавлен текст: Договор с
Условия для ячейки В34: Если не заполнена ячейка В28 – ячейка В34 пустая, а если заполнена ячейка В28, то в ячейке В34 формула = ячейка В28 и добавлен текст: Договор с

Ячейки диапазона B25:B29 это фамилия имя отчество.
Формулы, которые нужны для ячеек диапазона B31:B35 – к фамилии имени отчеству, ясли не пустые ячейки с фамилией должен добавиться текст: «Договор с»
Условия в прикреплённом файле.

Формула для ячейки В31
Код
=ЕСЛИ(B25<>"";B25;"")& " – Договор с  "
даёт правильный результат только в том случае, если не пустая ячейка В25. А если пустая ячейка В25, то результат в ячейке пишется ТЕКСТ: «Договор». А в этом случае должна быть пустая ячейка.
К сообщению приложен файл: _____-___.xlsx(38.6 Kb)
 
Ответить
СообщениеЗдравствуйте!
Поздравляю всех с Новым годом!
Желаю здоровья и что бы все желания исполнились.

Вот полное название темы:
Если не пустая ячейка с фамилией, то результат: к ячейка с фамилией, добавить текст. А если пустая ячейка с фамилией, то результат – пустая ячейка.

Пример в файле.

Как написать формулу для ячеек В31, В32, В33, В34, В35, с условием:
Условия для ячейки В31: Если не заполнена ячейка В25 – ячейка В31 пустая, а если заполнена ячейка В25, то в ячейке В31 формула = ячейка В25 и добавлен текст: Договор с
Условия для ячейки В32: Если не заполнена ячейка В26 – ячейка В32 пустая, а если заполнена ячейка В26, то в ячейке В32 формула = ячейка В26 и добавлен текст: Договор с
Условия для ячейки В33: Если не заполнена ячейка В27 – ячейка В33 пустая, а если заполнена ячейка В27, то в ячейке В33 формула = ячейка В27 и добавлен текст: Договор с
Условия для ячейки В34: Если не заполнена ячейка В28 – ячейка В34 пустая, а если заполнена ячейка В28, то в ячейке В34 формула = ячейка В28 и добавлен текст: Договор с

Ячейки диапазона B25:B29 это фамилия имя отчество.
Формулы, которые нужны для ячеек диапазона B31:B35 – к фамилии имени отчеству, ясли не пустые ячейки с фамилией должен добавиться текст: «Договор с»
Условия в прикреплённом файле.

Формула для ячейки В31
Код
=ЕСЛИ(B25<>"";B25;"")& " – Договор с  "
даёт правильный результат только в том случае, если не пустая ячейка В25. А если пустая ячейка В25, то результат в ячейке пишется ТЕКСТ: «Договор». А в этом случае должна быть пустая ячейка.

Автор - Никанор
Дата добавления - 02.01.2018 в 16:34
Pelena Дата: Вторник, 02.01.2018, 16:41 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12585
Репутация: 2768 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Код
=ЕСЛИ(B25<>"";B25& " – Договор с  ";"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИ(B25<>"";B25& " – Договор с  ";"")

Автор - Pelena
Дата добавления - 02.01.2018 в 16:41
Никанор Дата: Вторник, 02.01.2018, 16:58 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 177
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Pelena, Большое спасибо!
Всё чудесно так как я хотел.
В ячейке В1 указано название месяца
А можно ли эту формулу изменить, что бы к тексту добавить первое и последнее числа месяца в ТЕКСТовом формате?
И формула давала результат, в этом примере: «– Договор с 1 декабря по 31 декабря.»

Вот формула преобразования начала месяца в ТЕКСТ
Код
=ТЕКСТ(ДАТАМЕС(B1;0);"[$-FC19]ДД ММММ ГГГГ \г.;@ ")

эта формула даёт результат 1 декабря 2017 г.

А формула
Код
=ТЕКСТ(ДАТАМЕС(B1;1)+(-1);"[$-FC19]Д ММММ ГГГГ")
даёт результат последнее число месяца. В данном примере 31 декабря.

Может эти формулы помогут изменить формулу.
 
Ответить
СообщениеPelena, Большое спасибо!
Всё чудесно так как я хотел.
В ячейке В1 указано название месяца
А можно ли эту формулу изменить, что бы к тексту добавить первое и последнее числа месяца в ТЕКСТовом формате?
И формула давала результат, в этом примере: «– Договор с 1 декабря по 31 декабря.»

Вот формула преобразования начала месяца в ТЕКСТ
Код
=ТЕКСТ(ДАТАМЕС(B1;0);"[$-FC19]ДД ММММ ГГГГ \г.;@ ")

эта формула даёт результат 1 декабря 2017 г.

А формула
Код
=ТЕКСТ(ДАТАМЕС(B1;1)+(-1);"[$-FC19]Д ММММ ГГГГ")
даёт результат последнее число месяца. В данном примере 31 декабря.

Может эти формулы помогут изменить формулу.

Автор - Никанор
Дата добавления - 02.01.2018 в 16:58
vikttur Дата: Вторник, 02.01.2018, 17:00 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2687
Репутация: 477 ±
Замечаний: 0% ±

Так просто же: добавьте Ваши формулы (без знака =):
Код
=ЕСЛИ(B25<>"";B25& " – Договор с  " &начало&" по "&конец;"")


Сообщение отредактировал vikttur - Вторник, 02.01.2018, 17:03
 
Ответить
СообщениеТак просто же: добавьте Ваши формулы (без знака =):
Код
=ЕСЛИ(B25<>"";B25& " – Договор с  " &начало&" по "&конец;"")

Автор - vikttur
Дата добавления - 02.01.2018 в 17:00
Никанор Дата: Вторник, 02.01.2018, 17:10 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 177
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
vikttur, Большое спасибо!
И получилась формула:
Код
=ЕСЛИ(B25<>"";B25& " – Договор с  " &ТЕКСТ(ДАТАМЕС(B1;0);"[$-FC19]ДД ММММ ГГГГ \г.;@ ")&" по "&ТЕКСТ(ДАТАМЕС(B1;1)+(-1);"[$-FC19]Д ММММ ГГГГ");"")


А если надо только начало месяца, без последнего числа, то будет формула:
Код
=ЕСЛИ(B25<>"";B25&" – Договор с  "&ТЕКСТ(ДАТАМЕС(B1;0);"[$-FC19]ДД ММММ ГГГГ \г.;@ ")&" по")
 
Ответить
Сообщениеvikttur, Большое спасибо!
И получилась формула:
Код
=ЕСЛИ(B25<>"";B25& " – Договор с  " &ТЕКСТ(ДАТАМЕС(B1;0);"[$-FC19]ДД ММММ ГГГГ \г.;@ ")&" по "&ТЕКСТ(ДАТАМЕС(B1;1)+(-1);"[$-FC19]Д ММММ ГГГГ");"")


А если надо только начало месяца, без последнего числа, то будет формула:
Код
=ЕСЛИ(B25<>"";B25&" – Договор с  "&ТЕКСТ(ДАТАМЕС(B1;0);"[$-FC19]ДД ММММ ГГГГ \г.;@ ")&" по")

Автор - Никанор
Дата добавления - 02.01.2018 в 17:10
Pelena Дата: Вторник, 02.01.2018, 17:10 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12585
Репутация: 2768 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Цитата Никанор, 02.01.2018 в 16:58, в сообщении № 3 ()
Договор с 1 декабря по 31 декабря

Код
=ЕСЛИ(B25<>"";B25& " – Договор с "&ТЕКСТ($B$1;"[$-FC19]Д ММММ")&" по "&ТЕКСТ(КОНМЕСЯЦА($B$1;0);"[$-FC19]Д ММММ");"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Цитата Никанор, 02.01.2018 в 16:58, в сообщении № 3 ()
Договор с 1 декабря по 31 декабря

Код
=ЕСЛИ(B25<>"";B25& " – Договор с "&ТЕКСТ($B$1;"[$-FC19]Д ММММ")&" по "&ТЕКСТ(КОНМЕСЯЦА($B$1;0);"[$-FC19]Д ММММ");"")

Автор - Pelena
Дата добавления - 02.01.2018 в 17:10
Никанор Дата: Вторник, 02.01.2018, 17:14 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 177
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Pelena, Большое спасибо за ответ!
Формула считает так как нужно.
Вы написали короче формулу чем я.


Сообщение отредактировал Никанор - Вторник, 02.01.2018, 17:17
 
Ответить
СообщениеPelena, Большое спасибо за ответ!
Формула считает так как нужно.
Вы написали короче формулу чем я.

Автор - Никанор
Дата добавления - 02.01.2018 в 17:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » К непустой ячейке добавить текст.Если пусто то пустая ячейка (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!