Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ОТБОР ИЗ СТОЛБЦА СНАЧАЛА ЧИСЛОВЫХ ЗНАЧЕНИЙ , ЗАТЕМ ТЕКСТОВЫХ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ОТБОР ИЗ СТОЛБЦА СНАЧАЛА ЧИСЛОВЫХ ЗНАЧЕНИЙ , ЗАТЕМ ТЕКСТОВЫХ (Формулы/Formulas)
ОТБОР ИЗ СТОЛБЦА СНАЧАЛА ЧИСЛОВЫХ ЗНАЧЕНИЙ , ЗАТЕМ ТЕКСТОВЫХ
Рид Дата: Четверг, 04.01.2018, 14:24 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день
имеется " исходный список " в столбце c
в столбце g отобраны сначала числовые значения из исходного списка , затем текстовые, но из за того что в исходном списке три последние ячейки пустые, ( выделены желтым цветом) в формуле выдаются нули ( выделены зеленым цветом)
как можно изменить либо же составить новую формулу что бы после значения "300" шло " Камышов г" , затем "БАлексеев Н.Е." и тд

для наглядности имеется желаемый результат в столбце L , так как оно должно выглядеть .
К сообщению приложен файл: 4444.xlsx(22Kb)


ridik
 
Ответить
СообщениеДобрый день
имеется " исходный список " в столбце c
в столбце g отобраны сначала числовые значения из исходного списка , затем текстовые, но из за того что в исходном списке три последние ячейки пустые, ( выделены желтым цветом) в формуле выдаются нули ( выделены зеленым цветом)
как можно изменить либо же составить новую формулу что бы после значения "300" шло " Камышов г" , затем "БАлексеев Н.Е." и тд

для наглядности имеется желаемый результат в столбце L , так как оно должно выглядеть .

Автор - Рид
Дата добавления - 04.01.2018 в 14:24
vikttur Дата: Четверг, 04.01.2018, 14:28 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2647
Репутация: 474 ±
Замечаний: 0% ±

Вы считаете, что в своих темах отписываться не обязательно? Будем считать, что и помогать не обязательно.
 
Ответить
СообщениеВы считаете, что в своих темах отписываться не обязательно? Будем считать, что и помогать не обязательно.

Автор - vikttur
Дата добавления - 04.01.2018 в 14:28
Рид Дата: Четверг, 04.01.2018, 14:56 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
простите, я читал правила форума., и думал что ставить плюс человеку который помог этого достаточно , но теперь буду знать ,
я исправлюсь обещаю


ridik
 
Ответить
Сообщениепростите, я читал правила форума., и думал что ставить плюс человеку который помог этого достаточно , но теперь буду знать ,
я исправлюсь обещаю

Автор - Рид
Дата добавления - 04.01.2018 в 14:56
vikttur Дата: Четверг, 04.01.2018, 16:44 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2647
Репутация: 474 ±
Замечаний: 0% ±

Код
=ИНДЕКС($C$1:$C$38;НАИМЕНЬШИЙ(СТРОКА($C$3:$C$38)*ЕСЛИ(ЕЧИСЛО($C$3:$C$38);1;100);СТРОКА(A1))/ЕСЛИ(СТРОКА(A1)>СЧЁТ($C$3:$C$38);100;1))

Формула массива
 
Ответить
Сообщение
Код
=ИНДЕКС($C$1:$C$38;НАИМЕНЬШИЙ(СТРОКА($C$3:$C$38)*ЕСЛИ(ЕЧИСЛО($C$3:$C$38);1;100);СТРОКА(A1))/ЕСЛИ(СТРОКА(A1)>СЧЁТ($C$3:$C$38);100;1))

Формула массива

Автор - vikttur
Дата добавления - 04.01.2018 в 16:44
Рид Дата: Четверг, 04.01.2018, 17:07 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
vikttur а вот если пустые ячейки будут в середине столбца и я проверял , ноль выдает и в середине . как можно это подкоректировать??


ridik
 
Ответить
Сообщениеvikttur а вот если пустые ячейки будут в середине столбца и я проверял , ноль выдает и в середине . как можно это подкоректировать??

Автор - Рид
Дата добавления - 04.01.2018 в 17:07
vikttur Дата: Четверг, 04.01.2018, 17:47 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2647
Репутация: 474 ±
Замечаний: 0% ±

Покажите людям ссылку на дубль темы. Решение там.
 
Ответить
СообщениеПокажите людям ссылку на дубль темы. Решение там.

Автор - vikttur
Дата добавления - 04.01.2018 в 17:47
Рид Дата: Четверг, 04.01.2018, 21:35 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
уже решил с Вашей помощью))


ridik
 
Ответить
Сообщениеуже решил с Вашей помощью))

Автор - Рид
Дата добавления - 04.01.2018 в 21:35
Рид Дата: Пятница, 05.01.2018, 00:34 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013


ridik
 
Ответить
Сообщениерешение здесь http://www.planetaexcel.ru/forum....-formul

Автор - Рид
Дата добавления - 05.01.2018 в 00:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ОТБОР ИЗ СТОЛБЦА СНАЧАЛА ЧИСЛОВЫХ ЗНАЧЕНИЙ , ЗАТЕМ ТЕКСТОВЫХ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!