Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет данных по рабочим дням - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет данных по рабочим дням (Формулы/Formulas)
Подсчет данных по рабочим дням
chips Дата: Четверг, 11.01.2018, 11:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Ребята, помогите написать формулу по следующим условиям: есть 2 столбика Дата и Значение. Нужно суммировать значения только по рабочим дням (пн-пт) исключив значения выходных дней (сб-вс).
 
Ответить
СообщениеРебята, помогите написать формулу по следующим условиям: есть 2 столбика Дата и Значение. Нужно суммировать значения только по рабочим дням (пн-пт) исключив значения выходных дней (сб-вс).

Автор - chips
Дата добавления - 11.01.2018 в 11:48
китин Дата: Четверг, 11.01.2018, 11:50 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4924
Репутация: 786 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Примените ДЕНЬНЕД. точнее при наличии файла примера


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеПримените ДЕНЬНЕД. точнее при наличии файла примера

Автор - китин
Дата добавления - 11.01.2018 в 11:50
Pelena Дата: Четверг, 11.01.2018, 11:53 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12820
Репутация: 2825 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Код
=СУММПРОИЗВ((ДЕНЬНЕД(Диапзон_дат;2)<6)*Диапазон_значений)

Точнее при наличии файла с примером


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((ДЕНЬНЕД(Диапзон_дат;2)<6)*Диапазон_значений)

Точнее при наличии файла с примером

Автор - Pelena
Дата добавления - 11.01.2018 в 11:53
Che79 Дата: Четверг, 11.01.2018, 11:54 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1269
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
chips, здравствуйте. А пример кто должен нарисовать, мы?
Впрочем, держите, я сегодня добрый что-то. В файле жёлтая ячейка
Код
=СУММПРОИЗВ(B1:B31*(ДЕНЬНЕД(A1:A31;2)<6))

Значения из-за лени своей сделал через функцию СЛУЧМЕЖДУ().
К сообщению приложен файл: 180111.xlsx(9.7 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщениеchips, здравствуйте. А пример кто должен нарисовать, мы?
Впрочем, держите, я сегодня добрый что-то. В файле жёлтая ячейка
Код
=СУММПРОИЗВ(B1:B31*(ДЕНЬНЕД(A1:A31;2)<6))

Значения из-за лени своей сделал через функцию СЛУЧМЕЖДУ().

Автор - Che79
Дата добавления - 11.01.2018 в 11:54
китин Дата: Четверг, 11.01.2018, 12:03 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4924
Репутация: 786 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]
из-за лени

и как тебе не ай ай ай


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]
из-за лени

и как тебе не ай ай ай

Автор - китин
Дата добавления - 11.01.2018 в 12:03
chips Дата: Четверг, 11.01.2018, 12:05 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо большое за помощь, все работает!
 
Ответить
СообщениеСпасибо большое за помощь, все работает!

Автор - chips
Дата добавления - 11.01.2018 в 12:05
Che79 Дата: Четверг, 11.01.2018, 12:07 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1269
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
[offtop]
и как тебе не ай ай ай
блин, опять получилось как будто бы я списывал... Но я не списывал, зуб даю :D


Делай нормально и будет нормально!
 
Ответить
Сообщение[offtop]
и как тебе не ай ай ай
блин, опять получилось как будто бы я списывал... Но я не списывал, зуб даю :D

Автор - Che79
Дата добавления - 11.01.2018 в 12:07
chips Дата: Четверг, 11.01.2018, 12:08 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Есть еще нюанс, можно вычесть диапазон праздничных дней? Можно на примере от Che79
 
Ответить
СообщениеЕсть еще нюанс, можно вычесть диапазон праздничных дней? Можно на примере от Che79

Автор - chips
Дата добавления - 11.01.2018 в 12:08
Pelena Дата: Четверг, 11.01.2018, 12:11 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12820
Репутация: 2825 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
[offtop]
я не списывал

Да, да, оправдывайся теперь :D [/offtop]


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение[offtop]
я не списывал

Да, да, оправдывайся теперь :D [/offtop]

Автор - Pelena
Дата добавления - 11.01.2018 в 12:11
Che79 Дата: Четверг, 11.01.2018, 12:38 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 1269
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
можно вычесть диапазон праздничных дней.. на примере от Che79
Например, так
Код
=СУММПРОИЗВ(B1:B31*(ДЕНЬНЕД(A1:A31;2)<6)*(C1:C31<>"п"))
В столбце F навскидку праздники на год, в столбце С январские праздники через ВПР().
К сообщению приложен файл: 180111_1.xlsx(10.4 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
можно вычесть диапазон праздничных дней.. на примере от Che79
Например, так
Код
=СУММПРОИЗВ(B1:B31*(ДЕНЬНЕД(A1:A31;2)<6)*(C1:C31<>"п"))
В столбце F навскидку праздники на год, в столбце С январские праздники через ВПР().

Автор - Che79
Дата добавления - 11.01.2018 в 12:38
chips Дата: Четверг, 11.01.2018, 13:11 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
В столбце F навскидку праздники на год

В целом идея понятна, ориентируемся на "п", но не совсем понял как мне прикрутить список F?
Например список с праздничными днями на другой вкладке


Сообщение отредактировал chips - Четверг, 11.01.2018, 13:23
 
Ответить
Сообщение
В столбце F навскидку праздники на год

В целом идея понятна, ориентируемся на "п", но не совсем понял как мне прикрутить список F?
Например список с праздничными днями на другой вкладке

Автор - chips
Дата добавления - 11.01.2018 в 13:11
Che79 Дата: Четверг, 11.01.2018, 13:25 | Сообщение № 12
Группа: Проверенные
Ранг: Старожил
Сообщений: 1269
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
как мне прикрутить список F?
прикрутить куда? В моём примере он уже прикручен к С через ВПР(). Покажите Ваш реальный файл, так сразу будет легче всем. Ведь, если есть задача убрать праздники, то, наверняка, потом нужно добавить рабочие субботы (если они в этом году есть).


Делай нормально и будет нормально!
 
Ответить
Сообщение
как мне прикрутить список F?
прикрутить куда? В моём примере он уже прикручен к С через ВПР(). Покажите Ваш реальный файл, так сразу будет легче всем. Ведь, если есть задача убрать праздники, то, наверняка, потом нужно добавить рабочие субботы (если они в этом году есть).

Автор - Che79
Дата добавления - 11.01.2018 в 13:25
Pelena Дата: Четверг, 11.01.2018, 13:27 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12820
Репутация: 2825 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Вариант без буквы "п"
Код
=СУММПРОИЗВ(B1:B31*(ДЕНЬНЕД(A1:A31;2)<6)*ЕНД(ПОИСКПОЗ(A1:A31;F1:F14;0)))

или
Код
=СУММПРОИЗВ(B1:B31*(ДЕНЬНЕД(A1:A31;2)<6)*(1-СЧЁТЕСЛИ(F1:F14;A1:A31)))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант без буквы "п"
Код
=СУММПРОИЗВ(B1:B31*(ДЕНЬНЕД(A1:A31;2)<6)*ЕНД(ПОИСКПОЗ(A1:A31;F1:F14;0)))

или
Код
=СУММПРОИЗВ(B1:B31*(ДЕНЬНЕД(A1:A31;2)<6)*(1-СЧЁТЕСЛИ(F1:F14;A1:A31)))

Автор - Pelena
Дата добавления - 11.01.2018 в 13:27
chips Дата: Четверг, 11.01.2018, 13:44 | Сообщение № 14
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо за помощь, вы сделали мой день! )
 
Ответить
СообщениеСпасибо за помощь, вы сделали мой день! )

Автор - chips
Дата добавления - 11.01.2018 в 13:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет данных по рабочим дням (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!