Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Минимальное значение строки + "если", выбор названия столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Минимальное значение строки + "если", выбор названия столбца (Формулы/Formulas)
Минимальное значение строки + "если", выбор названия столбца
volgofant Дата: Четверг, 11.01.2018, 18:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
ДОбрый день, коротко о проблеме.
Необходимо чтобы в столбце "о" (лучшая цена) выбрано было минимально значение из соотвествующей строки, если это больше нуля, если равно 0 - то соответсвенно 0. А в соседнем столбе P было название столбца, с которого это значение было взято( если это >0), сьел весь мозг себе. Изначально вся таблица была подобрана через впр, и вместо 0 стояли #НД, и возможно ли тогда чтобы таблица работала со строками где есть такое значение.
К сообщению приложен файл: 8227096.xlsx(50.2 Kb)
 
Ответить
СообщениеДОбрый день, коротко о проблеме.
Необходимо чтобы в столбце "о" (лучшая цена) выбрано было минимально значение из соотвествующей строки, если это больше нуля, если равно 0 - то соответсвенно 0. А в соседнем столбе P было название столбца, с которого это значение было взято( если это >0), сьел весь мозг себе. Изначально вся таблица была подобрана через впр, и вместо 0 стояли #НД, и возможно ли тогда чтобы таблица работала со строками где есть такое значение.

Автор - volgofant
Дата добавления - 11.01.2018 в 18:17
Che79 Дата: Четверг, 11.01.2018, 19:09 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
volgofant, так хотите?
Лучшая цена (O2)
Код
=МИН(ЕСЛИ(C2:N2>0;C2:N2))
- формула массива, вводится Ctrl+Shift+Enter
название, если цена не 0 (P2)
Код
=ЕСЛИ(O2;ИНДЕКС($C$1:$N$1;ПОИСКПОЗ(O2;C2:N2;));"везде 0")

Только предварительно преобразуйте все значения в массиве в числа, иначе нарвётесь на ошибочные значения.

UPD
добавил файл, см. желтые ячейки
К сообщению приложен файл: 8227096_1.xlsx(59.6 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Четверг, 11.01.2018, 19:20
 
Ответить
Сообщениеvolgofant, так хотите?
Лучшая цена (O2)
Код
=МИН(ЕСЛИ(C2:N2>0;C2:N2))
- формула массива, вводится Ctrl+Shift+Enter
название, если цена не 0 (P2)
Код
=ЕСЛИ(O2;ИНДЕКС($C$1:$N$1;ПОИСКПОЗ(O2;C2:N2;));"везде 0")

Только предварительно преобразуйте все значения в массиве в числа, иначе нарвётесь на ошибочные значения.

UPD
добавил файл, см. желтые ячейки

Автор - Che79
Дата добавления - 11.01.2018 в 19:09
jakim Дата: Четверг, 11.01.2018, 19:59 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 845
Репутация: 223 ±
Замечаний: 0% ±

Excel 2010
лучшая цена

Код
=IFERROR(AGGREGATE(15;6;C2:N2/(C2:N2>0);1);0)

магазин

Код
=IFERROR(INDEX(C$1:N$1;;AGGREGATE(15;6;COLUMN($A:$Q)/(C2:N2=O2)/(C2:N2>0);1));"")
К сообщению приложен файл: 8565908.xlsx(61.8 Kb)
 
Ответить
Сообщение
лучшая цена

Код
=IFERROR(AGGREGATE(15;6;C2:N2/(C2:N2>0);1);0)

магазин

Код
=IFERROR(INDEX(C$1:N$1;;AGGREGATE(15;6;COLUMN($A:$Q)/(C2:N2=O2)/(C2:N2>0);1));"")

Автор - jakim
Дата добавления - 11.01.2018 в 19:59
vikttur Дата: Четверг, 11.01.2018, 20:18 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2711
Репутация: 477 ±
Замечаний: 0% ±

Простая, не массива:
Код
=НАИБОЛЬШИЙ(C2:N2;МАКС(СЧЁТЕСЛИ(C2:N2;">0");1))

Для названия столбца ИНДЕКС уже показали. Вариант:
Код
=ЕСЛИ(O2;ПРОСМОТР(2;1/(C2:N2=O2);$C$1:$N$1);)
 
Ответить
СообщениеПростая, не массива:
Код
=НАИБОЛЬШИЙ(C2:N2;МАКС(СЧЁТЕСЛИ(C2:N2;">0");1))

Для названия столбца ИНДЕКС уже показали. Вариант:
Код
=ЕСЛИ(O2;ПРОСМОТР(2;1/(C2:N2=O2);$C$1:$N$1);)

Автор - vikttur
Дата добавления - 11.01.2018 в 20:18
Che79 Дата: Пятница, 12.01.2018, 02:23 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
Название магазина можно еще так
Код
=ЕСЛИ(O2;ГПР(O2;$C2:$N$1000;1000-СТРОКА(A1););"")
В файле столбец Q. В C1000:N1000 (взял как бы с запасом) ссылки на C1:N1. На больших объемах будет тормозить.
К сообщению приложен файл: 8227096_2.xlsx(70.0 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеНазвание магазина можно еще так
Код
=ЕСЛИ(O2;ГПР(O2;$C2:$N$1000;1000-СТРОКА(A1););"")
В файле столбец Q. В C1000:N1000 (взял как бы с запасом) ссылки на C1:N1. На больших объемах будет тормозить.

Автор - Che79
Дата добавления - 12.01.2018 в 02:23
volgofant Дата: Пятница, 12.01.2018, 10:19 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Да, спасибо большое за ответы! Сейчас буду разбираться в формулах.
 
Ответить
СообщениеДа, спасибо большое за ответы! Сейчас буду разбираться в формулах.

Автор - volgofant
Дата добавления - 12.01.2018 в 10:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Минимальное значение строки + "если", выбор названия столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!