Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование ячеек по диапазону дат - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование ячеек по диапазону дат (Формулы/Formulas)
Суммирование ячеек по диапазону дат
gadjo Дата: Пятница, 12.01.2018, 15:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Нужна помощь в прописании формулы.
Во вложении файл с ежедневными расходами.
Необходимо сгруппировать расходы помесячно, т.е. просуммировать ячейки, соответствующие конкретному месяцу года (июнь2017, июль2017 ит.д.) (по стр.118-121) из диапазона значений выше.
Помогите прописать формулу в ячейках, чтобы ее можно было протянуть при дальнейшем заполнении таблицы...

Заранее спасибо!
К сообщению приложен файл: 5392223.xls(50.5 Kb)


Сообщение отредактировал gadjo - Пятница, 12.01.2018, 15:27
 
Ответить
СообщениеДобрый день!
Нужна помощь в прописании формулы.
Во вложении файл с ежедневными расходами.
Необходимо сгруппировать расходы помесячно, т.е. просуммировать ячейки, соответствующие конкретному месяцу года (июнь2017, июль2017 ит.д.) (по стр.118-121) из диапазона значений выше.
Помогите прописать формулу в ячейках, чтобы ее можно было протянуть при дальнейшем заполнении таблицы...

Заранее спасибо!

Автор - gadjo
Дата добавления - 12.01.2018 в 15:23
Che79 Дата: Пятница, 12.01.2018, 15:27 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1254
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Во вложении файл
нет файла, обратите внимание на размер (не более 100 кб).
Будет файл - конечно поможем!


Делай нормально и будет нормально!
 
Ответить
Сообщение
Во вложении файл
нет файла, обратите внимание на размер (не более 100 кб).
Будет файл - конечно поможем!

Автор - Che79
Дата добавления - 12.01.2018 в 15:27
gadjo Дата: Пятница, 12.01.2018, 15:28 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
нет файла, обратите внимание на размер (не более 100 кб).
Будет файл - конечно поможем!
исправил
 
Ответить
Сообщение
нет файла, обратите внимание на размер (не более 100 кб).
Будет файл - конечно поможем!
исправил

Автор - gadjo
Дата добавления - 12.01.2018 в 15:28
Che79 Дата: Пятница, 12.01.2018, 15:36 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1254
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
так хотите? Для B118 протягиваемая, не массивная
Код
=СУММПРОИЗВ(B$3:B$115*(ТЕКСТ($A$3:$A$115;"МГ")=ТЕКСТ($A118;"МГ")))
К сообщению приложен файл: 5392223_1.xls(53.5 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщениетак хотите? Для B118 протягиваемая, не массивная
Код
=СУММПРОИЗВ(B$3:B$115*(ТЕКСТ($A$3:$A$115;"МГ")=ТЕКСТ($A118;"МГ")))

Автор - Che79
Дата добавления - 12.01.2018 в 15:36
gadjo Дата: Пятница, 12.01.2018, 15:43 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
так хотите? Для B118 протягиваемая, не массивная

%) %) Спасибо огромное, счас буду разбираться, но думаю это то, что нужно
 
Ответить
Сообщение
так хотите? Для B118 протягиваемая, не массивная

%) %) Спасибо огромное, счас буду разбираться, но думаю это то, что нужно

Автор - gadjo
Дата добавления - 12.01.2018 в 15:43
vikttur Дата: Пятница, 12.01.2018, 15:44 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2687
Репутация: 477 ±
Замечаний: 0% ±

Проще в вычислениях:
Код
=СУММЕСЛИМН(B$3:B$115;$A$3:$A$115;">"&$A118;$A$3:$A$115;"<="&КОНМЕСЯЦА($A118;0))
 
Ответить
СообщениеПроще в вычислениях:
Код
=СУММЕСЛИМН(B$3:B$115;$A$3:$A$115;">"&$A118;$A$3:$A$115;"<="&КОНМЕСЯЦА($A118;0))

Автор - vikttur
Дата добавления - 12.01.2018 в 15:44
Che79 Дата: Пятница, 12.01.2018, 15:52 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1254
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Если год у Вас не меняется, то можно, например, так
Код
{=СУММ(ЕСЛИ(МЕСЯЦ($A$3:$A$115)=МЕСЯЦ($A118);B$3:B$115))}
формула массива, вводится одновременным нажатием Ctrl+Shift+Enter, при корректном вводе вокруг формулы появятся фигурные скобки.


Делай нормально и будет нормально!
 
Ответить
СообщениеЕсли год у Вас не меняется, то можно, например, так
Код
{=СУММ(ЕСЛИ(МЕСЯЦ($A$3:$A$115)=МЕСЯЦ($A118);B$3:B$115))}
формула массива, вводится одновременным нажатием Ctrl+Shift+Enter, при корректном вводе вокруг формулы появятся фигурные скобки.

Автор - Che79
Дата добавления - 12.01.2018 в 15:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование ячеек по диапазону дат (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!