Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Игнорировать участников с личным результатом. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Игнорировать участников с личным результатом. (Формулы/Formulas)
Игнорировать участников с личным результатом.
Valeron Дата: Вторник, 06.02.2018, 19:37 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер уважаемые знатоки Excel!!!
При заполнении протоколов появилась такая проблема.
В стартовом протоколе, если у участников в названии районов в конце есть буква -л, то
они не должны учитываться в командном протоколе(таблица справа), т.к. это личники.
Заранее благодарен!!!!
К сообщению приложен файл: __1.xlsm(37.5 Kb)
 
Ответить
СообщениеДобрый вечер уважаемые знатоки Excel!!!
При заполнении протоколов появилась такая проблема.
В стартовом протоколе, если у участников в названии районов в конце есть буква -л, то
они не должны учитываться в командном протоколе(таблица справа), т.к. это личники.
Заранее благодарен!!!!

Автор - Valeron
Дата добавления - 06.02.2018 в 19:37
Nic70y Дата: Вторник, 06.02.2018, 19:55 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4884
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
A4 спецформат
A5 и ниже
Код
=ЕСЛИ(ПРАВБ(C5;2)="-л";(A4+1)&"";A4+1)
K5 и ниже
Код
=ИНДЕКС(C$5:C$18251;НАИМЕНЬШИЙ(A$5:A$18251;J5))
(это чтоб без массивных
К сообщению приложен файл: _1.xlsm(24.1 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеA4 спецформат
A5 и ниже
Код
=ЕСЛИ(ПРАВБ(C5;2)="-л";(A4+1)&"";A4+1)
K5 и ниже
Код
=ИНДЕКС(C$5:C$18251;НАИМЕНЬШИЙ(A$5:A$18251;J5))
(это чтоб без массивных

Автор - Nic70y
Дата добавления - 06.02.2018 в 19:55
Valeron Дата: Среда, 07.02.2018, 20:07 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте Nic70y, !!!
В командном протоколе появляется дубликат названия команды, а можно чтобы
их духа вообще там не было :D
 
Ответить
СообщениеЗдравствуйте Nic70y, !!!
В командном протоколе появляется дубликат названия команды, а можно чтобы
их духа вообще там не было :D

Автор - Valeron
Дата добавления - 07.02.2018 в 20:07
Nic70y Дата: Среда, 07.02.2018, 20:23 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4884
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
можно
Код
=ЕСЛИ(И(ПРАВБ(C5;2)<>"-л";ЕСЛИОШИБКА(ПОИСКПОЗ(C5;C$5:C5;);0)=СТРОКА(A1));A4+1;(A4+1)&"")
вместо
A5 и ниже
[Перевод / Translate]
=ЕСЛИ(ПРАВБ(C5;2)="-л";(A4+1)&"";A4+1)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеможно
Код
=ЕСЛИ(И(ПРАВБ(C5;2)<>"-л";ЕСЛИОШИБКА(ПОИСКПОЗ(C5;C$5:C5;);0)=СТРОКА(A1));A4+1;(A4+1)&"")
вместо
A5 и ниже
[Перевод / Translate]
=ЕСЛИ(ПРАВБ(C5;2)="-л";(A4+1)&"";A4+1)

Автор - Nic70y
Дата добавления - 07.02.2018 в 20:23
Valeron Дата: Среда, 07.02.2018, 21:10 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер Nic70y, !!!!
Что-то в командном протоколе, в столбце Место, ранг не выводится ?
К сообщению приложен файл: ___.xlsm(41.2 Kb)
 
Ответить
СообщениеДобрый вечер Nic70y, !!!!
Что-то в командном протоколе, в столбце Место, ранг не выводится ?

Автор - Valeron
Дата добавления - 07.02.2018 в 21:10
Nic70y Дата: Среда, 07.02.2018, 21:17 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4884
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
конечно,
так же результат формул выдает ошибку
К сообщению приложен файл: 2757875.xlsm(40.6 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеконечно,
так же результат формул выдает ошибку

Автор - Nic70y
Дата добавления - 07.02.2018 в 21:17
Valeron Дата: Среда, 07.02.2018, 21:49 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Уважаемый Nic70y, можно поинтересоваться, а что значит
иероглиф в формуле, и что он делает ?
 
Ответить
СообщениеУважаемый Nic70y, можно поинтересоваться, а что значит
иероглиф в формуле, и что он делает ?

Автор - Valeron
Дата добавления - 07.02.2018 в 21:49
Nic70y Дата: Среда, 07.02.2018, 21:59 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4884
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
это вообще-то секретная информация,
но ладно, Вам расскажу, только без передачи.
иероглиф > любого текста на кириллице (и латинице тоже)
неточным поиском позиции ищем его в столбце
и так как его там нет - неточный поиск находит
последнюю позиции заполненной текстом ячейки (строки столбца)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеэто вообще-то секретная информация,
но ладно, Вам расскажу, только без передачи.
иероглиф > любого текста на кириллице (и латинице тоже)
неточным поиском позиции ищем его в столбце
и так как его там нет - неточный поиск находит
последнюю позиции заполненной текстом ячейки (строки столбца)

Автор - Nic70y
Дата добавления - 07.02.2018 в 21:59
Valeron Дата: Среда, 07.02.2018, 23:00 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Большое спасибо Nic70y, !!!
Вы мне очень сильно помогли.
Ну для меня с иероглифами, вообще высшая материя.
Ещё раз благодарю!!! hands
 
Ответить
СообщениеБольшое спасибо Nic70y, !!!
Вы мне очень сильно помогли.
Ну для меня с иероглифами, вообще высшая материя.
Ещё раз благодарю!!! hands

Автор - Valeron
Дата добавления - 07.02.2018 в 23:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Игнорировать участников с личным результатом. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!