Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/В результате не было #ЗНАЧ! а были пустые ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » В результате не было #ЗНАЧ! а были пустые ячейки (Формулы/Formulas)
В результате не было #ЗНАЧ! а были пустые ячейки
Никанор Дата: Среда, 07.02.2018, 16:34 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 212
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Помогите, пожалуйста, изменить формулу в диапазоне ячеек D19:D30, с условием: если соседние слева ячейки в диапазоне B19:C30 пустые – не заполнены, что бы результате ячейки D19:D30 были пустыми, а не было #ЗНАЧ!
Формулу, которую надо изменить
Код
=ЕСЛИОШИБКА(ДЕНЬ(B19);"")-G19

Я добавил столбец G и в результате, если пустые ячейки левее столбца D результат #ЗНАЧ!
А когда не было столбца G формула
Код
=ЕСЛИОШИБКА(ДЕНЬ(B19);"")
считала правильно – при пустых ячейках слева были также пустые ячейки в диапазоне D19:D30.
И сейчас считает правильно, только в том случае, если левее столбца D заполнены ячейки.
К сообщению приложен файл: 6172643.xlsx(28.9 Kb)


Сообщение отредактировал Никанор - Среда, 07.02.2018, 16:42
 
Ответить
СообщениеЗдравствуйте!
Помогите, пожалуйста, изменить формулу в диапазоне ячеек D19:D30, с условием: если соседние слева ячейки в диапазоне B19:C30 пустые – не заполнены, что бы результате ячейки D19:D30 были пустыми, а не было #ЗНАЧ!
Формулу, которую надо изменить
Код
=ЕСЛИОШИБКА(ДЕНЬ(B19);"")-G19

Я добавил столбец G и в результате, если пустые ячейки левее столбца D результат #ЗНАЧ!
А когда не было столбца G формула
Код
=ЕСЛИОШИБКА(ДЕНЬ(B19);"")
считала правильно – при пустых ячейках слева были также пустые ячейки в диапазоне D19:D30.
И сейчас считает правильно, только в том случае, если левее столбца D заполнены ячейки.

Автор - Никанор
Дата добавления - 07.02.2018 в 16:34
abtextime Дата: Среда, 07.02.2018, 16:41 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 745
Репутация: 103 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИОШИБКА(ДЕНЬ(B19)-G19;"")
К сообщению приложен файл: 3753722-2-.xlsx(30.0 Kb)


Сообщение отредактировал abtextime - Среда, 07.02.2018, 16:44
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ДЕНЬ(B19)-G19;"")

Автор - abtextime
Дата добавления - 07.02.2018 в 16:41
Никанор Дата: Среда, 07.02.2018, 16:46 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 212
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
abtextime, Здравствуйте!
Спасибо большое за молниеносный ответ на 7-ой минуте после размещения моего вопроса!
Всё очень просто – надо -G19 поставить сразу за скобками, а не в конце формулы.


Сообщение отредактировал Никанор - Среда, 07.02.2018, 16:49
 
Ответить
Сообщениеabtextime, Здравствуйте!
Спасибо большое за молниеносный ответ на 7-ой минуте после размещения моего вопроса!
Всё очень просто – надо -G19 поставить сразу за скобками, а не в конце формулы.

Автор - Никанор
Дата добавления - 07.02.2018 в 16:46
abtextime Дата: Среда, 07.02.2018, 16:49 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 745
Репутация: 103 ±
Замечаний: 0% ±

Excel 2010
Никанор, да, именно так
 
Ответить
СообщениеНиканор, да, именно так

Автор - abtextime
Дата добавления - 07.02.2018 в 16:49
abtextime Дата: Среда, 07.02.2018, 16:50 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 745
Репутация: 103 ±
Замечаний: 0% ±

Excel 2010
Никанор, Вы используйте активнее команду Формулы - Вычислить формулу, сами будете такие ошибки вылавливать
 
Ответить
СообщениеНиканор, Вы используйте активнее команду Формулы - Вычислить формулу, сами будете такие ошибки вылавливать

Автор - abtextime
Дата добавления - 07.02.2018 в 16:50
Никанор Дата: Среда, 07.02.2018, 17:04 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 212
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Алексей, подскажите пожалуйста как это сделать, где находится
Формулы - Вычислить формулу

и как потом изменить формулу на правильную?
 
Ответить
СообщениеАлексей, подскажите пожалуйста как это сделать, где находится
Формулы - Вычислить формулу

и как потом изменить формулу на правильную?

Автор - Никанор
Дата добавления - 07.02.2018 в 17:04
Che79 Дата: Среда, 07.02.2018, 17:10 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1260
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Хоть я и Алексей (но немножечко не тот :D ), но тоже готов подсказать. На ленте вкладка Формулы --подгруппа Зависимости формул - Вычислить формулу.
Кстати, я бы чисто из практических целей написал
Код
=ЕСЛИОШИБКА(ДЕНЬ(B19)-G19;)
и 0 (ноль) скрыл форматом, если нужно. Чтобы работать только с числами. Наверняка, числовые значения в ячейках столбца D и далее участвуют в вычислениях...


Делай нормально и будет нормально!
 
Ответить
СообщениеХоть я и Алексей (но немножечко не тот :D ), но тоже готов подсказать. На ленте вкладка Формулы --подгруппа Зависимости формул - Вычислить формулу.
Кстати, я бы чисто из практических целей написал
Код
=ЕСЛИОШИБКА(ДЕНЬ(B19)-G19;)
и 0 (ноль) скрыл форматом, если нужно. Чтобы работать только с числами. Наверняка, числовые значения в ячейках столбца D и далее участвуют в вычислениях...

Автор - Che79
Дата добавления - 07.02.2018 в 17:10
abtextime Дата: Среда, 07.02.2018, 17:12 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 745
Репутация: 103 ±
Замечаний: 0% ±

Excel 2010
Автоматически - никак. Но, выполняя вычисление по шагам, Вы увидите, в какой части формулы ошибка.
Так, для Вашей формулы, на финальном этапе выползает ""-G19
И понятно, что уменьшаемое в разности считается неправильно, т.е. функция ЕСЛИОШИБКА применена "слишком рано"


Сообщение отредактировал abtextime - Среда, 07.02.2018, 17:13
 
Ответить
СообщениеАвтоматически - никак. Но, выполняя вычисление по шагам, Вы увидите, в какой части формулы ошибка.
Так, для Вашей формулы, на финальном этапе выползает ""-G19
И понятно, что уменьшаемое в разности считается неправильно, т.е. функция ЕСЛИОШИБКА применена "слишком рано"

Автор - abtextime
Дата добавления - 07.02.2018 в 17:12
Никанор Дата: Среда, 07.02.2018, 17:37 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 212
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Che79, Алексей, спасибо за объяснение.
Наверняка, числовые значения в ячейках столбца D и далее участвуют в вычислениях...

они принимают участие в вычислениях – но мне удобнее работать, если пустые ячейки, что бы было видно что что столбец Е, который находится справа не нужно заполнять.
Просто интересно, можно как то ещё по другому написать формулу, что бы в диапазоне ячеек D19:D30 были пустые ячейки, если ячейки слева пустые?
 
Ответить
СообщениеChe79, Алексей, спасибо за объяснение.
Наверняка, числовые значения в ячейках столбца D и далее участвуют в вычислениях...

они принимают участие в вычислениях – но мне удобнее работать, если пустые ячейки, что бы было видно что что столбец Е, который находится справа не нужно заполнять.
Просто интересно, можно как то ещё по другому написать формулу, что бы в диапазоне ячеек D19:D30 были пустые ячейки, если ячейки слева пустые?

Автор - Никанор
Дата добавления - 07.02.2018 в 17:37
Никанор Дата: Среда, 07.02.2018, 17:38 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 212
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
abtextime, спасибо за объяснение.
 
Ответить
Сообщениеabtextime, спасибо за объяснение.

Автор - Никанор
Дата добавления - 07.02.2018 в 17:38
Che79 Дата: Среда, 07.02.2018, 17:45 | Сообщение № 11
Группа: Проверенные
Ранг: Старожил
Сообщений: 1260
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Цитата Никанор, 07.02.2018 в 17:37, в сообщении № 9 ()
можно как то ещё по другому написать формулу
так я уже
Код
=ЕСЛИОШИБКА(ДЕНЬ(B19)-G19;)
+ФЯ 0;;. Просто и далее будете натыкаться на #ЗНАЧ! , если вовремя не вспомните о ЕСЛИОШИБКА()


Делай нормально и будет нормально!
 
Ответить
Сообщение
Цитата Никанор, 07.02.2018 в 17:37, в сообщении № 9 ()
можно как то ещё по другому написать формулу
так я уже
Код
=ЕСЛИОШИБКА(ДЕНЬ(B19)-G19;)
+ФЯ 0;;. Просто и далее будете натыкаться на #ЗНАЧ! , если вовремя не вспомните о ЕСЛИОШИБКА()

Автор - Che79
Дата добавления - 07.02.2018 в 17:45
Nic70y Дата: Среда, 07.02.2018, 19:46 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4620
Репутация: 997 ±
Замечаний: 0% ±

Excel 2013
так
Код
=ЕСЛИ(-(0&B19);ДЕНЬ(B19)-G19;"")
смешнее


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениетак
Код
=ЕСЛИ(-(0&B19);ДЕНЬ(B19)-G19;"")
смешнее

Автор - Nic70y
Дата добавления - 07.02.2018 в 19:46
Никанор Дата: Четверг, 08.02.2018, 15:17 | Сообщение № 13
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 212
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Che79, Здравствуйте!
+ФЯ 0;;

Спасибо за объяснение как скрыть форматом ячейки 0 (ноль).
Теперь буду знать.
 
Ответить
СообщениеChe79, Здравствуйте!
+ФЯ 0;;

Спасибо за объяснение как скрыть форматом ячейки 0 (ноль).
Теперь буду знать.

Автор - Никанор
Дата добавления - 08.02.2018 в 15:17
Никанор Дата: Четверг, 08.02.2018, 15:17 | Сообщение № 14
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 212
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Che79, Здравствуйте!
+ФЯ 0;;

Спасибо за объяснение как скрыть форматом ячейки 0 (ноль).
Теперь буду знать.
 
Ответить
СообщениеChe79, Здравствуйте!
+ФЯ 0;;

Спасибо за объяснение как скрыть форматом ячейки 0 (ноль).
Теперь буду знать.

Автор - Никанор
Дата добавления - 08.02.2018 в 15:17
Никанор Дата: Четверг, 08.02.2018, 16:01 | Сообщение № 15
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 212
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Nic70y, Здравствуйте!
Спасибо за формулу – главное результат правильный и "не смешной".
 
Ответить
СообщениеNic70y, Здравствуйте!
Спасибо за формулу – главное результат правильный и "не смешной".

Автор - Никанор
Дата добавления - 08.02.2018 в 16:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » В результате не было #ЗНАЧ! а были пустые ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!