Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет количества непустых ячеек с условиями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет количества непустых ячеек с условиями (Формулы/Formulas)
Расчет количества непустых ячеек с условиями
LKV Дата: Четверг, 08.02.2018, 16:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Подскажите, пожалуйста, по какой формуле можно рассчитать количество непустых ячеек с заданными условиями?
Спасибо!
К сообщению приложен файл: 6321677.xlsx(9.5 Kb)
 
Ответить
СообщениеДобрый день!
Подскажите, пожалуйста, по какой формуле можно рассчитать количество непустых ячеек с заданными условиями?
Спасибо!

Автор - LKV
Дата добавления - 08.02.2018 в 16:17
Che79 Дата: Четверг, 08.02.2018, 16:22 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1271
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
LKV, здравствуйте. Так нужно?
Код
=СУММПРОИЗВ((C$2:C$14<>"")*($A$2:$A$14&" "&$B$2:$B$14=$B15))


Upd
Добавил файл с формулой
К сообщению приложен файл: 6321677_1.xlsx(10.1 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Четверг, 08.02.2018, 16:23
 
Ответить
СообщениеLKV, здравствуйте. Так нужно?
Код
=СУММПРОИЗВ((C$2:C$14<>"")*($A$2:$A$14&" "&$B$2:$B$14=$B15))


Upd
Добавил файл с формулой

Автор - Che79
Дата добавления - 08.02.2018 в 16:22
LKV Дата: Четверг, 08.02.2018, 16:31 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо, но я, видимо, некорректно оформил пример. Итоговая формула НЕ должна ссылаться на "объединенное условие".
К сообщению приложен файл: 7045976.xlsx(9.5 Kb)
 
Ответить
СообщениеСпасибо, но я, видимо, некорректно оформил пример. Итоговая формула НЕ должна ссылаться на "объединенное условие".

Автор - LKV
Дата добавления - 08.02.2018 в 16:31
abtextime Дата: Четверг, 08.02.2018, 16:32 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 829
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
Я бы просто накинул сводную и не парился. На Листе 2
К сообщению приложен файл: 5029992.xlsx(15.0 Kb)
 
Ответить
СообщениеЯ бы просто накинул сводную и не парился. На Листе 2

Автор - abtextime
Дата добавления - 08.02.2018 в 16:32
pabchek Дата: Четверг, 08.02.2018, 16:37 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 213 ±
Замечаний: 0% ±

Excel 2007
Мой вариант. Таки не сильно понял, но вдруг.. Формула для ячейки С15
Код
=СЧЁТЕСЛИ(C2:C13;"*")


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеМой вариант. Таки не сильно понял, но вдруг.. Формула для ячейки С15
Код
=СЧЁТЕСЛИ(C2:C13;"*")

Автор - pabchek
Дата добавления - 08.02.2018 в 16:37
Che79 Дата: Четверг, 08.02.2018, 16:44 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1271
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Сводной да, проще, но если формулой, то, может, так подойдёт?
Код
=СЧЁТЕСЛИМН($B$2:$B$13;$B2;C$2:C$13;"<>")
К сообщению приложен файл: 7045976_1.xlsx(10.1 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеСводной да, проще, но если формулой, то, может, так подойдёт?
Код
=СЧЁТЕСЛИМН($B$2:$B$13;$B2;C$2:C$13;"<>")

Автор - Che79
Дата добавления - 08.02.2018 в 16:44
LKV Дата: Четверг, 08.02.2018, 16:57 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Нет, к сожалению, нужно оба условие и именно формулой, сводная таблица не подойдет.
Но все равно большое спасибо!
 
Ответить
СообщениеНет, к сожалению, нужно оба условие и именно формулой, сводная таблица не подойдет.
Но все равно большое спасибо!

Автор - LKV
Дата добавления - 08.02.2018 в 16:57
abtextime Дата: Четверг, 08.02.2018, 17:08 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 829
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
а если так? )
К сообщению приложен файл: 2971452.xlsx(15.6 Kb)
 
Ответить
Сообщениеа если так? )

Автор - abtextime
Дата добавления - 08.02.2018 в 17:08
azma Дата: Четверг, 08.02.2018, 20:25 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
и можно так
К сообщению приложен файл: 5568041.xls(32.5 Kb)
 
Ответить
Сообщениеи можно так

Автор - azma
Дата добавления - 08.02.2018 в 20:25
azma Дата: Четверг, 08.02.2018, 20:32 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
или так
К сообщению приложен файл: 9924272.xls(32.0 Kb)
 
Ответить
Сообщениеили так

Автор - azma
Дата добавления - 08.02.2018 в 20:32
Che79 Дата: Четверг, 08.02.2018, 20:40 | Сообщение № 11
Группа: Проверенные
Ранг: Старожил
Сообщений: 1271
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Код
=СУММПРОИЗВ(($B$2:$B$13=СТРОКА($A1))*(D$2:D$13="да"))
К сообщению приложен файл: 5568041_1.xlsx(10.4 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(($B$2:$B$13=СТРОКА($A1))*(D$2:D$13="да"))

Автор - Che79
Дата добавления - 08.02.2018 в 20:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет количества непустых ячеек с условиями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!