Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция СЧЁТ не выполняется если в числе есть апостроф - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция СЧЁТ не выполняется если в числе есть апостроф (Формулы/Formulas)
Функция СЧЁТ не выполняется если в числе есть апостроф
stalber Дата: Пятница, 09.02.2018, 10:19 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Добрый день.

Необходима функция счёт.
Код
=СЧЁТ(A1:A20)


Но она не работает с числами которые имеют такое предупреждение "число в этой ячейке отформатировано как текст или перед ним стоит апостроф"

Каким образом можно решить данную проблему?

Вариант отформатировать числа в нормальный вид, чтобы заработала функция, мне не подойдёт.
К сообщению приложен файл: primerrr.xlsx(13.7 Kb)


Сообщение отредактировал awaddwaawddw - Пятница, 09.02.2018, 10:28
 
Ответить
СообщениеДобрый день.

Необходима функция счёт.
Код
=СЧЁТ(A1:A20)


Но она не работает с числами которые имеют такое предупреждение "число в этой ячейке отформатировано как текст или перед ним стоит апостроф"

Каким образом можно решить данную проблему?

Вариант отформатировать числа в нормальный вид, чтобы заработала функция, мне не подойдёт.

Автор - stalber
Дата добавления - 09.02.2018 в 10:19
китин Дата: Пятница, 09.02.2018, 10:22 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5103
Репутация: 809 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ответ есть, но будет после исправления нарушения правил форума в части оформленя сообщений ( формулу надо в тэги заключить)
Как оформлять сообщения?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 09.02.2018, 10:23
 
Ответить
Сообщениеответ есть, но будет после исправления нарушения правил форума в части оформленя сообщений ( формулу надо в тэги заключить)
Как оформлять сообщения?

Автор - китин
Дата добавления - 09.02.2018 в 10:22
stalber Дата: Пятница, 09.02.2018, 10:28 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
исправил
 
Ответить
Сообщениеисправил

Автор - stalber
Дата добавления - 09.02.2018 в 10:28
китин Дата: Пятница, 09.02.2018, 10:30 | Сообщение № 4
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5103
Репутация: 809 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
если у вас все так, как в примере можно применить
Код
=СЧЁТЕСЛИ(F2:F500;"<>-")
К сообщению приложен файл: awaddwaawddw.xlsx(14.2 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 09.02.2018, 10:33
 
Ответить
Сообщениеесли у вас все так, как в примере можно применить
Код
=СЧЁТЕСЛИ(F2:F500;"<>-")

Автор - китин
Дата добавления - 09.02.2018 в 10:30
stalber Дата: Пятница, 09.02.2018, 10:33 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Благодарю за помощь, данная формула
Код
=СЧЁТЕСЛИ(F2:F500;"<>-")
разрешила проблему.

Тема больше не актуальна. Решение найдено.
 
Ответить
СообщениеБлагодарю за помощь, данная формула
Код
=СЧЁТЕСЛИ(F2:F500;"<>-")
разрешила проблему.

Тема больше не актуальна. Решение найдено.

Автор - stalber
Дата добавления - 09.02.2018 в 10:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция СЧЁТ не выполняется если в числе есть апостроф (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!