Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Добавление пропущенных чисел (номеров) в столбце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Добавление пропущенных чисел (номеров) в столбце (Формулы/Formulas)
Добавление пропущенных чисел (номеров) в столбце
dev500 Дата: Среда, 28.02.2018, 12:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Добрый день,
Есть таблица с номерами абонентов такого вида:
9100 Иванов Петр
9101 Петров Иван
9122 Иванов Сергей
9123 Пупков Эдуард

Необходимо вставить пропущенные номера, чтобы таблица имела вид:

9100 Иванов Петр
9101 Петров Иван
9102 "Свободный номер"
9103
…...
9122 Иванов Сергей
9123 Пупков Эдуард
9124
9125
И так до 9999.
Большое спасибо всем кто готов помочь.
 
Ответить
СообщениеДобрый день,
Есть таблица с номерами абонентов такого вида:
9100 Иванов Петр
9101 Петров Иван
9122 Иванов Сергей
9123 Пупков Эдуард

Необходимо вставить пропущенные номера, чтобы таблица имела вид:

9100 Иванов Петр
9101 Петров Иван
9102 "Свободный номер"
9103
…...
9122 Иванов Сергей
9123 Пупков Эдуард
9124
9125
И так до 9999.
Большое спасибо всем кто готов помочь.

Автор - dev500
Дата добавления - 28.02.2018 в 12:39
Che79 Дата: Среда, 28.02.2018, 12:42 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
dev500, здравствуйте. Файл-пример (с сохранением реальной его структуры) от Вас будет или Вы нам самим предлагаете нарисовать?


Делай нормально и будет нормально!
 
Ответить
Сообщениеdev500, здравствуйте. Файл-пример (с сохранением реальной его структуры) от Вас будет или Вы нам самим предлагаете нарисовать?

Автор - Che79
Дата добавления - 28.02.2018 в 12:42
dev500 Дата: Среда, 28.02.2018, 12:52 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
файл во вложении, целиком файл не могу выложить.
данные отсортированы по возрастанию.
К сообщению приложен файл: 6047716.xls(13.5 Kb)
 
Ответить
Сообщениефайл во вложении, целиком файл не могу выложить.
данные отсортированы по возрастанию.

Автор - dev500
Дата добавления - 28.02.2018 в 12:52
AlexM Дата: Среда, 28.02.2018, 13:02 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3782
Репутация: 952 ±
Замечаний: 0% ±

Excel 2003
В Е1
Код
=ЕСЛИ(СТРОКА(A9100)>МАКС(A:A);"";СТРОКА(A9100))
В F1
Код
=ЕСЛИОШИБКА(ВПР(E1;A$1:B$999;2;)&"";"")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеВ Е1
Код
=ЕСЛИ(СТРОКА(A9100)>МАКС(A:A);"";СТРОКА(A9100))
В F1
Код
=ЕСЛИОШИБКА(ВПР(E1;A$1:B$999;2;)&"";"")

Автор - AlexM
Дата добавления - 28.02.2018 в 13:02
Che79 Дата: Среда, 28.02.2018, 13:07 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
номера Исправлено!
Код
=--ЕСЛИ(СТРОКА()>10;91&СТРОКА(A1)-1;910&СТРОКА(A1)-1)

фио
Код
=ЕСЛИОШИБКА(ВПР(D1;$A$1:$B$1000;2;);)
+ ФЯ ;;;@

[offtop] AlexM, Алексей, честно - не подсматривал...


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Среда, 28.02.2018, 13:16
 
Ответить
Сообщениеномера Исправлено!
Код
=--ЕСЛИ(СТРОКА()>10;91&СТРОКА(A1)-1;910&СТРОКА(A1)-1)

фио
Код
=ЕСЛИОШИБКА(ВПР(D1;$A$1:$B$1000;2;);)
+ ФЯ ;;;@

[offtop] AlexM, Алексей, честно - не подсматривал...

Автор - Che79
Дата добавления - 28.02.2018 в 13:07
dev500 Дата: Среда, 28.02.2018, 13:18 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Друзья, это все очень здорово! Но я в екселе чайник, объясните пожалуйста как это применить на вложенном файле ?
 
Ответить
СообщениеДрузья, это все очень здорово! Но я в екселе чайник, объясните пожалуйста как это применить на вложенном файле ?

Автор - dev500
Дата добавления - 28.02.2018 в 13:18
AlexM Дата: Среда, 28.02.2018, 13:21 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3782
Репутация: 952 ±
Замечаний: 0% ±

Excel 2003
Che79, я знаю. :-)
номера можно без минусов и скобок
Код
=910&СТРОКА(A1)-1
Моя формула не выведет номер больше максимального в столбце А
dev500, Функцию ЕСЛИОШИБКА() ставьте сами
К сообщению приложен файл: 6047716_01.xls(19.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 28.02.2018, 13:24
 
Ответить
СообщениеChe79, я знаю. :-)
номера можно без минусов и скобок
Код
=910&СТРОКА(A1)-1
Моя формула не выведет номер больше максимального в столбце А
dev500, Функцию ЕСЛИОШИБКА() ставьте сами

Автор - AlexM
Дата добавления - 28.02.2018 в 13:21
dev500 Дата: Среда, 28.02.2018, 13:35 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
AlexM, огромное спасибо за помощь! Ваше решение для меня идеально, раньше, чтобы поправить таблицу, уходило очень много времени.
 
Ответить
СообщениеAlexM, огромное спасибо за помощь! Ваше решение для меня идеально, раньше, чтобы поправить таблицу, уходило очень много времени.

Автор - dev500
Дата добавления - 28.02.2018 в 13:35
sboy Дата: Среда, 28.02.2018, 14:34 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2237
Репутация: 633 ±
Замечаний: 0% ±

Excel 2010
Вариант макросом (нажать на кнопку)
[vba]
Код
Sub dev500()
    With Application: .ScreenUpdating = False: Min_ = .Min(Range("A:A")): Max_ = .Max(Range("A:A")): End With
    With Range("C1").Resize(Max_ - Min_ + 1, 1): .Formula = "=ROW()-1+" & Min_: .Value = .Value: End With
    With Range("D1").Resize(Max_ - Min_ + 1, 1)
        .FormulaR1C1 = "=IFERROR(INDEX(C[-2],MATCH(RC[-1],C[-3],0)), """")"
        .Value = .Value
    End With
    Range("A:B").Delete
    Range("B:B").NumberFormat = ";;"
    Application.ScreenUpdating = True
End Sub
[/vba]
К сообщению приложен файл: 7801122.xls(34.5 Kb)
 
Ответить
СообщениеВариант макросом (нажать на кнопку)
[vba]
Код
Sub dev500()
    With Application: .ScreenUpdating = False: Min_ = .Min(Range("A:A")): Max_ = .Max(Range("A:A")): End With
    With Range("C1").Resize(Max_ - Min_ + 1, 1): .Formula = "=ROW()-1+" & Min_: .Value = .Value: End With
    With Range("D1").Resize(Max_ - Min_ + 1, 1)
        .FormulaR1C1 = "=IFERROR(INDEX(C[-2],MATCH(RC[-1],C[-3],0)), """")"
        .Value = .Value
    End With
    Range("A:B").Delete
    Range("B:B").NumberFormat = ";;"
    Application.ScreenUpdating = True
End Sub
[/vba]

Автор - sboy
Дата добавления - 28.02.2018 в 14:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Добавление пропущенных чисел (номеров) в столбце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!