Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбрать нужные столбцы согласно условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать нужные столбцы согласно условию (Формулы/Formulas)
Выбрать нужные столбцы согласно условию
АЛЕКСАНДР1986 Дата: Среда, 28.02.2018, 15:03 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 151
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
Появилась небольшая проблемка!
Есть изначально зеленая таблица исходя из красной строки (13 строки) нужно выбрать только те столбцы где значения больше нуля!
примерно я думал что благодаря вот этому что-то получится но получилась полная белиберда которая представлена в желтой таблице!
заранее спасибо за помощь!
Код
=ЕСЛИОШИБКА(ИНДЕКС($G13:$R13;;НАИМЕНЬШИЙ(ЕСЛИ($G$13:$R$13>0;СТОЛБЕЦ($G$13:$R$13)-6;"");СТОЛБЕЦ(E1)));0)
К сообщению приложен файл: __.xlsx(13.9 Kb)


Сообщение отредактировал АЛЕКСАНДР1986 - Среда, 28.02.2018, 15:10
 
Ответить
СообщениеДобрый день!
Появилась небольшая проблемка!
Есть изначально зеленая таблица исходя из красной строки (13 строки) нужно выбрать только те столбцы где значения больше нуля!
примерно я думал что благодаря вот этому что-то получится но получилась полная белиберда которая представлена в желтой таблице!
заранее спасибо за помощь!
Код
=ЕСЛИОШИБКА(ИНДЕКС($G13:$R13;;НАИМЕНЬШИЙ(ЕСЛИ($G$13:$R$13>0;СТОЛБЕЦ($G$13:$R$13)-6;"");СТОЛБЕЦ(E1)));0)

Автор - АЛЕКСАНДР1986
Дата добавления - 28.02.2018 в 15:03
Che79 Дата: Среда, 28.02.2018, 15:11 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1266
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
удалено, ошибка


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Среда, 28.02.2018, 15:16
 
Ответить
Сообщениеудалено, ошибка

Автор - Che79
Дата добавления - 28.02.2018 в 15:11
АЛЕКСАНДР1986 Дата: Среда, 28.02.2018, 15:17 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 151
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
ок!


Сообщение отредактировал АЛЕКСАНДР1986 - Среда, 28.02.2018, 15:17
 
Ответить
Сообщениеок!

Автор - АЛЕКСАНДР1986
Дата добавления - 28.02.2018 в 15:17
sboy Дата: Среда, 28.02.2018, 15:21 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1872
Репутация: 552 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
в последнем аргументе СТОЛБЕЦ, надо Е на А поменять
Код
=ЕСЛИОШИБКА(ИНДЕКС($G13:$R13;;НАИМЕНЬШИЙ(ЕСЛИ($G$13:$R$13>0;СТОЛБЕЦ($G$13:$R$13)-6;"");СТОЛБЕЦ(A1)));0)
К сообщению приложен файл: -13-.xlsx(13.8 Kb)
 
Ответить
СообщениеДобрый день.
в последнем аргументе СТОЛБЕЦ, надо Е на А поменять
Код
=ЕСЛИОШИБКА(ИНДЕКС($G13:$R13;;НАИМЕНЬШИЙ(ЕСЛИ($G$13:$R$13>0;СТОЛБЕЦ($G$13:$R$13)-6;"");СТОЛБЕЦ(A1)));0)

Автор - sboy
Дата добавления - 28.02.2018 в 15:21
Kuzya03 Дата: Среда, 28.02.2018, 15:55 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. подскажите, при выработке 8500 получается 2500, при выработке 9000 получается на 200р больше, при выработке 9500 получается на 400р больше и т. д. При том что 8500,9000,9500, находятся в одной ячейке и постоянно меняются.
 
Ответить
СообщениеДобрый день. подскажите, при выработке 8500 получается 2500, при выработке 9000 получается на 200р больше, при выработке 9500 получается на 400р больше и т. д. При том что 8500,9000,9500, находятся в одной ячейке и постоянно меняются.

Автор - Kuzya03
Дата добавления - 28.02.2018 в 15:55
Che79 Дата: Среда, 28.02.2018, 15:58 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1266
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Kuzya03, добрый день. Читайте Правила форума, создавайте свою тему, прикладывайте файл-пример с сохранением структуры (что есть изначально и что хотите на выходе).


Делай нормально и будет нормально!
 
Ответить
СообщениеKuzya03, добрый день. Читайте Правила форума, создавайте свою тему, прикладывайте файл-пример с сохранением структуры (что есть изначально и что хотите на выходе).

Автор - Che79
Дата добавления - 28.02.2018 в 15:58
Kuzya03 Дата: Среда, 28.02.2018, 16:45 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Все что есть я выложил. Просто нужно помочь составить расчет при вышеприведенных файлах. И вообще это реально сделать или нет?????
 
Ответить
СообщениеВсе что есть я выложил. Просто нужно помочь составить расчет при вышеприведенных файлах. И вообще это реально сделать или нет?????

Автор - Kuzya03
Дата добавления - 28.02.2018 в 16:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать нужные столбцы согласно условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!