Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/перевести определенное количество чисел в дату - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перевести определенное количество чисел в дату (Формулы/Formulas)
перевести определенное количество чисел в дату
sergay1988 Дата: Четверг, 01.03.2018, 08:52 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте,уважаемые форумчане, у меня возник, один вопрос, есть у меня таблица, в которой есть ИИН, если точнее столбец E2, первые цифры это год,месяц,дата рождения(к примеру МУХАМЕДИНОВ НУРЛАН ЕСИМОВИЧ ячейка B2. ИИН у него 830606351498 ячейка E2, 06.06.1983 год рождения) чтобы дата рождения ставилось в ячейки G2?
К сообщению приложен файл: 7607260.xlsx(22.0 Kb)


Сообщение отредактировал sergay1988 - Четверг, 01.03.2018, 08:52
 
Ответить
СообщениеЗдравствуйте,уважаемые форумчане, у меня возник, один вопрос, есть у меня таблица, в которой есть ИИН, если точнее столбец E2, первые цифры это год,месяц,дата рождения(к примеру МУХАМЕДИНОВ НУРЛАН ЕСИМОВИЧ ячейка B2. ИИН у него 830606351498 ячейка E2, 06.06.1983 год рождения) чтобы дата рождения ставилось в ячейки G2?

Автор - sergay1988
Дата добавления - 01.03.2018 в 08:52
китин Дата: Четверг, 01.03.2018, 09:01 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5020
Репутация: 797 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Здравствуйте. так?
Код
=ЕСЛИОШИБКА(ДАТА(19&ЛЕВБ($E2;2);ПСТР($E2;3;2);ПСТР($E2;5;2));"")

[p.s.]но это если год рождения в прошлом веке
К сообщению приложен файл: Date.xlsx(24.0 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 01.03.2018, 09:02
 
Ответить
СообщениеЗдравствуйте. так?
Код
=ЕСЛИОШИБКА(ДАТА(19&ЛЕВБ($E2;2);ПСТР($E2;3;2);ПСТР($E2;5;2));"")

[p.s.]но это если год рождения в прошлом веке

Автор - китин
Дата добавления - 01.03.2018 в 09:01
sergay1988 Дата: Четверг, 01.03.2018, 09:22 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин, а если поставить критерий с 1990 по 2018 год?
 
Ответить
Сообщениекитин, а если поставить критерий с 1990 по 2018 год?

Автор - sergay1988
Дата добавления - 01.03.2018 в 09:22
sergay1988 Дата: Четверг, 01.03.2018, 09:27 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин, спасибо, вам!!! пойдет
 
Ответить
Сообщениекитин, спасибо, вам!!! пойдет

Автор - sergay1988
Дата добавления - 01.03.2018 в 09:27
китин Дата: Четверг, 01.03.2018, 09:31 | Сообщение № 5
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5020
Репутация: 797 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Ну тогда усложним малость
Код
=ЕСЛИОШИБКА(ДАТА(ЕСЛИ(--ЛЕВБ($E2;2)<=18;20&ЛЕВБ($E2;2);19&ЛЕВБ($E2;2));ПСТР($E2;3;2);ПСТР($E2;5;2));"")

Думаю, что родившихся ранее 1919 года в списке нет
К сообщению приложен файл: Date22.xlsx(24.2 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 01.03.2018, 09:33
 
Ответить
СообщениеНу тогда усложним малость
Код
=ЕСЛИОШИБКА(ДАТА(ЕСЛИ(--ЛЕВБ($E2;2)<=18;20&ЛЕВБ($E2;2);19&ЛЕВБ($E2;2));ПСТР($E2;3;2);ПСТР($E2;5;2));"")

Думаю, что родившихся ранее 1919 года в списке нет

Автор - китин
Дата добавления - 01.03.2018 в 09:31
AlexM Дата: Четверг, 01.03.2018, 10:13 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3755
Репутация: 947 ±
Замечаний: 0% ±

Excel 2003
Аналог формулы из сообщения №5, только без функции ЕСЛИОШИБКА()
Код
=--(19+(--ЛЕВБ(E2;2)<=18)&ТЕКСТ(ЛЕВБ(E2;6);"00\/00\/00"))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Четверг, 01.03.2018, 10:14
 
Ответить
СообщениеАналог формулы из сообщения №5, только без функции ЕСЛИОШИБКА()
Код
=--(19+(--ЛЕВБ(E2;2)<=18)&ТЕКСТ(ЛЕВБ(E2;6);"00\/00\/00"))

Автор - AlexM
Дата добавления - 01.03.2018 в 10:13
китин Дата: Четверг, 01.03.2018, 10:19 | Сообщение № 7
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5020
Репутация: 797 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
AlexM, hands hands hands hands hands hands hands


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеAlexM, hands hands hands hands hands hands hands

Автор - китин
Дата добавления - 01.03.2018 в 10:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перевести определенное количество чисел в дату (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!