Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск пепесечения (значения) трех вертикальных массивов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск пепесечения (значения) трех вертикальных массивов (Формулы/Formulas)
поиск пепесечения (значения) трех вертикальных массивов
LKV Дата: Четверг, 01.03.2018, 15:46 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Подскажите, пожалуйста, каким образом можно решить задачу поиска значения через обработку трех вертикальных массивов данных, притом что обрабатывать массивы нужно строго в формате А:А, В:В и т.д., т.е. без указания конкретных строк? Т.е. необходимо на Лист 1 подтянуть исполнителей, обрабатывая столбцы A, B, C на Листе 2.
Спасибо!
К сообщению приложен файл: _3.xlsx(10.1 Kb)
 
Ответить
СообщениеДобрый день!
Подскажите, пожалуйста, каким образом можно решить задачу поиска значения через обработку трех вертикальных массивов данных, притом что обрабатывать массивы нужно строго в формате А:А, В:В и т.д., т.е. без указания конкретных строк? Т.е. необходимо на Лист 1 подтянуть исполнителей, обрабатывая столбцы A, B, C на Листе 2.
Спасибо!

Автор - LKV
Дата добавления - 01.03.2018 в 15:46
Nic70y Дата: Четверг, 01.03.2018, 15:54 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4679
Репутация: 1008 ±
Замечаний: 0% ±

Excel 2013
объекты всегда идут друг за другом или могут перемешаться?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеобъекты всегда идут друг за другом или могут перемешаться?

Автор - Nic70y
Дата добавления - 01.03.2018 в 15:54
sboy Дата: Четверг, 01.03.2018, 15:56 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1872
Репутация: 552 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Пепесечение можно найти вот такой формулой массива
Код
=ИНДЕКС(Лист2!C:C;ПОИСКПОЗ(A$1&A2;Лист2!A:A&Лист2!B:B;))

только непонятно почему
обрабатывать массивы нужно строго в формате А:А, В:В и т.д.

это может сильно затруднить работу файла при больших объемах информации
К сообщению приложен файл: _3-3-.xlsx(10.8 Kb)
 
Ответить
СообщениеДобрый день.
Пепесечение можно найти вот такой формулой массива
Код
=ИНДЕКС(Лист2!C:C;ПОИСКПОЗ(A$1&A2;Лист2!A:A&Лист2!B:B;))

только непонятно почему
обрабатывать массивы нужно строго в формате А:А, В:В и т.д.

это может сильно затруднить работу файла при больших объемах информации

Автор - sboy
Дата добавления - 01.03.2018 в 15:56
LKV Дата: Четверг, 01.03.2018, 15:56 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, всегда друг за другом
 
Ответить
СообщениеNic70y, всегда друг за другом

Автор - LKV
Дата добавления - 01.03.2018 в 15:56
LKV Дата: Четверг, 01.03.2018, 15:59 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
sboy, спасибо!!!
 
Ответить
Сообщениеsboy, спасибо!!!

Автор - LKV
Дата добавления - 01.03.2018 в 15:59
Che79 Дата: Четверг, 01.03.2018, 16:01 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1266
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Пепесечение можно найти вот такой формулой
Код
=ПРОСМОТР(;-ПОИСК($A$1&$A2;Лист2!A:A&Лист2!B:B);Лист2!C:C)


Делай нормально и будет нормально!
 
Ответить
Сообщение
Пепесечение можно найти вот такой формулой
Код
=ПРОСМОТР(;-ПОИСК($A$1&$A2;Лист2!A:A&Лист2!B:B);Лист2!C:C)

Автор - Che79
Дата добавления - 01.03.2018 в 16:01
Nic70y Дата: Четверг, 01.03.2018, 16:02 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4679
Репутация: 1008 ±
Замечаний: 0% ±

Excel 2013
всегда
ну тогда обычная формула
Код
=ИНДЕКС(Лист2!$C:$C;ПОИСКПОЗ(A2;ИНДЕКС(Лист2!$B:$B;ПОИСКПОЗ(A$1;Лист2!$A:$A;)):ИНДЕКС(Лист2!$B:$B;ЕСЛИОШИБКА(ПОИСКПОЗ(C$1;Лист2!$A:$A;);ПОИСКПОЗ("我";Лист2!$A:$A)));)+ПОИСКПОЗ(A$1;Лист2!$A:$A;)-1)
К сообщению приложен файл: 8223019.xlsx(10.7 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
всегда
ну тогда обычная формула
Код
=ИНДЕКС(Лист2!$C:$C;ПОИСКПОЗ(A2;ИНДЕКС(Лист2!$B:$B;ПОИСКПОЗ(A$1;Лист2!$A:$A;)):ИНДЕКС(Лист2!$B:$B;ЕСЛИОШИБКА(ПОИСКПОЗ(C$1;Лист2!$A:$A;);ПОИСКПОЗ("我";Лист2!$A:$A)));)+ПОИСКПОЗ(A$1;Лист2!$A:$A;)-1)

Автор - Nic70y
Дата добавления - 01.03.2018 в 16:02
jakim Дата: Четверг, 01.03.2018, 16:37 | Сообщение № 8
Группа: Друзья
Ранг: Ветеран
Сообщений: 838
Репутация: 221 ±
Замечаний: 0% ±

Excel 2010
Формула без массивного ввода

Код
=IFERROR(INDEX(Лист2!$C$2:$C$150;AGGREGATE(15;6;ROW($1:$150)/(A$1=Лист2!$A$2:$A$150)/(A2=Лист2!$B$2:$B$150);1));"")
К сообщению приложен файл: 3466077.xlsx(10.7 Kb)


Сообщение отредактировал jakim - Четверг, 01.03.2018, 16:39
 
Ответить
Сообщение
Формула без массивного ввода

Код
=IFERROR(INDEX(Лист2!$C$2:$C$150;AGGREGATE(15;6;ROW($1:$150)/(A$1=Лист2!$A$2:$A$150)/(A2=Лист2!$B$2:$B$150);1));"")

Автор - jakim
Дата добавления - 01.03.2018 в 16:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск пепесечения (значения) трех вертикальных массивов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!