Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Использование ВПР с учетом строк и столбцов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Использование ВПР с учетом строк и столбцов (Формулы/Formulas)
Использование ВПР с учетом строк и столбцов
volya09 Дата: Среда, 07.03.2018, 11:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день,

Необходима помощь с функцией впр. На 1 вкладке исходные данные (в стандартной таблице их естественно больше), во 2 вкладе как данные должны быть представлены для дальнейшего расчета. Мне совсем не хочется заниматься копирование. Если у кого-то есть возможность подсказать, буду благодарна. Спасибо!
К сообщению приложен файл: 0116206.xlsx(9.1 Kb)
 
Ответить
СообщениеДобрый день,

Необходима помощь с функцией впр. На 1 вкладке исходные данные (в стандартной таблице их естественно больше), во 2 вкладе как данные должны быть представлены для дальнейшего расчета. Мне совсем не хочется заниматься копирование. Если у кого-то есть возможность подсказать, буду благодарна. Спасибо!

Автор - volya09
Дата добавления - 07.03.2018 в 11:47
китин Дата: Среда, 07.03.2018, 12:00 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4885
Репутация: 780 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну не ВПР а ИНДЕКС, да еще и массивный
Код
=ИНДЕКС(Лист1!$C$4:$C$9;ПОИСКПОЗ($A4&B$3;Лист1!$A$4:$A$9&Лист1!$B$4:$B$9;0))
К сообщению приложен файл: volya09.xlsx(9.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 07.03.2018, 12:00
 
Ответить
Сообщениену не ВПР а ИНДЕКС, да еще и массивный
Код
=ИНДЕКС(Лист1!$C$4:$C$9;ПОИСКПОЗ($A4&B$3;Лист1!$A$4:$A$9&Лист1!$B$4:$B$9;0))

Автор - китин
Дата добавления - 07.03.2018 в 12:00
Pelena Дата: Среда, 07.03.2018, 12:03 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12753
Репутация: 2809 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Варианты
Код
=СУММЕСЛИМН(Лист1!$C$4:$C$9;Лист1!$A$4:$A$9;$A4;Лист1!$B$4:$B$9;B$3)

Код
=СУММПРОИЗВ(($A4=Лист1!$A$4:$A$9)*(B$3=Лист1!$B$4:$B$9)*Лист1!$C$4:$C$9)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВарианты
Код
=СУММЕСЛИМН(Лист1!$C$4:$C$9;Лист1!$A$4:$A$9;$A4;Лист1!$B$4:$B$9;B$3)

Код
=СУММПРОИЗВ(($A4=Лист1!$A$4:$A$9)*(B$3=Лист1!$B$4:$B$9)*Лист1!$C$4:$C$9)

Автор - Pelena
Дата добавления - 07.03.2018 в 12:03
Nic70y Дата: Среда, 07.03.2018, 12:04 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4675
Репутация: 1006 ±
Замечаний: 0% ±

Excel 2013
Не так не пойдет!
ВПР - значит ВПР!
массивная
Код
=ВПР(B$3;ЕСЛИ($A4=Лист1!$A$4:$A$9;Лист1!$B$4:$C$9);2;)
К сообщению приложен файл: 3976751.xlsx(9.5 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Среда, 07.03.2018, 12:06
 
Ответить
СообщениеНе так не пойдет!
ВПР - значит ВПР!
массивная
Код
=ВПР(B$3;ЕСЛИ($A4=Лист1!$A$4:$A$9;Лист1!$B$4:$C$9);2;)

Автор - Nic70y
Дата добавления - 07.03.2018 в 12:04
Che79 Дата: Среда, 07.03.2018, 13:12 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1266
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Вариант . Обычная (не массивная) на Листе 2
Код
=ПРОСМОТР(;-ПОИСК($A4&B$3;Лист1!$A$4:$A$9&Лист1!$B$4:$B$9);Лист1!$C$4:$C$9)
ВПР - значит ВПР!
Формула массива на Листе 3
Код
=ВПР($A4&B$3;ЕСЛИ({1;0};Лист1!$A$4:$A$9&Лист1!$B$4:$B$9;Лист1!$C$4:$C$9);2;)
К сообщению приложен файл: 0116206_1.xlsx(10.4 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Среда, 07.03.2018, 13:59
 
Ответить
СообщениеВариант . Обычная (не массивная) на Листе 2
Код
=ПРОСМОТР(;-ПОИСК($A4&B$3;Лист1!$A$4:$A$9&Лист1!$B$4:$B$9);Лист1!$C$4:$C$9)
ВПР - значит ВПР!
Формула массива на Листе 3
Код
=ВПР($A4&B$3;ЕСЛИ({1;0};Лист1!$A$4:$A$9&Лист1!$B$4:$B$9;Лист1!$C$4:$C$9);2;)

Автор - Che79
Дата добавления - 07.03.2018 в 13:12
Pelena Дата: Среда, 07.03.2018, 13:48 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12753
Репутация: 2809 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
А ещё сводной можно, особенно если
в стандартной таблице их естественно больше
К сообщению приложен файл: 9382882.xlsx(13.2 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеА ещё сводной можно, особенно если
в стандартной таблице их естественно больше

Автор - Pelena
Дата добавления - 07.03.2018 в 13:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Использование ВПР с учетом строк и столбцов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!