Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Совмещение строк по принципу вхождения одинаковых значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Совмещение строк по принципу вхождения одинаковых значений (Формулы/Formulas)
Совмещение строк по принципу вхождения одинаковых значений
Ефгений Дата: Пятница, 09.03.2018, 16:24 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

2010
здравия Вам умный люд. помогите пожалуйста в решении одной задачки в exel. В строках в столбце В, есть значения которые встречаются в столбце А. Существует ли какой нибудь метод, при котором строки в столбике В, встанут напротив строк в столбце А, по совпадению в строках хотябы одного слова? Пример ниже.
К сообщению приложен файл: 1393234.xlsx(12.1 Kb)
 
Ответить
Сообщениездравия Вам умный люд. помогите пожалуйста в решении одной задачки в exel. В строках в столбце В, есть значения которые встречаются в столбце А. Существует ли какой нибудь метод, при котором строки в столбике В, встанут напротив строк в столбце А, по совпадению в строках хотябы одного слова? Пример ниже.

Автор - Ефгений
Дата добавления - 09.03.2018 в 16:24
gling Дата: Пятница, 09.03.2018, 18:07 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1814
Репутация: 439 ±
Замечаний: 0% ±

2010
Здравствуйте. Попробуйте формулу массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$36;ПОИСКПОЗ(1=1;ЕЧИСЛО(ПОИСК(A2;$B$2:$B$36));));"")
К сообщению приложен файл: 5702939.xlsx(19.7 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте. Попробуйте формулу массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$36;ПОИСКПОЗ(1=1;ЕЧИСЛО(ПОИСК(A2;$B$2:$B$36));));"")

Автор - gling
Дата добавления - 09.03.2018 в 18:07
Ефгений Дата: Пятница, 09.03.2018, 23:52 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

2010
Ух ты, работает :D .Спасибо Вам большущее за помощь. Очень вдохновляет то, что есть люди которые готовы прийти на помощь. Спасибо Вам еще раз.
 
Ответить
СообщениеУх ты, работает :D .Спасибо Вам большущее за помощь. Очень вдохновляет то, что есть люди которые готовы прийти на помощь. Спасибо Вам еще раз.

Автор - Ефгений
Дата добавления - 09.03.2018 в 23:52
Ефгений Дата: Суббота, 10.03.2018, 00:16 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

2010
Скажите а возможно получать все строки по столбцу В? Дело в том что например ISUZU 2 разные строки, а я только 1 получаю.
 
Ответить
СообщениеСкажите а возможно получать все строки по столбцу В? Дело в том что например ISUZU 2 разные строки, а я только 1 получаю.

Автор - Ефгений
Дата добавления - 10.03.2018 в 00:16
gling Дата: Суббота, 10.03.2018, 00:29 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1814
Репутация: 439 ±
Замечаний: 0% ±

2010
Может лучше против данных из столбца В, прописать совпадение которое есть в столбце А?
К сообщению приложен файл: 9114159.xlsx(23.6 Kb)


ЯД-41001506838083
 
Ответить
СообщениеМожет лучше против данных из столбца В, прописать совпадение которое есть в столбце А?

Автор - gling
Дата добавления - 10.03.2018 в 00:29
Светлый Дата: Суббота, 10.03.2018, 00:55 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 612
Репутация: 165 ±
Замечаний: 0% ±

Excel 2010
Формула массива. Копируем вниз и вправо.
Код
=ИНДЕКС($B:$B;НАИМЕНЬШИЙ(ЕСЛИ(1-ЕОШ(ПОИСК($A2;$B$2:$B$215));СТРОКА(B$2:B$215);999);СТОЛБЕЦ(A2)))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеФормула массива. Копируем вниз и вправо.
Код
=ИНДЕКС($B:$B;НАИМЕНЬШИЙ(ЕСЛИ(1-ЕОШ(ПОИСК($A2;$B$2:$B$215));СТРОКА(B$2:B$215);999);СТОЛБЕЦ(A2)))

Автор - Светлый
Дата добавления - 10.03.2018 в 00:55
Ефгений Дата: Суббота, 10.03.2018, 09:27 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

2010
дело в том,что в столбце А все строки оформлены ссылками, а данный метод возвращает строки без ссылок. Возможно их сохранить?
 
Ответить
Сообщениедело в том,что в столбце А все строки оформлены ссылками, а данный метод возвращает строки без ссылок. Возможно их сохранить?

Автор - Ефгений
Дата добавления - 10.03.2018 в 09:27
Ефгений Дата: Понедельник, 12.03.2018, 00:13 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

2010
По всей видимости такое не возможно <_<
 
Ответить
СообщениеПо всей видимости такое не возможно <_<

Автор - Ефгений
Дата добавления - 12.03.2018 в 00:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Совмещение строк по принципу вхождения одинаковых значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!