Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР по частичному совпадению - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР по частичному совпадению (Формулы/Formulas)
ВПР по частичному совпадению
hbs-group Дата: Воскресенье, 11.03.2018, 23:38 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Уважаемые форумчане!
Пожалуйста, помогите мне с вопросом.
Необходимо сделать ВПР по частичному совпадению.

В прикрепленном файле 2 листа.
Нужно в "Лист 1" взять ячейку, и по любому из слов в этой ячейке найти совпадение в "Листе 2".
p.s. нужно, чтобы в столбце D появился сайт (и соответственно, сравнивать нужно по городу - Абакан и т.п.)
К сообщению приложен файл: 7061760.xlsx(10.1 Kb)


Сообщение отредактировал hbs-group - Воскресенье, 11.03.2018, 23:41
 
Ответить
СообщениеУважаемые форумчане!
Пожалуйста, помогите мне с вопросом.
Необходимо сделать ВПР по частичному совпадению.

В прикрепленном файле 2 листа.
Нужно в "Лист 1" взять ячейку, и по любому из слов в этой ячейке найти совпадение в "Листе 2".
p.s. нужно, чтобы в столбце D появился сайт (и соответственно, сравнивать нужно по городу - Абакан и т.п.)

Автор - hbs-group
Дата добавления - 11.03.2018 в 23:38
bmv98rus Дата: Понедельник, 12.03.2018, 07:54 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1258
Репутация: 214 ±
Замечаний: 0% ±

Excel 2013/2016
hbs-group, Боюсь, что надо действовать от обратного и искать вячейке листа 1 значения из листа 2. Илм, если это возможно выделить город на листе 1, если он имеет определенное место в строке.
Код
=IFERROR(INDEX(Лист2!$B:$B;LOOKUP(2;1/ISNUMBER(FIND(Лист2!A$1:$A$3;B1));ROW(Лист2!$A$1:$A$3)));"не найдено")

или
Код
=IFERROR(INDEX(Лист2!$B:$B;LOOKUP(2;1/ISNUMBER(SEARCH(Лист2!A$1:$A$3;B1));ROW(Лист2!$A$1:$A$3)));"не найдено")
если регистр не важен

В данном варианте выведет последнее совпадение.
К сообщению приложен файл: Copy_of_7061760.xlsx(10.2 Kb)


Сообщение отредактировал bmv98rus - Понедельник, 12.03.2018, 09:25
 
Ответить
Сообщениеhbs-group, Боюсь, что надо действовать от обратного и искать вячейке листа 1 значения из листа 2. Илм, если это возможно выделить город на листе 1, если он имеет определенное место в строке.
Код
=IFERROR(INDEX(Лист2!$B:$B;LOOKUP(2;1/ISNUMBER(FIND(Лист2!A$1:$A$3;B1));ROW(Лист2!$A$1:$A$3)));"не найдено")

или
Код
=IFERROR(INDEX(Лист2!$B:$B;LOOKUP(2;1/ISNUMBER(SEARCH(Лист2!A$1:$A$3;B1));ROW(Лист2!$A$1:$A$3)));"не найдено")
если регистр не важен

В данном варианте выведет последнее совпадение.

Автор - bmv98rus
Дата добавления - 12.03.2018 в 07:54
AlexM Дата: Понедельник, 12.03.2018, 10:36 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3741
Репутация: 944 ±
Замечаний: 0% ±

Excel 2003
можно чуть короче
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/ЕЧИСЛО(НАЙТИ(Лист2!A$1:A$3;B1));Лист2!B$1:B$3);"не найдено")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеможно чуть короче
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/ЕЧИСЛО(НАЙТИ(Лист2!A$1:A$3;B1));Лист2!B$1:B$3);"не найдено")

Автор - AlexM
Дата добавления - 12.03.2018 в 10:36
hbs-group Дата: Понедельник, 12.03.2018, 11:07 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
bmv98rus, AlexM, спасибо огромное!
Отличной и продуктивной вам недели! :)
 
Ответить
Сообщениеbmv98rus, AlexM, спасибо огромное!
Отличной и продуктивной вам недели! :)

Автор - hbs-group
Дата добавления - 12.03.2018 в 11:07
bmv98rus Дата: Понедельник, 12.03.2018, 11:17 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1258
Репутация: 214 ±
Замечаний: 0% ±

Excel 2013/2016
AlexM, что с утра подтупил, Вот сижу думаю, что хотел , для чего индекс , :-)
а, понял, чтоб хоть как то ВПР напоминало :-). На самом деле сперва сделал через Match массивную и первое вхождение, а потом не убрал лишнее
Код
=IFERROR(INDEX(Лист2!$B:$B;MATCH(1=1;ISNUMBER(SEARCH(Лист2!A$1:$A$3;B1));0));"не найдено")
 
Ответить
СообщениеAlexM, что с утра подтупил, Вот сижу думаю, что хотел , для чего индекс , :-)
а, понял, чтоб хоть как то ВПР напоминало :-). На самом деле сперва сделал через Match массивную и первое вхождение, а потом не убрал лишнее
Код
=IFERROR(INDEX(Лист2!$B:$B;MATCH(1=1;ISNUMBER(SEARCH(Лист2!A$1:$A$3;B1));0));"не найдено")

Автор - bmv98rus
Дата добавления - 12.03.2018 в 11:17
AlexM Дата: Понедельник, 12.03.2018, 12:44 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3741
Репутация: 944 ±
Замечаний: 0% ±

Excel 2003
Можно с ВПР(), но получится формула массива
Код
=ЕСЛИОШИБКА(ВПР(1;ЕСЛИ({1;0};НАЙТИ(Лист2!A$1:A$3;B1)^0;Лист2!B$1:B$3);2;);"не найдено")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеМожно с ВПР(), но получится формула массива
Код
=ЕСЛИОШИБКА(ВПР(1;ЕСЛИ({1;0};НАЙТИ(Лист2!A$1:A$3;B1)^0;Лист2!B$1:B$3);2;);"не найдено")

Автор - AlexM
Дата добавления - 12.03.2018 в 12:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР по частичному совпадению (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!