Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Составление расписания уроков - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Составление расписания уроков (Формулы/Formulas)
Составление расписания уроков
Алексей2018 Дата: Четверг, 29.03.2018, 23:10 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый вечер! Нужна помощь в составлении расписания уроков. Суть вот в чем:
имеется лист "Учителя", на нем расписание учителей с понедельника по пятницу (по 7 уроков), с указанием предмета, который он ведет.
имеется лист "5-9", на нем расписание для учащихся с понедельника по пятницу.
Задача такая: как сделать так, чтобы при вводе класса в расписание учителя, предмет, который ведет учитель выводился в расписании для учащихся. Заранее благодарю!
Р.S. файл во вложении
К сообщению приложен файл: __.xls(29.5 Kb)


Сообщение отредактировал Алексей2018 - Четверг, 29.03.2018, 23:11
 
Ответить
СообщениеДобрый вечер! Нужна помощь в составлении расписания уроков. Суть вот в чем:
имеется лист "Учителя", на нем расписание учителей с понедельника по пятницу (по 7 уроков), с указанием предмета, который он ведет.
имеется лист "5-9", на нем расписание для учащихся с понедельника по пятницу.
Задача такая: как сделать так, чтобы при вводе класса в расписание учителя, предмет, который ведет учитель выводился в расписании для учащихся. Заранее благодарю!
Р.S. файл во вложении

Автор - Алексей2018
Дата добавления - 29.03.2018 в 23:10
dude Дата: Пятница, 30.03.2018, 08:56 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 155
Репутация: 22 ±
Замечаний: 0% ±

2016
Код
=ИНДЕКС(Учителя!$B:$B;СУММПРОИЗВ((C$1=СМЕЩ(Учителя!$C$3;;(СЧЁТЗ($A$2:$A2)-1)*7;3;7))*($B2=СМЕЩ(Учителя!$C$2;;(СЧЁТЗ($A$2:$A2)-1)*7;;7))*СТРОКА(Учителя!$B$3:$B$5)))
К сообщению приложен файл: 111.xlsx(11.4 Kb)
 
Ответить
Сообщение
Код
=ИНДЕКС(Учителя!$B:$B;СУММПРОИЗВ((C$1=СМЕЩ(Учителя!$C$3;;(СЧЁТЗ($A$2:$A2)-1)*7;3;7))*($B2=СМЕЩ(Учителя!$C$2;;(СЧЁТЗ($A$2:$A2)-1)*7;;7))*СТРОКА(Учителя!$B$3:$B$5)))

Автор - dude
Дата добавления - 30.03.2018 в 08:56
Pelena Дата: Пятница, 30.03.2018, 08:56 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14321
Репутация: 3131 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Учителя!$B$3:$B$5;ПОИСКПОЗ(1;МУМНОЖ(--((C$1=Учителя!$C$3:$AK$5)*(СТОЛБЕЦ(Учителя!$C$3:$AK$5)-2)=(СТРОКА()-1));ТРАНСП(СТОЛБЕЦ(Учителя!$C$3:$AK$5)^0));0));"")
К сообщению приложен файл: -2-.xls(48.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Учителя!$B$3:$B$5;ПОИСКПОЗ(1;МУМНОЖ(--((C$1=Учителя!$C$3:$AK$5)*(СТОЛБЕЦ(Учителя!$C$3:$AK$5)-2)=(СТРОКА()-1));ТРАНСП(СТОЛБЕЦ(Учителя!$C$3:$AK$5)^0));0));"")

Автор - Pelena
Дата добавления - 30.03.2018 в 08:56
Алексей2018 Дата: Пятница, 30.03.2018, 12:07 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день! Спасибо большое за ответы. А если, учителей больше 3 (около 60), и + учебным днем является суббота, а также классов около 35.
Каким образом нужно внести исправления в формулу, чтобы она работала верно. Заранее спасибо!
К сообщению приложен файл: 5459675.xls(34.5 Kb)
 
Ответить
СообщениеДобрый день! Спасибо большое за ответы. А если, учителей больше 3 (около 60), и + учебным днем является суббота, а также классов около 35.
Каким образом нужно внести исправления в формулу, чтобы она работала верно. Заранее спасибо!

Автор - Алексей2018
Дата добавления - 30.03.2018 в 12:07
dude Дата: Пятница, 30.03.2018, 12:28 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 155
Репутация: 22 ±
Замечаний: 0% ±

2016
Код
=ИНДЕКС(Учителя!$C:$C;СУММПРОИЗВ((C$1=СМЕЩ(Учителя!$D$3;;(СЧЁТЗ($A$2:$A2)-1)*$L$1;$M$1-2;$L$1))*($B2=СМЕЩ(Учителя!$D$2;;(СЧЁТЗ($A$2:$A2)-1)*$L$1;;$L$1))*СТРОКА(ДВССЫЛ("3:"&$M$1))))
К сообщению приложен файл: 0051819.xls(39.0 Kb)
 
Ответить
Сообщение
Код
=ИНДЕКС(Учителя!$C:$C;СУММПРОИЗВ((C$1=СМЕЩ(Учителя!$D$3;;(СЧЁТЗ($A$2:$A2)-1)*$L$1;$M$1-2;$L$1))*($B2=СМЕЩ(Учителя!$D$2;;(СЧЁТЗ($A$2:$A2)-1)*$L$1;;$L$1))*СТРОКА(ДВССЫЛ("3:"&$M$1))))

Автор - dude
Дата добавления - 30.03.2018 в 12:28
Алексей2018 Дата: Пятница, 30.03.2018, 14:51 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena,
Цитата Алексей2018, 30.03.2018 в 12:07, в сообщении № 4 ()
Добрый день! Спасибо большое за ответы. А если, учителей больше 3 (около 60), и + учебным днем является суббота, а также классов около 35.
Каким образом нужно внести исправления в формулу, чтобы она работала верно. Заранее спасибо!
К сообщению приложен файл: 5459675.xls(34.5 Kb)
 
Ответить
СообщениеPelena,
Цитата Алексей2018, 30.03.2018 в 12:07, в сообщении № 4 ()
Добрый день! Спасибо большое за ответы. А если, учителей больше 3 (около 60), и + учебным днем является суббота, а также классов около 35.
Каким образом нужно внести исправления в формулу, чтобы она работала верно. Заранее спасибо!
К сообщению приложен файл: 5459675.xls(34.5 Kb)

Автор - Алексей2018
Дата добавления - 30.03.2018 в 14:51
Pelena Дата: Пятница, 30.03.2018, 15:12 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 14321
Репутация: 3131 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ЕСЛИОШИБКА(ИНДЕКС(Учителя!$B$3:$B$50;ПОИСКПОЗ(1;МУМНОЖ(--((C$1=Учителя!$C$3:$AR$50)*(СТОЛБЕЦ(Учителя!$C$3:$AR$50)-2)=(СТРОКА()-1));ТРАНСП(СТОЛБЕЦ(Учителя!$C$3:$AR$50)^0));0));"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС(Учителя!$B$3:$B$50;ПОИСКПОЗ(1;МУМНОЖ(--((C$1=Учителя!$C$3:$AR$50)*(СТОЛБЕЦ(Учителя!$C$3:$AR$50)-2)=(СТРОКА()-1));ТРАНСП(СТОЛБЕЦ(Учителя!$C$3:$AR$50)^0));0));"")

Автор - Pelena
Дата добавления - 30.03.2018 в 15:12
Алексей2018 Дата: Пятница, 30.03.2018, 15:34 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день! Вставляю формулу в строку, но к сожалению, она не работает
К сообщению приложен файл: 2174112.png(26.3 Kb) · 5905310.png(25.2 Kb)


Сообщение отредактировал Алексей2018 - Пятница, 30.03.2018, 15:52
 
Ответить
СообщениеДобрый день! Вставляю формулу в строку, но к сожалению, она не работает

Автор - Алексей2018
Дата добавления - 30.03.2018 в 15:34
Pelena Дата: Пятница, 30.03.2018, 15:55 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 14321
Репутация: 3131 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Формула массива вводится сочетанием клавиш Ctrl+Shift+Enter


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива вводится сочетанием клавиш Ctrl+Shift+Enter

Автор - Pelena
Дата добавления - 30.03.2018 в 15:55
Алексей2018 Дата: Пятница, 30.03.2018, 16:04 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena,
т.е. при ее вводе в ячейку необходимо сочетание вышеуказанных клавиш?
 
Ответить
СообщениеPelena,
т.е. при ее вводе в ячейку необходимо сочетание вышеуказанных клавиш?

Автор - Алексей2018
Дата добавления - 30.03.2018 в 16:04
Алексей2018 Дата: Пятница, 30.03.2018, 16:07 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, большое спасибо! Все получилось
 
Ответить
СообщениеPelena, большое спасибо! Все получилось

Автор - Алексей2018
Дата добавления - 30.03.2018 в 16:07
krosav4ig Дата: Пятница, 30.03.2018, 23:59 | Сообщение № 12
Группа: Друзья
Ранг: Старожил
Сообщений: 2140
Репутация: 892 ±
Замечаний: 0% ±

Excel 2007,2010,2013
[offtop]
Цитата Алексей2018, 30.03.2018 в 12:07, в сообщении № 4 ()
А если, учителей больше 3 (около 60), и + учебным днем является суббота, а также классов около 35.

то лучше пользовать специализированное ПО (ИМХО)[/offtop]


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщение[offtop]
Цитата Алексей2018, 30.03.2018 в 12:07, в сообщении № 4 ()
А если, учителей больше 3 (около 60), и + учебным днем является суббота, а также классов около 35.

то лучше пользовать специализированное ПО (ИМХО)[/offtop]

Автор - krosav4ig
Дата добавления - 30.03.2018 в 23:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Составление расписания уроков (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!