Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти повторы строчек состоящей из шести ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти повторы строчек состоящей из шести ячеек (Формулы/Formulas)
Найти повторы строчек состоящей из шести ячеек
Totalmen Дата: Суббота, 31.03.2018, 10:38 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброе утро,помогите пожалуйста !!! pray Дана таблица из строчек с шестью ячейками ,одна строка это одно общее данное,так вот надо из таблицы в 15 000 строк найти повторы строк по целым цифрам десятые в расчёт не брать и если повторов нет то можно задать погрешность поиска.Спасибо за помощь.
К сообщению приложен файл: __.xlsx(9.7 Kb)


Сообщение отредактировал Totalmen - Суббота, 31.03.2018, 10:41
 
Ответить
СообщениеДоброе утро,помогите пожалуйста !!! pray Дана таблица из строчек с шестью ячейками ,одна строка это одно общее данное,так вот надо из таблицы в 15 000 строк найти повторы строк по целым цифрам десятые в расчёт не брать и если повторов нет то можно задать погрешность поиска.Спасибо за помощь.

Автор - Totalmen
Дата добавления - 31.03.2018 в 10:38
AlexM Дата: Суббота, 31.03.2018, 12:19 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3762
Репутация: 949 ±
Замечаний: 0% ±

Excel 2003
На примере работает, 15000 строк не проверял
Код
=ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ((--ЛЕВБ($A$3:$F$12;2)>=ЛЕВБ($I$3:$N$3;2)-$H$2)*(--ЛЕВБ($A$3:$F$12;2)<=ЛЕВБ($I$3:$N$3;2)+$H$2);{1:1:1:1:1:1})=6;СТРОКА($A$3:$F$12));СТРОКА(A1)))
К сообщению приложен файл: Totalmen_01.xlsx(12.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеНа примере работает, 15000 строк не проверял
Код
=ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ((--ЛЕВБ($A$3:$F$12;2)>=ЛЕВБ($I$3:$N$3;2)-$H$2)*(--ЛЕВБ($A$3:$F$12;2)<=ЛЕВБ($I$3:$N$3;2)+$H$2);{1:1:1:1:1:1})=6;СТРОКА($A$3:$F$12));СТРОКА(A1)))

Автор - AlexM
Дата добавления - 31.03.2018 в 12:19
Totalmen Дата: Суббота, 31.03.2018, 12:41 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Я правильно понимаю ,что нужно в формуле поменять 12 на 15000 в двух местах?
 
Ответить
СообщениеЯ правильно понимаю ,что нужно в формуле поменять 12 на 15000 в двух местах?

Автор - Totalmen
Дата добавления - 31.03.2018 в 12:41
AlexM Дата: Суббота, 31.03.2018, 12:59 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3762
Репутация: 949 ±
Замечаний: 0% ±

Excel 2003
В трех.
Формула массива вводится тремя клавишами Ctrl+Shift+Enter
В примере решения ошибки скрываются условным форматированием. Можно скрыть функцией ЕСЛИОШИБКА()



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеВ трех.
Формула массива вводится тремя клавишами Ctrl+Shift+Enter
В примере решения ошибки скрываются условным форматированием. Можно скрыть функцией ЕСЛИОШИБКА()

Автор - AlexM
Дата добавления - 31.03.2018 в 12:59
Totalmen Дата: Суббота, 31.03.2018, 15:01 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Извините но при попытке поменять на 15000 строк не чего не работает,это не из за Вас я просто не понимаю что делать((((
 
Ответить
СообщениеИзвините но при попытке поменять на 15000 строк не чего не работает,это не из за Вас я просто не понимаю что делать((((

Автор - Totalmen
Дата добавления - 31.03.2018 в 15:01
AlexM Дата: Суббота, 31.03.2018, 17:34 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3762
Репутация: 949 ±
Замечаний: 0% ±

Excel 2003
Если данные в диапазоне $A$3:$F$12, а вы укажете диапазон $A$3:$F$15000, работать не будет
Диапазон должен быть ограничен первой пустой строкой.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕсли данные в диапазоне $A$3:$F$12, а вы укажете диапазон $A$3:$F$15000, работать не будет
Диапазон должен быть ограничен первой пустой строкой.

Автор - AlexM
Дата добавления - 31.03.2018 в 17:34
Totalmen Дата: Суббота, 31.03.2018, 18:04 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
То есть если у меня 14877 то я должен указать 14878 ,верно?
 
Ответить
СообщениеТо есть если у меня 14877 то я должен указать 14878 ,верно?

Автор - Totalmen
Дата добавления - 31.03.2018 в 18:04
AlexM Дата: Суббота, 31.03.2018, 20:16 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3762
Репутация: 949 ±
Замечаний: 0% ±

Excel 2003
Если 14878 пустая строка, то диапазон $A$3:$F$14877
Вы с первым примером поэкспериментируйте. Измените диапазон $A$3:$F$13 и уже работать не будет.
Вариант формулы, у которой диапазон автоматически подстраивается.
Код
=ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ((--ЛЕВБ($A$3:ИНДЕКС($F:$F;СЧЁТЗ($A$3:$A$19999)+2);2)>=ЛЕВБ($I$3:$N$3;2)-$H$2)*(--ЛЕВБ($A$3:ИНДЕКС($F:$F;СЧЁТЗ($A$3:$A$19999)+2);2)<=ЛЕВБ($I$3:$N$3;2)+$H$2);{1:1:1:1:1:1})=6;СТРОКА($A$3:ИНДЕКС($F:$F;СЧЁТЗ($A$3:$A$19999)+2)));СТРОКА(A1)))
К сообщению приложен файл: Totalmen_02.xlsx(12.3 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Суббота, 31.03.2018, 20:16
 
Ответить
СообщениеЕсли 14878 пустая строка, то диапазон $A$3:$F$14877
Вы с первым примером поэкспериментируйте. Измените диапазон $A$3:$F$13 и уже работать не будет.
Вариант формулы, у которой диапазон автоматически подстраивается.
Код
=ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ((--ЛЕВБ($A$3:ИНДЕКС($F:$F;СЧЁТЗ($A$3:$A$19999)+2);2)>=ЛЕВБ($I$3:$N$3;2)-$H$2)*(--ЛЕВБ($A$3:ИНДЕКС($F:$F;СЧЁТЗ($A$3:$A$19999)+2);2)<=ЛЕВБ($I$3:$N$3;2)+$H$2);{1:1:1:1:1:1})=6;СТРОКА($A$3:ИНДЕКС($F:$F;СЧЁТЗ($A$3:$A$19999)+2)));СТРОКА(A1)))

Автор - AlexM
Дата добавления - 31.03.2018 в 20:16
Totalmen Дата: Суббота, 31.03.2018, 20:34 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Я изменил вроде бы всё ,таблицу увеличил до 22 ,изменил формулу ,но всё равно что то не получается посмотрите пожалуйста,что я делаю не так?
К сообщению приложен файл: Totalmen_01-1-.xlsx(12.7 Kb)
 
Ответить
СообщениеЯ изменил вроде бы всё ,таблицу увеличил до 22 ,изменил формулу ,но всё равно что то не получается посмотрите пожалуйста,что я делаю не так?

Автор - Totalmen
Дата добавления - 31.03.2018 в 20:34
AlexM Дата: Суббота, 31.03.2018, 21:33 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3762
Репутация: 949 ±
Замечаний: 0% ±

Excel 2003
что я делаю не так?

Формула массива вводится тремя клавишами Ctrl+Shift+Enter

При правильном вводе формула обрамляется фигурными скобками, так {=формула}
К сообщению приложен файл: Totalmen_01-2-.xlsx(13.2 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
что я делаю не так?

Формула массива вводится тремя клавишами Ctrl+Shift+Enter

При правильном вводе формула обрамляется фигурными скобками, так {=формула}

Автор - AlexM
Дата добавления - 31.03.2018 в 21:33
Светлый Дата: Суббота, 31.03.2018, 22:28 | Сообщение № 11
Группа: Проверенные
Ранг: Ветеран
Сообщений: 652
Репутация: 176 ±
Замечаний: 0% ±

Excel 2010
Формула массива. Пустые ячейки ошибку не дают, но ошибка будет, если первые два символа не цифры:
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ(--(ABS(ЛЕВБ($I$3:$N$3;2)-(0&ЛЕВБ($A$3:$F$15003;2)))<=$H$2);ТРАНСП($A$2:$F$2))=21;СТРОКА($A$3:$A$15003));СТРОКА(H1)));"")

или
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ(--(ABS(ЛЕВБ($I$3:$N$3;2)-(0&ЛЕВБ($A$3:$F$15003;2)))<=$H$2);{1:1:1:1:1:1})=6;СТРОКА($A$3:$A$15003));СТРОКА(H1)));"")


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Суббота, 31.03.2018, 22:33
 
Ответить
СообщениеФормула массива. Пустые ячейки ошибку не дают, но ошибка будет, если первые два символа не цифры:
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ(--(ABS(ЛЕВБ($I$3:$N$3;2)-(0&ЛЕВБ($A$3:$F$15003;2)))<=$H$2);ТРАНСП($A$2:$F$2))=21;СТРОКА($A$3:$A$15003));СТРОКА(H1)));"")

или
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ(--(ABS(ЛЕВБ($I$3:$N$3;2)-(0&ЛЕВБ($A$3:$F$15003;2)))<=$H$2);{1:1:1:1:1:1})=6;СТРОКА($A$3:$A$15003));СТРОКА(H1)));"")

Автор - Светлый
Дата добавления - 31.03.2018 в 22:28
AlexM Дата: Воскресенье, 01.04.2018, 13:32 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3762
Репутация: 949 ±
Замечаний: 0% ±

Excel 2003
Сергей, мне понравилась идея с ABS() и ноликом. Использую ее в своей формуле
Код
=ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ(Ч(ABS(ЛЕВБ($I$3:$N$3;2)-ЛЕВБ($A$3:$F$99&0;2))<=$H$2);{1:1:1:1:1:1})=6;СТРОКА($A$3:$A$99));СТРОКА(A1)))
К сообщению приложен файл: Totalmen_03.xlsx(12.4 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Воскресенье, 01.04.2018, 13:33
 
Ответить
СообщениеСергей, мне понравилась идея с ABS() и ноликом. Использую ее в своей формуле
Код
=ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ(Ч(ABS(ЛЕВБ($I$3:$N$3;2)-ЛЕВБ($A$3:$F$99&0;2))<=$H$2);{1:1:1:1:1:1})=6;СТРОКА($A$3:$A$99));СТРОКА(A1)))

Автор - AlexM
Дата добавления - 01.04.2018 в 13:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти повторы строчек состоящей из шести ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!