Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос текста в другой столбец по количеству пробелов. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос текста в другой столбец по количеству пробелов. (Формулы/Formulas)
Перенос текста в другой столбец по количеству пробелов.
Donald Дата: Среда, 04.04.2018, 08:32 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Есть текст в одном столбце но в разных строках, перед текстом разное количество пробелов(см.пример) можно ли перенести текст на другой столбец по количеству пробелов перед ним?
[vba]
Код

Дата
    Вид работ
            Основное средство
                    Прицепное устройство
[/vba]
Спасибо.
К сообщению приложен файл: _Microsoft_Exce.xlsx(8.5 Kb)


Сообщение отредактировал Donald - Среда, 04.04.2018, 08:37
 
Ответить
СообщениеЕсть текст в одном столбце но в разных строках, перед текстом разное количество пробелов(см.пример) можно ли перенести текст на другой столбец по количеству пробелов перед ним?
[vba]
Код

Дата
    Вид работ
            Основное средство
                    Прицепное устройство
[/vba]
Спасибо.

Автор - Donald
Дата добавления - 04.04.2018 в 08:32
sboy Дата: Среда, 04.04.2018, 09:30 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1944
Репутация: 564 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Вот такой вариант
Код
=ЕСЛИ(СУММПРОИЗВ(ДЛСТР($B2:B2))=0;ЕСЛИ(ПСТР($A2;1+3*(СТОЛБЕЦ(A2)-1);1)=" ";"";ПРАВБ($A2;ДЛСТР($A2)-3*(СТОЛБЕЦ(A2)-1)));"")

upd.
чуть сократил формулу
Код
=ЕСЛИ(СУММПРОИЗВ(ДЛСТР($B2:B2));"";ЕСЛИ(ПСТР($A2;1+3*(СТОЛБЕЦ(A2)-1);1)=" ";"";СЖПРОБЕЛЫ($A2)))
К сообщению приложен файл: 2357858.xlsx(9.2 Kb)


Сообщение отредактировал sboy - Среда, 04.04.2018, 10:38
 
Ответить
СообщениеДобрый день.
Вот такой вариант
Код
=ЕСЛИ(СУММПРОИЗВ(ДЛСТР($B2:B2))=0;ЕСЛИ(ПСТР($A2;1+3*(СТОЛБЕЦ(A2)-1);1)=" ";"";ПРАВБ($A2;ДЛСТР($A2)-3*(СТОЛБЕЦ(A2)-1)));"")

upd.
чуть сократил формулу
Код
=ЕСЛИ(СУММПРОИЗВ(ДЛСТР($B2:B2));"";ЕСЛИ(ПСТР($A2;1+3*(СТОЛБЕЦ(A2)-1);1)=" ";"";СЖПРОБЕЛЫ($A2)))

Автор - sboy
Дата добавления - 04.04.2018 в 09:30
Donald Дата: Среда, 04.04.2018, 10:29 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо
 
Ответить
СообщениеСпасибо

Автор - Donald
Дата добавления - 04.04.2018 в 10:29
AlexM Дата: Среда, 04.04.2018, 11:16 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3747
Репутация: 946 ±
Замечаний: 0% ±

Excel 2003
sboy, еще чуть короче
Код
=ЕСЛИ(СУММПРОИЗВ(ДЛСТР($B2:B2));"";ЕСЛИ(ПСТР($A2;3*СТОЛБЕЦ(A2)-2;1)=" ";"";СЖПРОБЕЛЫ($A2)))
или
Код
=ЕСЛИ(СУММПРОИЗВ(ДЛСТР($B2:B2))+(ПСТР($A2;3*СТОЛБЕЦ(A2)-2;1)=" ");"";СЖПРОБЕЛЫ($A2))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 04.04.2018, 11:20
 
Ответить
Сообщениеsboy, еще чуть короче
Код
=ЕСЛИ(СУММПРОИЗВ(ДЛСТР($B2:B2));"";ЕСЛИ(ПСТР($A2;3*СТОЛБЕЦ(A2)-2;1)=" ";"";СЖПРОБЕЛЫ($A2)))
или
Код
=ЕСЛИ(СУММПРОИЗВ(ДЛСТР($B2:B2))+(ПСТР($A2;3*СТОЛБЕЦ(A2)-2;1)=" ");"";СЖПРОБЕЛЫ($A2))

Автор - AlexM
Дата добавления - 04.04.2018 в 11:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос текста в другой столбец по количеству пробелов. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!